summaryrefslogtreecommitdiff
path: root/kde-frameworks/kparts/kparts-5.105.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-08 17:32:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-08 17:32:36 +0100
commit02f2b9c649c1687088b6ccb6d30b35f519f107cf (patch)
tree0465ff79d2692a3e01db8bb1ab412adbbf744854 /kde-frameworks/kparts/kparts-5.105.0.ebuild
parent74cd29ea4467291ea2c34971de87d6bdc21233e9 (diff)
gentoo auto-resync : 08:04:2023 - 17:32:35
Diffstat (limited to 'kde-frameworks/kparts/kparts-5.105.0.ebuild')
-rw-r--r--kde-frameworks/kparts/kparts-5.105.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kparts/kparts-5.105.0.ebuild b/kde-frameworks/kparts/kparts-5.105.0.ebuild
new file mode 100644
index 000000000000..cd94c1493b6a
--- /dev/null
+++ b/kde-frameworks/kparts/kparts-5.105.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework providing elaborate user-interface components"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ >=kde-frameworks/ktextwidgets-${PVCUT}:5
+"