summaryrefslogtreecommitdiff
path: root/kde-frameworks/kio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /kde-frameworks/kio/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'kde-frameworks/kio/files')
-rw-r--r--kde-frameworks/kio/files/kio-5.77.0-crashfix.patch29
-rw-r--r--kde-frameworks/kio/files/kio-5.77.0-fix-default-codec-not-usascii-1.patch36
-rw-r--r--kde-frameworks/kio/files/kio-5.77.0-fix-default-codec-not-usascii-2.patch100
-rw-r--r--kde-frameworks/kio/files/kio-5.77.0-gcc11.patch32
-rw-r--r--kde-frameworks/kio/files/kio-5.80.1-fix-crash-in-ThumbnailProtocol.patch104
-rw-r--r--kde-frameworks/kio/files/kio-5.80.1-fix-create-files-on-ftp.patch26
-rw-r--r--kde-frameworks/kio/files/kio-5.81.0-fix-qtconcurrent-private-link.patch46
7 files changed, 176 insertions, 197 deletions
diff --git a/kde-frameworks/kio/files/kio-5.77.0-crashfix.patch b/kde-frameworks/kio/files/kio-5.77.0-crashfix.patch
deleted file mode 100644
index d24a0d976c01..000000000000
--- a/kde-frameworks/kio/files/kio-5.77.0-crashfix.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 9dc9e26b9196111eeacb5609b36957f74f5a14c4 Mon Sep 17 00:00:00 2001
-From: Ismael Asensio <isma.af@gmail.com>
-Date: Tue, 22 Dec 2020 22:23:17 +0100
-Subject: [PATCH] RenameDialog: Add missing nullptr initialization
-
-It fixes a crash when pressing `Apply to All` in those cases where
-the action was not present, as the code checks for nullptr
-
-BUG: 430374
-FIXED-IN: 5.78
----
- src/widgets/renamedialog.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/widgets/renamedialog.cpp b/src/widgets/renamedialog.cpp
-index ac1d91d2..c3e04753 100644
---- a/src/widgets/renamedialog.cpp
-+++ b/src/widgets/renamedialog.cpp
-@@ -161,6 +161,7 @@ public:
- bCancel = nullptr;
- bRename = bSkip = nullptr;
- bOverwrite = nullptr;
-+ bOverwriteWhenOlder = nullptr;
- bResume = bSuggestNewName = nullptr;
- bApplyAll = nullptr;
- m_pLineEdit = nullptr;
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.77.0-fix-default-codec-not-usascii-1.patch b/kde-frameworks/kio/files/kio-5.77.0-fix-default-codec-not-usascii-1.patch
deleted file mode 100644
index 8f589b796aa5..000000000000
--- a/kde-frameworks/kio/files/kio-5.77.0-fix-default-codec-not-usascii-1.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 0a13e0a3e830be2b2b2e5c2c6cf8cef25bd68bd8 Mon Sep 17 00:00:00 2001
-From: Tusooa Zhu <tusooa@vista.aero>
-Date: Thu, 4 Feb 2021 08:36:26 -0500
-Subject: [PATCH] Fix default codec being set to "US-ASCII" in KIO apps
-
-From https://doc.qt.io/qt-5/qloggingcategory.html#Q_LOGGING_CATEGORY-1 :
-"The implicitly-defined QLoggingCategory object is created on first use,
-in a thread-safe manner."
-
-The original way to explicitly define a static QLoggingCategory will lead
-to a call to ucnv_getDefaultName() before QApplication constructor (where
-setlocale() is called), thus making QTextCodec::codecForLocale() misbehave.
-Here we replace the explicit definition with the Q_LOGGING_CATEGORY macro,
-and thus avoid this problem.
-
-BUG: 432406
----
- src/widgets/kdirmodel.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/widgets/kdirmodel.cpp b/src/widgets/kdirmodel.cpp
-index a48ab462..aa049e3d 100644
---- a/src/widgets/kdirmodel.cpp
-+++ b/src/widgets/kdirmodel.cpp
-@@ -36,7 +36,7 @@
- #include <qt_windows.h>
- #endif
-
--static QLoggingCategory category("kf.kio.widgets.kdirmodel", QtInfoMsg);
-+Q_LOGGING_CATEGORY(category, "kf.kio.widgets.kdirmodel", QtInfoMsg)
-
- class KDirModelNode;
- class KDirModelDirNode;
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.77.0-fix-default-codec-not-usascii-2.patch b/kde-frameworks/kio/files/kio-5.77.0-fix-default-codec-not-usascii-2.patch
deleted file mode 100644
index 90f4bb5b0a95..000000000000
--- a/kde-frameworks/kio/files/kio-5.77.0-fix-default-codec-not-usascii-2.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From 423bea37e4bb06b9c04a62a9a91b720ec5d5e3d5 Mon Sep 17 00:00:00 2001
-From: Tusooa Zhu <tusooa@vista.aero>
-Date: Thu, 4 Feb 2021 18:06:23 -0500
-Subject: [PATCH] Use Q_LOGGING_CATEGORY macro instead of explicit
- QLoggingCategory
-
-Explicitly defining a QLoggingCategory will make QTextCodec::codecForLocale()
-misbehave, so we change it to Q_LOGGING_CATEGORY macro.
-
-CCBUG: 432406
----
- src/kpasswdserver/kpasswdserver.cpp | 2 +-
- src/urifilters/ikws/kuriikwsfilter.cpp | 2 +-
- src/urifilters/ikws/kuriikwsfiltereng.cpp | 2 +-
- src/urifilters/ikws/kurisearchfilter.cpp | 2 +-
- src/urifilters/localdomain/localdomainurifilter.cpp | 2 +-
- src/urifilters/shorturi/kshorturifilter.cpp | 2 +-
- 6 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/kpasswdserver/kpasswdserver.cpp b/src/kpasswdserver/kpasswdserver.cpp
-index 4ed73085..a832a0ab 100644
---- a/src/kpasswdserver/kpasswdserver.cpp
-+++ b/src/kpasswdserver/kpasswdserver.cpp
-@@ -28,7 +28,7 @@
- #include <QTimer>
- #include <ctime>
-
--static QLoggingCategory category("kf.kio.kpasswdserver", QtInfoMsg);
-+Q_LOGGING_CATEGORY(category, "kf.kio.kpasswdserver", QtInfoMsg)
-
- #define AUTHINFO_EXTRAFIELD_DOMAIN QStringLiteral("domain")
- #define AUTHINFO_EXTRAFIELD_ANONYMOUS QStringLiteral("anonymous")
-diff --git a/src/urifilters/ikws/kuriikwsfilter.cpp b/src/urifilters/ikws/kuriikwsfilter.cpp
-index 3a516fd8..bbc17678 100644
---- a/src/urifilters/ikws/kuriikwsfilter.cpp
-+++ b/src/urifilters/ikws/kuriikwsfilter.cpp
-@@ -22,7 +22,7 @@
- #define QL1C(x) QLatin1Char(x)
-
- namespace {
--QLoggingCategory category("kf.kio.urifilters.ikws", QtWarningMsg);
-+Q_LOGGING_CATEGORY(category, "kf.kio.urifilters.ikws", QtWarningMsg)
- }
-
- /**
-diff --git a/src/urifilters/ikws/kuriikwsfiltereng.cpp b/src/urifilters/ikws/kuriikwsfiltereng.cpp
-index 5b1bbc48..29647e3e 100644
---- a/src/urifilters/ikws/kuriikwsfiltereng.cpp
-+++ b/src/urifilters/ikws/kuriikwsfiltereng.cpp
-@@ -22,7 +22,7 @@
- #include <QLoggingCategory>
-
- namespace {
--QLoggingCategory category("kf.kio.urifilters.ikws", QtWarningMsg);
-+Q_LOGGING_CATEGORY(category, "kf.kio.urifilters.ikws", QtWarningMsg)
- }
-
- #define PDVAR(n, v) qCDebug(category) << n << " = '" << v << "'"
-diff --git a/src/urifilters/ikws/kurisearchfilter.cpp b/src/urifilters/ikws/kurisearchfilter.cpp
-index a12a9f59..669246c1 100644
---- a/src/urifilters/ikws/kurisearchfilter.cpp
-+++ b/src/urifilters/ikws/kurisearchfilter.cpp
-@@ -26,7 +26,7 @@
- K_PLUGIN_CLASS_WITH_JSON(KUriSearchFilter, "kurisearchfilter.json")
-
- namespace {
--QLoggingCategory category("kf.kio.urifilters.ikws", QtWarningMsg);
-+Q_LOGGING_CATEGORY(category, "kf.kio.urifilters.ikws", QtWarningMsg)
- }
-
- KUriSearchFilter::KUriSearchFilter(QObject *parent, const QVariantList &)
-diff --git a/src/urifilters/localdomain/localdomainurifilter.cpp b/src/urifilters/localdomain/localdomainurifilter.cpp
-index 862419a7..94a53606 100644
---- a/src/urifilters/localdomain/localdomainurifilter.cpp
-+++ b/src/urifilters/localdomain/localdomainurifilter.cpp
-@@ -20,7 +20,7 @@
- #define QL1S(x) QLatin1String(x)
-
- namespace {
--QLoggingCategory category("kf.kio.urifilters.localdomain", QtWarningMsg);
-+Q_LOGGING_CATEGORY(category, "kf.kio.urifilters.localdomain", QtWarningMsg)
- }
-
- /**
-diff --git a/src/urifilters/shorturi/kshorturifilter.cpp b/src/urifilters/shorturi/kshorturifilter.cpp
-index dc866e6c..62d810c4 100644
---- a/src/urifilters/shorturi/kshorturifilter.cpp
-+++ b/src/urifilters/shorturi/kshorturifilter.cpp
-@@ -27,7 +27,7 @@
- #include <KUser>
-
- namespace {
--QLoggingCategory category("kf.kio.urifilters.shorturi", QtWarningMsg);
-+Q_LOGGING_CATEGORY(category, "kf.kio.urifilters.shorturi", QtWarningMsg)
- }
-
- /**
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.77.0-gcc11.patch b/kde-frameworks/kio/files/kio-5.77.0-gcc11.patch
deleted file mode 100644
index 7432364a9864..000000000000
--- a/kde-frameworks/kio/files/kio-5.77.0-gcc11.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 9965ec1b9e6f6db192a2355e4e3eb80bc27fc092 Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Sun, 24 Jan 2021 11:10:27 +0200
-Subject: [PATCH] Fix build with gcc11
-
-Apparently now we need to #include <limit>.
-
-Patch by Geoff Leach:
-https://bugs.gentoo.org/766480
-https://invent.kde.org/frameworks/kio/-/issues/3
-
-NO_CHANGELOG
----
- src/kntlm/des.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/kntlm/des.cpp b/src/kntlm/des.cpp
-index 18d85bfd..65c86f06 100644
---- a/src/kntlm/des.cpp
-+++ b/src/kntlm/des.cpp
-@@ -29,6 +29,8 @@
- #include <string.h>
- #include <qendian.h>
-
-+#include <limits>
-+
- static void permute_ip(unsigned char *inblock, DES_KEY *key, unsigned char *outblock);
- static void permute_fp(unsigned char *inblock, DES_KEY *key, unsigned char *outblock);
- static void perminit_ip(DES_KEY *key);
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.80.1-fix-crash-in-ThumbnailProtocol.patch b/kde-frameworks/kio/files/kio-5.80.1-fix-crash-in-ThumbnailProtocol.patch
new file mode 100644
index 000000000000..059c9f824241
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.80.1-fix-crash-in-ThumbnailProtocol.patch
@@ -0,0 +1,104 @@
+From a68cb73c4e071ed24b18a95e11fbbbc8d59840b4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?M=C3=A9ven=20Car?= <meven29@gmail.com>
+Date: Sun, 21 Mar 2021 05:22:57 +0100
+Subject: [PATCH] PreviewJob: Initialize cachesSize with 0, only pass size > 0
+ to shmget, improve createThumbnail
+
+BUG: 430862
+---
+ src/widgets/previewjob.cpp | 48 +++++++++++++++++++++++---------------
+ 1 file changed, 29 insertions(+), 19 deletions(-)
+
+diff --git a/src/widgets/previewjob.cpp b/src/widgets/previewjob.cpp
+index 988da16b0..9b6e661e8 100644
+--- a/src/widgets/previewjob.cpp
++++ b/src/widgets/previewjob.cpp
+@@ -70,7 +70,7 @@ public:
+ : initialItems(items)
+ , width(size.width())
+ , height(size.height())
+- , cacheSize(-1)
++ , cacheSize(0)
+ , bScale(true)
+ , bSave(true)
+ , ignoreMaximumSize(false)
+@@ -114,8 +114,8 @@ public:
+ // Size of thumbnail
+ int width;
+ int height;
+- // Unscaled size of thumbnail (128 or 256 if cache is enabled)
+- int cacheSize;
++ // Unscaled size of thumbnail (128, 256 or 512 if cache is enabled)
++ ushort cacheSize;
+ // Whether the thumbnail should be scaled
+ bool bScale;
+ // Whether we should save the thumbnail
+@@ -712,39 +712,49 @@ void PreviewJobPrivate::createThumbnail(const QString &pixPath)
+ });
+
+ bool save = bSave && currentItem.plugin->property(QStringLiteral("CacheThumbnail")).toBool() && !sequenceIndex;
++ int thumb_width = width;
++ int thumb_height = height;
++ int thumb_iconSize = iconSize;
++ if (save) {
++ thumb_width = thumb_height = cacheSize;
++ thumb_iconSize = 64;
++ }
++
+ job->addMetaData(QStringLiteral("mimeType"), currentItem.item.mimetype());
+- job->addMetaData(QStringLiteral("width"), QString().setNum(save ? cacheSize : width));
+- job->addMetaData(QStringLiteral("height"), QString().setNum(save ? cacheSize : height));
+- job->addMetaData(QStringLiteral("iconSize"), QString().setNum(save ? 64 : iconSize));
+- job->addMetaData(QStringLiteral("iconAlpha"), QString().setNum(iconAlpha));
++ job->addMetaData(QStringLiteral("width"), QString::number(thumb_width));
++ job->addMetaData(QStringLiteral("height"), QString::number(thumb_height));
++ job->addMetaData(QStringLiteral("iconSize"), QString::number(thumb_iconSize));
++ job->addMetaData(QStringLiteral("iconAlpha"), QString::number(iconAlpha));
+ job->addMetaData(QStringLiteral("plugin"), currentItem.plugin->library());
+ job->addMetaData(QStringLiteral("enabledPlugins"), enabledPlugins.join(QLatin1Char(',')));
+ job->addMetaData(QStringLiteral("devicePixelRatio"), QString::number(devicePixelRatio));
+ if (sequenceIndex) {
+- job->addMetaData(QStringLiteral("sequence-index"), QString().setNum(sequenceIndex));
++ job->addMetaData(QStringLiteral("sequence-index"), QString::number(sequenceIndex));
+ }
+
+ #if WITH_SHM
+ if (shmid == -1) {
+ if (shmaddr) {
++ // clean previous shared memory segment
+ shmdt((char *)shmaddr);
+ shmctl(shmid, IPC_RMID, nullptr);
++ shmaddr = nullptr;
+ }
+- auto size = std::max(cacheSize * cacheSize, width * height);
+- shmid = shmget(IPC_PRIVATE, size * 4 * devicePixelRatio * devicePixelRatio, IPC_CREAT | 0600);
+- if (shmid != -1) {
+- shmaddr = (uchar *)(shmat(shmid, nullptr, SHM_RDONLY));
+- if (shmaddr == (uchar *)-1) {
+- shmctl(shmid, IPC_RMID, nullptr);
+- shmaddr = nullptr;
+- shmid = -1;
++ auto size = thumb_width * thumb_height;
++ if (size > 0) {
++ shmid = shmget(IPC_PRIVATE, size * 4 * devicePixelRatio * devicePixelRatio, IPC_CREAT | 0600);
++ if (shmid != -1) {
++ shmaddr = (uchar *)(shmat(shmid, nullptr, SHM_RDONLY));
++ if (shmaddr == (uchar *)-1) {
++ shmctl(shmid, IPC_RMID, nullptr);
++ shmaddr = nullptr;
++ shmid = -1;
++ }
+ }
+- } else {
+- shmaddr = nullptr;
+ }
+ }
+ if (shmid != -1) {
+- job->addMetaData(QStringLiteral("shmid"), QString().setNum(shmid));
++ job->addMetaData(QStringLiteral("shmid"), QString::number(shmid));
+ }
+ #endif
+ }
+--
+GitLab
+
diff --git a/kde-frameworks/kio/files/kio-5.80.1-fix-create-files-on-ftp.patch b/kde-frameworks/kio/files/kio-5.80.1-fix-create-files-on-ftp.patch
new file mode 100644
index 000000000000..cece00965294
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.80.1-fix-create-files-on-ftp.patch
@@ -0,0 +1,26 @@
+From 71c7420e4b33b4bace8ed6d4fa45fa5e281d38bd Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?M=C3=A9ven=20Car?= <meven.car@enioka.com>
+Date: Sat, 27 Mar 2021 11:00:07 +0100
+Subject: [PATCH] KNewFileMenu: use destination side to stat destination
+
+BUG: 429541
+---
+ src/filewidgets/knewfilemenu.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/filewidgets/knewfilemenu.cpp b/src/filewidgets/knewfilemenu.cpp
+index 64c4b1c2e..48fdf8622 100644
+--- a/src/filewidgets/knewfilemenu.cpp
++++ b/src/filewidgets/knewfilemenu.cpp
+@@ -1242,7 +1242,7 @@ void KNewFileMenuPrivate::_k_slotTextChanged(const QString &text)
+ } else {
+ url = QUrl(m_baseUrl.toString() + QLatin1Char('/') + text);
+ }
+- KIO::StatJob *job = KIO::statDetails(url, KIO::StatJob::StatSide::SourceSide, KIO::StatDetail::StatBasic);
++ KIO::StatJob *job = KIO::statDetails(url, KIO::StatJob::StatSide::DestinationSide, KIO::StatDetail::StatBasic);
+ QObject::connect(job, &KJob::result, q, [this](KJob *job) {
+ _k_slotStatResult(job);
+ });
+--
+GitLab
+
diff --git a/kde-frameworks/kio/files/kio-5.81.0-fix-qtconcurrent-private-link.patch b/kde-frameworks/kio/files/kio-5.81.0-fix-qtconcurrent-private-link.patch
new file mode 100644
index 000000000000..42637cd6e1e7
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.81.0-fix-qtconcurrent-private-link.patch
@@ -0,0 +1,46 @@
+From e6825658b7f59a3a933559def9aebf21ff0efb7f Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 23 Apr 2021 20:10:31 +0200
+Subject: [PATCH] Drop find_dependency(Qt5Concurrent) from
+ KF5KIOConfig.cmake.in
+
+This was added in 2f83dde2c8e8a25f0fe3dd52012bb49cb69e1ea5 but as far as I can
+see it is only a KIO build time dependency with no Qt5Concurrent header being
+used in KIO headers.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ KF5KIOConfig.cmake.in | 1 -
+ src/core/CMakeLists.txt | 2 +-
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/KF5KIOConfig.cmake.in b/KF5KIOConfig.cmake.in
+index 687ec512..749e9b9b 100644
+--- a/KF5KIOConfig.cmake.in
++++ b/KF5KIOConfig.cmake.in
+@@ -21,7 +21,6 @@ find_dependency(KF5WindowSystem "@KF_DEP_VERSION@")
+ endif()
+
+ find_dependency(Qt5Network "@REQUIRED_QT_VERSION@")
+-find_dependency(Qt5Concurrent "@REQUIRED_QT_VERSION@")
+ find_dependency(Qt5DBus "@REQUIRED_QT_VERSION@")
+
+ include("${CMAKE_CURRENT_LIST_DIR}/KF5KIOTargets.cmake")
+diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
+index 76c3061c..fe4be56b 100644
+--- a/src/core/CMakeLists.txt
++++ b/src/core/CMakeLists.txt
+@@ -188,9 +188,9 @@ PUBLIC
+ KF5::CoreAddons # KJob
+ KF5::Service # TODO KF6 move to PRIVATE
+ Qt5::Network
+- Qt5::Concurrent # QtConcurrentRun in hostinfo.cpp
+ Qt5::DBus
+ PRIVATE
++ Qt5::Concurrent # QtConcurrentRun in hostinfo.cpp
+ Qt5::Xml # davjob.cpp uses QDom
+ KF5::ConfigCore
+ KF5::I18n
+--
+2.31.1
+