summaryrefslogtreecommitdiff
path: root/kde-frameworks/kdesu/kdesu-5.84.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /kde-frameworks/kdesu/kdesu-5.84.0.ebuild
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.84.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.84.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.84.0.ebuild b/kde-frameworks/kdesu/kdesu-5.84.0.ebuild
new file mode 100644
index 000000000000..f80367b7e219
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.84.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+inherit ecm kde.org
+
+DESCRIPTION="Framework to handle super user actions"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kpty-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}