summaryrefslogtreecommitdiff
path: root/kde-frameworks/kdesu/kdesu-5.104.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-12 00:09:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-12 00:09:22 +0000
commit8fa69fdd0836c0b856dd0f9ef77d5fb25df844ec (patch)
tree5b2388d462e1ce30c6c01d22c809fab8b5beee8f /kde-frameworks/kdesu/kdesu-5.104.0.ebuild
parent23650861e24563ddcf10919ab5b1912676c3ff0c (diff)
gentoo auto-resync : 12:03:2023 - 00:09:21
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.104.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.104.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.104.0.ebuild b/kde-frameworks/kdesu/kdesu-5.104.0.ebuild
new file mode 100644
index 000000000000..d5ebea58648d
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.104.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to handle super user actions"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="X"
+
+RDEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kpty-${PVCUT}*:5
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}