summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcrash/kcrash-5.95.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /kde-frameworks/kcrash/kcrash-5.95.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.95.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.95.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.95.0.ebuild b/kde-frameworks/kcrash/kcrash-5.95.0.ebuild
new file mode 100644
index 000000000000..1436cd29ba71
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.95.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="nls X"
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_X11=$(usex X)
+ )
+ ecm_src_configure
+}