summaryrefslogtreecommitdiff
path: root/kde-frameworks/kconfig/kconfig-5.85.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /kde-frameworks/kconfig/kconfig-5.85.0.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'kde-frameworks/kconfig/kconfig-5.85.0.ebuild')
-rw-r--r--kde-frameworks/kconfig/kconfig-5.85.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-frameworks/kconfig/kconfig-5.85.0.ebuild b/kde-frameworks/kconfig/kconfig-5.85.0.ebuild
new file mode 100644
index 000000000000..c03101c447be
--- /dev/null
+++ b/kde-frameworks/kconfig/kconfig-5.85.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for reading and writing configuration"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="dbus nls"
+
+# bug 560086
+RESTRICT+=" test"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ dbus? ( >=dev-qt/qtdbus-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtconcurrent-${QTMIN}:5 )
+"
+
+DOCS=( DESIGN docs/{DESIGN.kconfig,options.md} )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ -DKCONFIG_USE_DBUS=$(usex dbus)
+ )
+ ecm_src_configure
+}