summaryrefslogtreecommitdiff
path: root/kde-frameworks/kconfig/kconfig-5.51.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /kde-frameworks/kconfig/kconfig-5.51.0.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'kde-frameworks/kconfig/kconfig-5.51.0.ebuild')
-rw-r--r--kde-frameworks/kconfig/kconfig-5.51.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-frameworks/kconfig/kconfig-5.51.0.ebuild b/kde-frameworks/kconfig/kconfig-5.51.0.ebuild
new file mode 100644
index 000000000000..fb5f9b2dd01f
--- /dev/null
+++ b/kde-frameworks/kconfig/kconfig-5.51.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for reading and writing configuration"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtxml)
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ test? ( $(add_qt_dep qtconcurrent) )
+"
+
+# bug 560086
+RESTRICT+=" test"
+
+DOCS=( DESIGN docs/DESIGN.kconfig docs/options.md )