summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcompletion/kcompletion-5.54.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /kde-frameworks/kcompletion/kcompletion-5.54.0.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'kde-frameworks/kcompletion/kcompletion-5.54.0.ebuild')
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.54.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/kcompletion-5.54.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.54.0.ebuild
new file mode 100644
index 000000000000..28bc1e950976
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.54.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"