summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /kde-frameworks/frameworkintegration
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest2
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.61.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index ea6b4b38e042..b57058c7a0f8 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,3 +1,5 @@
DIST frameworkintegration-5.60.0.tar.xz 1753424 BLAKE2B f0752ba701ad1bc3c447f1d7c17ab22b922efc570bf6ef84c51ef58ee9e3f32f68f0ef222c88991252db60a0b0e63cdec672b20b693807d50b3bed2b1b7c95b3 SHA512 4313e31789046e49d644a8613c0274c44f15ce7bfdee1e66240a1cbf6c625eba093fa0a2d922833a336c208aa75af8c949d0881bd17efe2c1007045d3a9288a5
+DIST frameworkintegration-5.61.0.tar.xz 1753264 BLAKE2B 3db63e29c65ed49df7140f9cc058044ff9f78ee12221447843d5d5b1b6d4063d18f3c099221788af35ee6dd946a22fb43a265370561cbadff2476c4b97adf692 SHA512 9781e1d977713b2c7e604a30bb35a53e33f85002755d03615d501db101ac7ce718fcd50a83510f17806462998ddc11a88d38083d43a8a645643010ed17b06057
EBUILD frameworkintegration-5.60.0.ebuild 1135 BLAKE2B 8b7aa45b3ea719b04168306c34ab1583b33a4601b1299423e227bf6d8084bcc9d7c69b5924de7031e8ce7021d1e4e053472172ef6f1394e49f1b3a0d126d62ab SHA512 08726481436220befa39a27e91dde2a85b65c4ce40159b3a936bbd55dab139192dadd3239672a36764b0a82da15d5e8c12c97273082d2e67d5110918865a939d
+EBUILD frameworkintegration-5.61.0.ebuild 1138 BLAKE2B 759bcccee4241b7924f6d8cd62fe02200be17a2dffffc0ff676ad49192c934e38b08d7956875a1b37d7aba28c7c050c752d4cb8bf90a32f4c54a5af2182e6254 SHA512 93ec5f372790e1e95f6a63efc94aba099237f68f10617337189fb3cc510f067aad304dd978238446d8ad7dc36c6e6a1a4bfdbec6a29aae6434e3abfddc99d512
MISC metadata.xml 339 BLAKE2B 9adff6fc4d48a8e94cd7701e7a3b956963b25af1538793345846c70186d7536597bcd9a1cac92b292220de5d6c2562864b64556c36cd579041b567d970db6828 SHA512 cf6eaaca36d7a193361608ad80cd1a4e79f71952926fb01c8905879422c91d38d6988e473a14960437491e5b43d227497500b79ff3696f0d96cbc1b69f9165c1
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.61.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.61.0.ebuild
new file mode 100644
index 000000000000..abb6426a7b47
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.61.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}