summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-14 14:25:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-14 14:25:52 +0100
commita6b284ce6cc4682e2f879616e915f11774a183ac (patch)
tree53c864b622355c5dd667a6822e3c280dcfbad76a /kde-frameworks/frameworkintegration
parent53b3135150fc3b8f4831f8cc9d83276228e94916 (diff)
gentoo auto-resync : 14:08:2022 - 14:25:52
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest2
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.97.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 88631232b8d7..7d22fa9e962a 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,3 +1,5 @@
DIST frameworkintegration-5.96.0.tar.xz 1759604 BLAKE2B 24d4806432487e35e01645da97195f700e086c68c6d2f39e7e5e86d00f10a982224fff2fa2eb7d7808fadad4d7524fd2318f67f8d47759e2533a261aa8589470 SHA512 cdc521ff7ba5d3c37d239fb7575a8c1e5b66b1bcba9e315da857b3ddd25b9a7cabc3dc0338186b23b9606badef7c7153c117b92618b626eb54b95c540cc2e680
+DIST frameworkintegration-5.97.0.tar.xz 1759588 BLAKE2B 2165bedee7866dfe2b08313af0a77339a7f7a1ec3ba77d30dcc5346af6023786a34a0d14499ab50923d5989fd94187941ca26442e04340c327bdcc637ab31210 SHA512 5b6a4f562183c4cda5c068786b14db22508af0ea535cf6a03e5502834196a6393a43def590fea1ee8562cb7f3bbc2c69722d459225b0128a593f32ba486a5e51
EBUILD frameworkintegration-5.96.0.ebuild 1014 BLAKE2B ed55d31a00b712dd30882ca1ad3e5e4262e7559ef51f7bd044f51ff9d70b5c5ad7ffae3798251b96c1ac8d61ec69dac8163b9786bb1faca6448efc3e1edecc9d SHA512 8807fc741dda37a54f9a8d6d92f45b49840f44b8fb82959c406c854250244be00106ee94a46d731789758c05f6b78e93c643a4e2cf96234b01f866a27a821c08
+EBUILD frameworkintegration-5.97.0.ebuild 1017 BLAKE2B 36eac1d37121f244a07865301c43357addfc173101845c2105d37562b6ffc36f6964934cbe13a29062571ce4a79942f8efdbc314fcfe51cab445c7d9e63ab95c SHA512 74144c1705cb05dcfe0b397506d3d40a80028d07c40cccfd6c0e4d0ee1f0e67b0cf60b27d8ae123e7622cb18c7313a6db017ccd886c3cdda2abfdbf61969d2c0
MISC metadata.xml 456 BLAKE2B 4392b1cc6f304778d71236d5eb557dfbbd530143eea5cad9a3c3034e3e8b22c835f6c7f980124a21cefd35a2dd1efd5110adc0a5342170f88dfd7418b12bee99 SHA512 7ba65331cad434e2dceee012a5458d268eb2a04e0f7276b265c15644e6db5209bc7eee7d9695aa0038c435711e0f6f0dc53c7bae9d773b48f01e22a22e4dbb80
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.97.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.97.0.ebuild
new file mode 100644
index 000000000000..e4e34fce95e5
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.97.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}