summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 18:04:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 18:04:20 +0100
commita1e66b29f226eb6b6509b18ffbe5b1134b3dcaa4 (patch)
tree36e2324007bc1ee88f2e2f929f0a1614478b3df0 /kde-frameworks/frameworkintegration
parent2719f73b6813d11d13a9650cdd2ab8ec6e69385d (diff)
gentoo auto-resync : 09:07:2022 - 18:04:20
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest2
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.96.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 7e7e1dc5c29a..2652ed3ac9bf 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,5 +1,7 @@
DIST frameworkintegration-5.92.0.tar.xz 1758268 BLAKE2B 7f72908f93158f42c2e90488aa037bb7dd9146e333b504a9034c8b5c6898fb5a6357a62fc81c237f8be9b854d05c97ce4352d28aa4f28ba1674d26b0098c7e41 SHA512 3445749f4ee10493a798433a7b5630dc22701c98c3f81c7e2236cffea9f9576ce8123006e5123698e5d648771ea77bff848453b188b1a6e791aab08184cebecc
DIST frameworkintegration-5.95.0.tar.xz 1758292 BLAKE2B 54588bd57289f2b42dcadc230257d031345b0d0cbce5bf674547431b654be418e209aac2692e693e64c86175b0a08cc01ad97294cad7dfcb65c918411d47e695 SHA512 a6fbc2bdeac9a3e2aecf0b6e2bfa0169b36e02d03665758230abc2497015a1540d33e58cb0283ec8333713debb58289deb423a679f726e041ada2d325833d743
+DIST frameworkintegration-5.96.0.tar.xz 1759604 BLAKE2B 24d4806432487e35e01645da97195f700e086c68c6d2f39e7e5e86d00f10a982224fff2fa2eb7d7808fadad4d7524fd2318f67f8d47759e2533a261aa8589470 SHA512 cdc521ff7ba5d3c37d239fb7575a8c1e5b66b1bcba9e315da857b3ddd25b9a7cabc3dc0338186b23b9606badef7c7153c117b92618b626eb54b95c540cc2e680
EBUILD frameworkintegration-5.92.0.ebuild 996 BLAKE2B d2f05b2db8e364c0da4b2b4e007df850778ef1d771f5ac98b631237ea2e434347dafcac288ca9dc1872b6382bb5be54ca9a71367f35db26a0d37e287e1d880d0 SHA512 998406eadf4c6218e2984165dbcc36667b19735440f9e11e581dce33251d11e861e60328a45b1e44100b2c8e07d92e59837d54d80f452972b06694ed1bdc5113
EBUILD frameworkintegration-5.95.0.ebuild 1006 BLAKE2B 6818de7ba56ffdc02242eb204b21501a1c492308f08cdde4059178638e064d6beeca5f72da2a7782267417d7f34dd1c14c963cdd80fb0702a43fdd15e570568a SHA512 23e15cce9482d6c55ed18b4771a79a72f70e1393a70bf8c83da6a064f73405aad1ef254d90a3e3e2bf2656026d6304dd73dd02aab8a51d2306dff1208c73e8e8
+EBUILD frameworkintegration-5.96.0.ebuild 1006 BLAKE2B 67478b730b9636549f9f14a093f9e1bc547324a14279bc4901f7dd8ed08bda288ded1e5eb7e340ecc11ae3cf5500ef3426f462e6d67807d7b4d0350380dde2f8 SHA512 110efc2051a25a1d510d7e6fec9b66b30cccb0380004edafe260339cf2107f6e8921cd056cf775693994a76d108332c2b4bc13f681a524b8582b8cb6e312f648
MISC metadata.xml 456 BLAKE2B 4392b1cc6f304778d71236d5eb557dfbbd530143eea5cad9a3c3034e3e8b22c835f6c7f980124a21cefd35a2dd1efd5110adc0a5342170f88dfd7418b12bee99 SHA512 7ba65331cad434e2dceee012a5458d268eb2a04e0f7276b265c15644e6db5209bc7eee7d9695aa0038c435711e0f6f0dc53c7bae9d773b48f01e22a22e4dbb80
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.96.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.96.0.ebuild
new file mode 100644
index 000000000000..e496a1e09d6c
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.96.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.4
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}