summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /kde-frameworks/frameworkintegration
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest2
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.84.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 8ed58a722590..09c060244866 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,5 +1,7 @@
DIST frameworkintegration-5.82.0.tar.xz 1755828 BLAKE2B 18c056daf8db8e06995d3f0b6985f9aabb05e8a4e7323635faf92701f04dbf135cf63221fe739504d2ccd7718dd02a6718ab7fa7ba84b86cb37394ff878b6e3f SHA512 5865e560789c50829c5648365db58497d0da141d1699f396ca431740e6f919ef68c89e2cb98ac1f320cdb07fae098de683b17c920f79a2b459ffd874935b6e77
DIST frameworkintegration-5.83.0.tar.xz 1755808 BLAKE2B 6ea18cc46ade635f0ab1641318fb123b510e8dce1b0482c678d94556f10438de04ab780fa857c1363b87c5e72b7005d834defa75cff7ccfa1b31e4fef0235ef8 SHA512 a95380a3f13082345223e8aee070367ace9b54e54470847afa0c9ff8894788b91b31d4988ce5a432b0020b9c22fbc90a0eca6b1a5f6867ef7156e47a8f42739c
+DIST frameworkintegration-5.84.0.tar.xz 1755824 BLAKE2B 97782740521c7d6794a5f3063c4f2bea54f25d665857f7cabe8b67eb67d46ba26f8277d630cf1af71cc07c0342a36c25ae71fa1f7b0752f62aa2607291b6f7c7 SHA512 eb226600a1c17ebb9387eb42b212b6d2397f118ce2c52ba2463e8c8acf62b39f96aafe68573b9474bf4c0a13d6542bcadcb35ff4c8880425d448838630ea179f
EBUILD frameworkintegration-5.82.0.ebuild 991 BLAKE2B a2504a4055a05297517cb5ff6335d97d05fd77f811b49beb7e13cc917593e068ae061d17f1a3d383fe6115062622fd44bc719128ca9d2cc4808eeaea80c894d2 SHA512 0f3288378838ab2dc3c0dfe880343f132aa54f2f52a0aae6b23fa50181e609f0e381897aecf8e5b5256b9f307fbd5901f5e2f96421158f642b224c06e1731aeb
EBUILD frameworkintegration-5.83.0.ebuild 994 BLAKE2B c5af19730aa8f772d3fd4235c1b100a0470efad3fa2514e5acb920c671d11657e226b3c7938082fa356d86fe58ca732002a13ab7ac36c7810ceb96c8d8c56119 SHA512 4bac1d77b8b1797debb25dc0e2761d1bad5d0800800024f2e89bebb55a8735a4151a2657b631d56d4e41360127cde7271ac8b9660e8018989a884303c9f73845
+EBUILD frameworkintegration-5.84.0.ebuild 994 BLAKE2B c5af19730aa8f772d3fd4235c1b100a0470efad3fa2514e5acb920c671d11657e226b3c7938082fa356d86fe58ca732002a13ab7ac36c7810ceb96c8d8c56119 SHA512 4bac1d77b8b1797debb25dc0e2761d1bad5d0800800024f2e89bebb55a8735a4151a2657b631d56d4e41360127cde7271ac8b9660e8018989a884303c9f73845
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.84.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.84.0.ebuild
new file mode 100644
index 000000000000..8fbf5abdb53b
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.84.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}