summaryrefslogtreecommitdiff
path: root/kde-frameworks/frameworkintegration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
commit20e7188871e6d724b707132f925b9872536a91a0 (patch)
tree1b8d527714db0a937011ad650939d9152d36506c /kde-frameworks/frameworkintegration
parente4769acf6646f4b0ef28cb695cec8ed128aba920 (diff)
gentoo auto-resync : 15:12:2023 - 20:53:45
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest2
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.113.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 1b69b2c024f3..987a49427322 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,3 +1,5 @@
DIST frameworkintegration-5.112.0.tar.xz 1760464 BLAKE2B 34b68a38078faa452359921c688f4c83474c45e746badb9dd1cbdfe378268bb71b342c88761ea277c4837b5de64f0e3a417654836561385fce36eaa02ce6895e SHA512 515b6f17d6de666084b27f7d91dafbfc7e4fb704ec22a98763350976de73bbfcc215eaf0373c843ff709981b3e631f23a99c7db1bd275506bfa8d5a8649e223a
+DIST frameworkintegration-5.113.0.tar.xz 1760432 BLAKE2B f8289c33889cf8bafd51b1db44efba93d9b580a9cd69be69e2fadd957a2db728d0c981da5af4c8b4be264fc3af8b7b44d6be0e144dc2a596a601cfc35f1d6274 SHA512 a9fe7a6c262482cb8b8d392064f66413a03d2bd031263470b0bbef1466bc18749d874d93c4c637958fecc72d7ec9273eabb3d48a0d7c457533c1ea7caf419e90
EBUILD frameworkintegration-5.112.0.ebuild 989 BLAKE2B cf3471cdd526e7d071d07caa98b4a9af48bb2a5b0b182e40d7914d9fd2757b247c8d78c5946dc7bed43ecfd8e90e906a99148c3dc02c5867fac686f72af049ec SHA512 9bd8ab560a80b24e932476f88d81fbca4451492617e072750171f730f724b273315a5569d3501764681b676ba3458c5bdcc2be993d1745f5cd89a9c6b098c8d0
+EBUILD frameworkintegration-5.113.0.ebuild 992 BLAKE2B ad364b29c40605118774eabb5fa706d55f79a0e340d6266d74b18785be88f50890a974a11300e5bd08ea86fc3a2eb3e2e470c64f8affb84f0ef0402791b4b8e5 SHA512 6874a3ff194d35f45f62ccc40d62b25508f511b08764778cd49aeb8e5dd37a8a674c85d09371eb713f78615736d8a7d90c3f8dc4e9c6aefb9daf6a59912af50f
MISC metadata.xml 456 BLAKE2B 4392b1cc6f304778d71236d5eb557dfbbd530143eea5cad9a3c3034e3e8b22c835f6c7f980124a21cefd35a2dd1efd5110adc0a5342170f88dfd7418b12bee99 SHA512 7ba65331cad434e2dceee012a5458d268eb2a04e0f7276b265c15644e6db5209bc7eee7d9695aa0038c435711e0f6f0dc53c7bae9d773b48f01e22a22e4dbb80
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.113.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.113.0.ebuild
new file mode 100644
index 000000000000..36b3122c1d84
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.113.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}