summaryrefslogtreecommitdiff
path: root/kde-frameworks/countryflags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /kde-frameworks/countryflags
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'kde-frameworks/countryflags')
-rw-r--r--kde-frameworks/countryflags/Manifest4
-rw-r--r--kde-frameworks/countryflags/countryflags-5.90.0.ebuild22
-rw-r--r--kde-frameworks/countryflags/files/countryflags-5.90.0-standalone.patch31
-rw-r--r--kde-frameworks/countryflags/metadata.xml16
4 files changed, 73 insertions, 0 deletions
diff --git a/kde-frameworks/countryflags/Manifest b/kde-frameworks/countryflags/Manifest
new file mode 100644
index 000000000000..9d03a5fb4820
--- /dev/null
+++ b/kde-frameworks/countryflags/Manifest
@@ -0,0 +1,4 @@
+AUX countryflags-5.90.0-standalone.patch 1953 BLAKE2B 556973d44e147efeecd3080fb8165c00e0f9cd3f37933d9761b8c5c5fb7549553208e44a7b121b78813a64937a44253446604d3a038dff7d0e59dc1fab65ac3a SHA512 13f8883f955bc49a75d05949584da05b7886bf280e70d3808e7fbcaf02f9b15779aa4b6a0e3a2c3372d6b801d415bdd7fb9a8b169bc381e541734343fa74c3e8
+DIST kdelibs4support-5.90.0.tar.xz 3644376 BLAKE2B f5ff38c515a0455e702acada733bca8e0de74b550e9a1a828bc928084bfdb27a8ec0f50b02f8b664fe63f07091e071c3a458e8f93fe0246431f6765c234fd343 SHA512 0636a0ba6fc4a3993068a1aa0422d6de6c3b732bc165b329cbc37f19ba29fe06306dc1017e32f36fc89911661674fb78e3be0a2e792551ee513861557fde6553
+EBUILD countryflags-5.90.0.ebuild 550 BLAKE2B b06294fc553233d224a89d33910710e611f0f80c47d66912e93134cc26af77e35d76e5df757462c10c2b2a74b575321e1dca120bd1eab990fbaeab55d47f178f SHA512 b2be1eb7572cc869278c04dd6ed5d820666b7f55bfc1a631821e6f857b0e4fc60fd9fd797127b3deb96c06babd02ca1dcfb6225dcf6a0e560c08185a3dbddb7a
+MISC metadata.xml 456 BLAKE2B 4392b1cc6f304778d71236d5eb557dfbbd530143eea5cad9a3c3034e3e8b22c835f6c7f980124a21cefd35a2dd1efd5110adc0a5342170f88dfd7418b12bee99 SHA512 7ba65331cad434e2dceee012a5458d268eb2a04e0f7276b265c15644e6db5209bc7eee7d9695aa0038c435711e0f6f0dc53c7bae9d773b48f01e22a22e4dbb80
diff --git a/kde-frameworks/countryflags/countryflags-5.90.0.ebuild b/kde-frameworks/countryflags/countryflags-5.90.0.ebuild
new file mode 100644
index 000000000000..84058dd8fffc
--- /dev/null
+++ b/kde-frameworks/countryflags/countryflags-5.90.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="false"
+KDE_ORG_NAME="kdelibs4support"
+inherit ecm kde.org
+
+DESCRIPTION="Icons of flags for various countries"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+CMAKE_USE_DIR="${S}/src/l10n"
+
+# https://phabricator.kde.org/T13722
+# https://invent.kde.org/frameworks/breeze-icons/-/issues/1
+PATCHES=( "${FILESDIR}/${P}-standalone.patch" )
+
+RDEPEND="!<kde-frameworks/kdelibs4support-5.90.0:5"
diff --git a/kde-frameworks/countryflags/files/countryflags-5.90.0-standalone.patch b/kde-frameworks/countryflags/files/countryflags-5.90.0-standalone.patch
new file mode 100644
index 000000000000..777fc622580d
--- /dev/null
+++ b/kde-frameworks/countryflags/files/countryflags-5.90.0-standalone.patch
@@ -0,0 +1,31 @@
+From 4abd415bae7dd03cfb30f7db3597e0ab241f19e5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 17 Dec 2021 16:09:12 +0100
+Subject: [PATCH] Standalone install of countryflags (src/l10n)
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ src/l10n/CMakeLists.txt | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/src/l10n/CMakeLists.txt b/src/l10n/CMakeLists.txt
+index babb57b8..915b6fe4 100644
+--- a/src/l10n/CMakeLists.txt
++++ b/src/l10n/CMakeLists.txt
+@@ -1,3 +1,13 @@
++cmake_minimum_required(VERSION 3.16)
++
++project(CountryFlags)
++
++include(FeatureSummary)
++find_package(ECM 5.89.0 NO_MODULE)
++set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
++
++include(KDEInstallDirs)
++
+ install( FILES northafrica.desktop westafrica.desktop southafrica.desktop centralafrica.desktop eastafrica.desktop caribbean.desktop oceania.desktop centralamerica.desktop northamerica.desktop southamerica.desktop easteurope.desktop westeurope.desktop centraleurope.desktop northeurope.desktop southeurope.desktop southasia.desktop southeastasia.desktop eastasia.desktop centralasia.desktop middleeast.desktop DESTINATION ${KDE_INSTALL_DATADIR_KF5}/locale/countries )
+
+ set(listLang C epo ad ae af ag ai al am an ao ar as at au aw ax az ba bb bd be bf bg bh bi bj bl bm bn bo br bs bt bw by bz ca cc cd cf cg ch ci ck cl cm cn co cr cu cv cx cy cz de dj dk dm do dz ec ee eg eh er es et fi fj fk fm fo fr ga gb gd ge gf gg gh gi gl gm gn gp gq gr gt gu gw gy hk hn hr ht hu id ie il im in iq ir is it je jm jo jp ke kg kh ki km kn kp kr kw ky kz la lb lc li lk lr ls lt lu lv ly ma mc md me mf mg mh mk ml mm mn mo mp mq mr ms mt mu mv mw mx my mz na nc ne nf ng ni nl no np nr nu nz om pa pe pf pg ph pk pl pm pn pr ps pt pw py qa re ro rs ru rw sa sb sc sd se sg sh si sk sl sm sn so sr ss st sv sy sz tc td tg th tj tk tl tm tn to tp tr tt tv tw tz ua ug us uy uz va vc ve vg vi vn vu wf ws ye yt za zm zw )
+--
+2.34.1
+
diff --git a/kde-frameworks/countryflags/metadata.xml b/kde-frameworks/countryflags/metadata.xml
new file mode 100644
index 000000000000..506ecf605bc4
--- /dev/null
+++ b/kde-frameworks/countryflags/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ </upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Frameworks API.
+ </subslots>
+ </slots>
+</pkgmetadata>