summaryrefslogtreecommitdiff
path: root/kde-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-23 14:44:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-23 14:44:46 +0100
commitcdfd4f0c915964d401cba19362c7dea8e89ad1da (patch)
treef6d313d1b57913d1309e00a578166e1e10fa6b8d /kde-apps
parent05a34d98821265bf73820931936f86704b9002c6 (diff)
gentoo auto-resync : 23:08:2022 - 14:44:46
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/Manifest.gzbin37277 -> 37273 bytes
-rw-r--r--kde-apps/kalarm/Manifest1
-rw-r--r--kde-apps/kalarm/files/kalarm-22.07.90-without_x11.patch75
3 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/Manifest.gz b/kde-apps/Manifest.gz
index 30804d9c35de..022ded78fdd4 100644
--- a/kde-apps/Manifest.gz
+++ b/kde-apps/Manifest.gz
Binary files differ
diff --git a/kde-apps/kalarm/Manifest b/kde-apps/kalarm/Manifest
index cea76c4a583a..7ab330b551d7 100644
--- a/kde-apps/kalarm/Manifest
+++ b/kde-apps/kalarm/Manifest
@@ -1,4 +1,5 @@
AUX kalarm-22.04.3-without_x11.patch 2519 BLAKE2B 0c71b4bbd30033be19825315d997df0138fb910219a5ce58396f9919d9bc61d6fafea911316b07f134a310eedee77938e6484f9231265792e85b41f20dbd2080 SHA512 766b840920ac6b18fe79ddb0953f75e5b036d8cd4f7370c9869ab7489c5c5e7dc0828d3bd61e2cab7897b4ee4be3252fce0be7db1f8213da4ffd803011147e8a
+AUX kalarm-22.07.90-without_x11.patch 2823 BLAKE2B 5be6d4d7ce605f9a1188678d89067e06a8c2c380749860ad86c5d15e6d1cbfc08d65d06d2fa34cff3c845e122110705782ae5813ca81d111824a6634bf89d9a7 SHA512 d13b2e3fedc6b86f4e10066af6b316c4fe3f76920e878c5b41d096c722b156c1a6e5c5faa984d42d214e1739e2c0df4776fdcc3bc2c5e4f6b1f0100d16ab4c4c
DIST kalarm-22.04.3.tar.xz 2347752 BLAKE2B 9749172b9246c0f903ccbf7fd6ca7dae756ac9cfab594a85cc0cdff772dc0f0c21b48b2f2c0ff71467b117f0e287def9c4202a033636ce93f1317a567ff8e017 SHA512 22650e5263d0a7bb584da138977da32cad38672f2e2dd2beb5ad1b9f31f76cbed68fd3b9ca5c241bacbc793ce5102da5b331b68e689868620f46aab2234d26c4
DIST kalarm-22.08.0.tar.xz 2365496 BLAKE2B ed9beb446852a7e9562fd6a7c6540d6166e1206fb959bed67069bca27259a59b2450ddee16ef306865ae5b83c88295dd11c5833d94739d14159e2def837d4944 SHA512 49c19cf6c9144e7d76dcf051ec23cf4ea51f6f8552aa96c2d325c049fd31b08ce8fd1a62c44d98368b5c673cbb026f5c332e44d70ca6fca6d5b5610613369884
EBUILD kalarm-22.04.3-r1.ebuild 2491 BLAKE2B ed5ff0797af99d488a178d66bfeafd9de81fe5da3a4f33cafed7326d844d0a9cb7ab0b4acadfc1cca1c19dacbbad2aaa1b50004130964fdeb55222636537543e SHA512 61dda501fd326b8e6f60c760caf61c9fa04d3841692d7d3072039b8af4f5e13ab9faefbd43151555533213e787a5b4663241df04b1085d2c52abe7d455f09cf1
diff --git a/kde-apps/kalarm/files/kalarm-22.07.90-without_x11.patch b/kde-apps/kalarm/files/kalarm-22.07.90-without_x11.patch
new file mode 100644
index 000000000000..6dc0d4e02d0d
--- /dev/null
+++ b/kde-apps/kalarm/files/kalarm-22.07.90-without_x11.patch
@@ -0,0 +1,75 @@
+From 308aa74653acc86cd6a206599a56500c827927ef Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 Nov 2021 12:59:32 +0100
+Subject: [PATCH] Add CMake option to build WITHOUT_X11
+
+We want to be able to build without X11 support even if some of the used
+libraries may not work w/o X11 themselves yet or need to be built with
+X11 support for other reverse dependencies.
+
+KDEPIM_HAVE_X11 already exists and is set automagically so far, but using
+-DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any dependencies list X11
+as required in their cmake config.
+
+Introducing this option means there is no behavior change by default,
+cmake will just skip finding X11 or adding unwanted features if the
+option is enabled.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 21 +++++++++++++--------
+ src/CMakeLists.txt | 2 +-
+ 2 files changed, 14 insertions(+), 9 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 05ef5181..c1849f2a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -127,18 +127,23 @@ endif()
+ configure_file(kalarm-version-string.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/kalarm-version-string.h @ONLY)
+
+ if (NOT APPLE)
+- find_package(X11)
+-endif()
+-if (X11_FOUND)
+- if (QT_MAJOR_VERSION STREQUAL "5")
+- find_package(Qt5X11Extras ${QT_REQUIRED_VERSION} REQUIRED NO_MODULE)
+- else()
+- find_package(Qt${QT_MAJOR_VERSION} ${QT_REQUIRED_VERSION} CONFIG REQUIRED Gui) # qtx11extras_p.h for Qt6 < 6.2
++ option(WITHOUT_X11 "Build without X11 integration (skips finding X11)" OFF)
++ if (NOT WITHOUT_X11)
++ find_package(X11)
++ set(KDEPIM_HAVE_X11 ${X11_FOUND})
++ if (X11_FOUND)
++ if (QT_MAJOR_VERSION STREQUAL "5")
++ find_package(Qt5X11Extras ${QT_REQUIRED_VERSION} REQUIRED NO_MODULE)
++ else()
++ find_package(Qt${QT_MAJOR_VERSION} ${QT_REQUIRED_VERSION} CONFIG REQUIRED Gui) # qtx11extras_p.h for Qt6 < 6.2
++ endif()
++ endif()
+ endif()
++ add_feature_info(WITHOUT_X11 ${WITHOUT_X11} "Build without X11 integration")
+ endif()
++
+ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
+
+-set(KDEPIM_HAVE_X11 ${X11_FOUND})
+ configure_file(src/config-kalarm.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-kalarm.h)
+
+ include_directories(${kalarm_SOURCE_DIR} ${kalarm_BINARY_DIR})
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 6bb3e5ba..9a3fb73c 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -335,7 +335,7 @@ if (ENABLE_WAKE_FROM_SUSPEND)
+ target_link_libraries(kalarm_bin KF5::AuthCore)
+ endif()
+
+-if(X11_FOUND)
++if(KDEPIM_HAVE_X11)
+ if (QT_MAJOR_VERSION STREQUAL "5")
+ target_link_libraries(kalarm_bin Qt${QT_MAJOR_VERSION}::X11Extras ${X11_X11_LIB})
+ elseif (Qt6_VERSION_MINOR LESS 2)
+--
+GitLab
+