summaryrefslogtreecommitdiff
path: root/kde-apps/kio-extras
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 14:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 14:10:02 +0100
commit7e17b5aabc330abb894f2b90bef0e3fcbcd180d2 (patch)
tree0b0cd08ce6e24faf7c868b07127ee0b6b32153c7 /kde-apps/kio-extras
parentda3552023d9aae2ee5183df71a80a8169414974e (diff)
gentoo auto-resync : 06:08:2022 - 14:10:01
Diffstat (limited to 'kde-apps/kio-extras')
-rw-r--r--kde-apps/kio-extras/Manifest3
-rw-r--r--kde-apps/kio-extras/files/kio-extras-22.04.3-without_x11.patch62
-rw-r--r--kde-apps/kio-extras/kio-extras-22.04.3.ebuild4
3 files changed, 67 insertions, 2 deletions
diff --git a/kde-apps/kio-extras/Manifest b/kde-apps/kio-extras/Manifest
index b22ad777ebdc..8f7bf4ce3630 100644
--- a/kde-apps/kio-extras/Manifest
+++ b/kde-apps/kio-extras/Manifest
@@ -1,3 +1,4 @@
+AUX kio-extras-22.04.3-without_x11.patch 2036 BLAKE2B a6ed7cee07eba03821f057c11c4bfbd29ae4a2cb81c8bfce809c3451f182de2a4f84a2769dc9551a88f352b64a86a072795dc8940422b82ac665bb6f3a3077f8 SHA512 ecfcc62723b3b591b3f5f8bc783e7fa8051371fea721b452ebb01e6d167cf1b0eb6647cf562e2858614275eecf460a686e70e6ce90b467cc087a8a16dc750bfd
DIST kio-extras-22.04.3.tar.xz 642208 BLAKE2B 6c9f0a7d03a2b735c10a8b42cfae62c222d1e2b5a73e4827ab565f7b7b2d5a818aceffd3e6c838ed7bd5ba4f5f3ecc359757b096b4542275e2f45f6993dac7de SHA512 8e6be2829743b4a44326335dfbfd655c7b52508ab7db566e0f5bec1a56a39ebd33a5d0438b7dc192ec3f0ebcde34ccff5e37d6b63d6bfd9f4ba5a5624616d732
-EBUILD kio-extras-22.04.3.ebuild 2646 BLAKE2B a7dac0e0aaedee0aae803e67aab1770a3687ba57ebacefa261c5e6d9fee4099e6faa15eb88865f57056b317ff1ea5dd79c7c051bb34a8ffef683ff73cdefe828 SHA512 1ff7f51d4dae56d49c72055dac1fb5e183a202f2a0316d375b6edce0df4dcb2a36f9da75dd0ffb3348871890c2ffab354d02a1fa5c3b7bb118dfc66ff412f1e9
+EBUILD kio-extras-22.04.3.ebuild 2689 BLAKE2B 0e4e5ec1842463a71c711fec57cb91c66d065d220ba840a9505681ec227c0714db5da8573019f5072234ad6dedf505cf992fa4f794f49b707c52b90765a69601 SHA512 008f44cf1df1dba1549131329ca47f37854750a2f7dc82f7dd0deff318c42d55eaa651a8d685565776636eaa1c8801237bd2fd2462f79eaedfe0f052f3d673d5
MISC metadata.xml 913 BLAKE2B d7ea851c61364c2fb7cfd129ba9aec20614532bce4a0837a4445f733a2c2a7124450df95f59c5bbda166d50d2e520354749b5f47914c396a1a2f42809755ac92 SHA512 cd1b93a8acd9dd96902548c943e985876887b394e0e92cb6de46bc05a8310ba334d11ec587623c5bb2ac462b1ee16d388adfb0b439d75f2f34f41ca5426e2b94
diff --git a/kde-apps/kio-extras/files/kio-extras-22.04.3-without_x11.patch b/kde-apps/kio-extras/files/kio-extras-22.04.3-without_x11.patch
new file mode 100644
index 000000000000..4c97ab5187c6
--- /dev/null
+++ b/kde-apps/kio-extras/files/kio-extras-22.04.3-without_x11.patch
@@ -0,0 +1,62 @@
+From b8dda4b3129f42323e1f6ccb37c16cb62a740d39 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 Nov 2021 14:07:32 +0100
+Subject: [PATCH] Add CMake option to build WITHOUT_X11
+
+We want to be able to build without X11 support even if some of the used
+libraries may not work w/o X11 themselves yet or need to be built with
+X11 support for other reverse dependencies.
+
+-DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any dependencies list X11
+as required in their cmake config, also X11_FOUND could be set by
+cascading cmake dependencies.
+
+Introducing this option means there is no behavior change by default,
+cmake will just skip finding X11 or adding unwanted features if the
+option is enabled.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ thumbnail/CMakeLists.txt | 19 +++++++++++--------
+ 1 file changed, 11 insertions(+), 8 deletions(-)
+
+diff --git a/thumbnail/CMakeLists.txt b/thumbnail/CMakeLists.txt
+index f6f38992d..ee322a1bf 100644
+--- a/thumbnail/CMakeLists.txt
++++ b/thumbnail/CMakeLists.txt
+@@ -21,13 +21,16 @@ set_package_properties(libappimage PROPERTIES
+ PURPOSE "Provides support for AppImage thumbnails"
+ )
+
+-find_package(X11)
+-set_package_properties(X11 PROPERTIES
+- DESCRIPTION "X11 libraries"
+- URL "https://www.x.org"
+- TYPE OPTIONAL
+- PURPOSE "Provides support for XCursor thumbnails"
+-)
++option(WITHOUT_X11 "Build without support for XCursor thumbnails (disables finding X11)" OFF)
++if (NOT WITHOUT_X11)
++ find_package(X11)
++ set_package_properties(X11 PROPERTIES
++ DESCRIPTION "X11 libraries"
++ URL "https://www.x.org"
++ TYPE OPTIONAL
++ PURPOSE "Provides support for XCursor thumbnails"
++ )
++endif()
+
+ find_package(Taglib 1.11)
+ set_package_properties(Taglib PROPERTIES
+@@ -210,7 +213,7 @@ endif()
+
+ ########### next target ###############
+
+-if(X11_Xcursor_FOUND)
++if(X11_Xcursor_FOUND AND NOT WITHOUT_X11)
+
+ add_library(cursorthumbnail MODULE cursorcreator.cpp cursorcreatorplugin.cpp)
+
+--
+GitLab
+
diff --git a/kde-apps/kio-extras/kio-extras-22.04.3.ebuild b/kde-apps/kio-extras/kio-extras-22.04.3.ebuild
index abf5c1450dcd..dd98f82228bd 100644
--- a/kde-apps/kio-extras/kio-extras-22.04.3.ebuild
+++ b/kde-apps/kio-extras/kio-extras-22.04.3.ebuild
@@ -70,6 +70,8 @@ RDEPEND="${DEPEND}
"
BDEPEND="man? ( dev-util/gperf )"
+PATCHES=( "${FILESDIR}/${P}-without_x11.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package activities KF5Activities)
@@ -83,7 +85,7 @@ src_configure() {
$(cmake_use_find_package samba Samba)
$(cmake_use_find_package sftp libssh)
$(cmake_use_find_package taglib Taglib)
- $(cmake_use_find_package X X11)
+ -DWITHOUT_X11=$(usex !X)
)
use samba && mycmakeargs+=(
-DBUILD_KDSoapWSDiscoveryClient=OFF # disable bundled stuff