summaryrefslogtreecommitdiff
path: root/kde-apps/kimap/kimap-21.08.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
commit616579b5d773c50af31ee56f00105d96ce641ca2 (patch)
tree2ad4d3ba1429bd93a36ab99a2f5ec3490412115e /kde-apps/kimap/kimap-21.08.0.ebuild
parent068424b26532f3551a81421a9be67ed206e5c11a (diff)
gentoo resync : 14.08.2021
Diffstat (limited to 'kde-apps/kimap/kimap-21.08.0.ebuild')
-rw-r--r--kde-apps/kimap/kimap-21.08.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/kimap/kimap-21.08.0.ebuild b/kde-apps/kimap/kimap-21.08.0.ebuild
new file mode 100644
index 000000000000..e6b4c2bafe42
--- /dev/null
+++ b/kde-apps/kimap/kimap-21.08.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Library for interacting with IMAP servers"
+HOMEPAGE="https://api.kde.org/kdepim/kimap/html/index.html"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/cyrus-sasl
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+"
+# TODO: Convince upstream not to install stuff with tests
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtnetwork-${QTMIN}:5 )
+"
+
+src_test() {
+ # tests cannot be run in parallel #605586
+ local myctestargs=(
+ -j1
+ )
+ ecm_src_test
+}