summaryrefslogtreecommitdiff
path: root/kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
commit9d0673651c57438d51e18c6b8ca894d0491b2df3 (patch)
treec5b6cd187b8998d2c56d3b279ac425973d4c3a33 /kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch
parentbe21a4c281fc76681a84dd2f103e850866ce4946 (diff)
gentoo auto-resync : 24:08:2022 - 20:48:33
Diffstat (limited to 'kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch')
-rw-r--r--kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch b/kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch
new file mode 100644
index 000000000000..d0b7cd2a25f7
--- /dev/null
+++ b/kde-apps/kdialog/files/kdialog-22.04.3-without_x11.patch
@@ -0,0 +1,44 @@
+From 0a50669e229a965a61039e5f9f20c345d72231b5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 Nov 2021 13:52:23 +0100
+Subject: [PATCH] Add CMake option to build WITHOUT_X11
+
+We want to be able to build without X11 support even if some of the used
+libraries may not work w/o X11 themselves yet or need to be built with
+X11 support for other reverse dependencies.
+
+HAVE_X11 already exists and is set automagically so far, but using
+-DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any dependencies list X11
+as required in their cmake config.
+
+Introducing this option means there is no behavior change by default,
+cmake will just skip finding X11 or adding unwanted features if the
+option is enabled.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2bb478129..8449057db 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,10 +26,10 @@ include(FeatureSummary)
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS TextWidgets Notifications GuiAddons IconThemes WindowSystem KIO DBusAddons)
+ find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS DBus)
+
+-
+-find_package(X11)
+-if(X11_FOUND)
+- set(HAVE_X11 1)
++option(WITHOUT_X11 "Build without X11 integration (skips finding X11)" OFF)
++if (NOT WITHOUT_X11)
++ find_package(X11)
++ set(HAVE_X11 ${X11_FOUND})
+ endif()
+
+ add_definitions(
+--
+GitLab
+