summaryrefslogtreecommitdiff
path: root/kde-apps/kdepim-addons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /kde-apps/kdepim-addons
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'kde-apps/kdepim-addons')
-rw-r--r--kde-apps/kdepim-addons/Manifest2
-rw-r--r--kde-apps/kdepim-addons/kdepim-addons-20.12.0.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/kde-apps/kdepim-addons/Manifest b/kde-apps/kdepim-addons/Manifest
index 41c70508f615..27b455e64e09 100644
--- a/kde-apps/kdepim-addons/Manifest
+++ b/kde-apps/kdepim-addons/Manifest
@@ -1,3 +1,5 @@
DIST kdepim-addons-20.08.3.tar.xz 2071996 BLAKE2B f66800962d6f42d7205ee718b639b22f2865f6e0f1b36a7c5caac7074affbf83bb5540e9ac6e3cb5587b6b129eb69e8d156f5b6f2f8bf90e11c00f08bb9adf01 SHA512 c788f3aa204486491747ca976268347b8b916c84670e58087a009d0cd153be9a199c09434f2e884d26d39f92728210e97ac4e9c74f20ba6fcf37c6e83276980d
+DIST kdepim-addons-20.12.0.tar.xz 2145340 BLAKE2B 5c13e33738d408aa212369066504ace304b087132d7dbb96ef15cbf1436147e15f18650c9f146acb0ef410133a3793bb7e306a97a6219d4be2383e8516947772 SHA512 57fe901c797470bb1a06a12cb63db1f123cdf1a9e61d100a1e22d88cbef7e268864cb1b86c48535aca1f7a50fad64a70c7db8fe95832875f0f8c6b3b87cfd89e
EBUILD kdepim-addons-20.08.3.ebuild 2440 BLAKE2B 7b58e0b6390e94215ea0cdf002e67ed679e1525bbc7e661edbd6ac26886ed03fff7ac1e2fb9b502e401344bc1cba8bf7559c5b3a3753eb183dcc439ae462c4dd SHA512 62243ba8915f195c977df13a9c19d6fc862f3fe41742dbb1695f9a74582c90cfc44d140b616034f7e7fef94a537edc8f9d588833530c68e377ebcadc932080e5
+EBUILD kdepim-addons-20.12.0.ebuild 2507 BLAKE2B 3a635a6042f220d507df3c72c89e7be103b74351d7c1572bb9f7e6712d9a2f48e6e48d985032b93d50438079121aebf51599c3fc1abf10e3d4e87b406180879d SHA512 5eb317b94c8e035c8bdbbd2269deb44f51c82c55ba0270dd1a93b16d3d394dc5ec038edf80eda290ccb83aa18567dc5f419b6dd56b677c9db2ce0b339cd9affb
MISC metadata.xml 466 BLAKE2B 3f47bc3e22bf68542c83cea8d135bb3495f364b18734effe636ce5627a9be865f8a92f4c6a430bd2a7c47e8e88922fac82cf436c25c303abbd6ff895648917ff SHA512 c213ed927dcc9562e52726a93bb9dbb9b2b315bd6b230daa52093785e67ca31b305f59e2900c7100cf66b586880e32487d1ec3227024c9f5460f7e29525d491c
diff --git a/kde-apps/kdepim-addons/kdepim-addons-20.12.0.ebuild b/kde-apps/kdepim-addons/kdepim-addons-20.12.0.ebuild
new file mode 100644
index 000000000000..76659db8ec65
--- /dev/null
+++ b/kde-apps/kdepim-addons/kdepim-addons-20.12.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.75.0
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Plugins for KDE Personal Information Management Suite"
+HOMEPAGE="https://apps.kde.org/en/kontact"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="importwizard markdown"
+
+RDEPEND="
+ >=app-crypt/gpgme-1.11.1[cxx,qt5]
+ >=dev-libs/grantlee-5.2.0:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-notes-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/eventviews-${PVCUT}:5
+ >=kde-apps/grantleetheme-${PVCUT}:5
+ >=kde-apps/incidenceeditor-${PVCUT}:5
+ >=kde-apps/kaddressbook-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kimap-${PVCUT}:5
+ >=kde-apps/kitinerary-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kontactinterface-${PVCUT}:5
+ >=kde-apps/kpkpass-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-apps/libksieve-${PVCUT}:5
+ >=kde-apps/libktnef-${PVCUT}:5
+ >=kde-apps/mailcommon-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/prison-${KFMIN}:5
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ importwizard? ( >=kde-apps/akonadi-import-wizard-${PVCUT}:5 )
+ markdown? ( app-text/discount )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package importwizard KPimImportWizard)
+ $(cmake_use_find_package markdown Discount)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "regex support for Sieve editor plugin" kde-misc/kregexpeditor
+ fi
+ ecm_pkg_postinst
+}