summaryrefslogtreecommitdiff
path: root/kde-apps/kaccounts-integration/kaccounts-integration-21.04.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /kde-apps/kaccounts-integration/kaccounts-integration-21.04.3.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'kde-apps/kaccounts-integration/kaccounts-integration-21.04.3.ebuild')
-rw-r--r--kde-apps/kaccounts-integration/kaccounts-integration-21.04.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/kde-apps/kaccounts-integration/kaccounts-integration-21.04.3.ebuild b/kde-apps/kaccounts-integration/kaccounts-integration-21.04.3.ebuild
new file mode 100644
index 000000000000..e6a71ffbc9cb
--- /dev/null
+++ b/kde-apps/kaccounts-integration/kaccounts-integration-21.04.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+KFMIN=5.80.0
+PLASMA_MINIMAL=5.16.5
+QTMIN=5.15.2
+VIRTUALDBUS_TEST="true"
+inherit ecm kde.org
+
+DESCRIPTION="Administer web accounts for the sites and services across the Plasma desktop"
+HOMEPAGE="https://community.kde.org/KTp"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="
+ sys-devel/gettext
+"
+COMMON_DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ net-libs/accounts-qt
+ >=net-libs/libaccounts-glib-1.21:=
+ net-libs/signond
+"
+DEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PLASMA_MINIMAL}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+"
+
+# bug #549444
+RESTRICT+=" test"