summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /kde-apps/dolphin
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest4
-rw-r--r--kde-apps/dolphin/dolphin-19.08.0.ebuild90
-rw-r--r--kde-apps/dolphin/metadata.xml7
3 files changed, 97 insertions, 4 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index f4c1e1c426ba..6f84b3bd37ad 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-19.04.3.tar.xz 5128016 BLAKE2B 9cf2b075cdbe87002589aa99c31036ad9648a6f70cd248698ff38b0a983a2b59100b52cd6645396d613294dac70a33bca1a52ea225630c15339e0f8f471ac0c1 SHA512 b0838f2ec1e1a22912a1178a262d7cc680dba5f11828bb0dac6bf59bf4c1a2affab912994d4f43adfe299bacd337848d11333996cfdfa54940f8604667e97e3a
+DIST dolphin-19.08.0.tar.xz 5253048 BLAKE2B 702cb5763ee39342381653d583aeebabb4efc7ad13a150bee650d6fb0aee96c8c9b0140b55236ca1613db7455f768f6d2f4ab0d51c2a21134f19790fe04b28bd SHA512 39afe693238b375f81a270d8b28a58c543aaab2a11e59d1c29f0daacbdaf1c43c271aae14104ba574349db2de690cef577d2143487248c86607ec247bc653824
EBUILD dolphin-19.04.3.ebuild 2313 BLAKE2B 6f46bcdf2bcce4fa160b6d077fff1ef03c1130e6b09bfaa32cd7b431637964eadbc0a8cdaf4adb37ce117cc79dfec63b921e8685a534a36b8a5e627c83c7d4e2 SHA512 8093bffe06d620e7044eeefe216b7ee2ffb96a189e20f7759d37d5cc8bea09e40f225b5a8bfa660b84bdaee5ef4ebf0567e0c94a00cbb3e997549bc660314af2
-MISC metadata.xml 325 BLAKE2B 2526d5a76392c6c3ba96998586cab48d43c3bf87422c698fbfe009c398d2f84b13193f4cebd06e87b3f7856a83824e3ed3a34b902a437671fb9302de2af44674 SHA512 8a728d296c68f8046b32871bb185a467b1b03a25af3c026647d76b40d83d1f8ee959fac135b26ed1fdb3ec15cdb6c58c75d9fd128122331181530637e2d69169
+EBUILD dolphin-19.08.0.ebuild 2633 BLAKE2B 6af50a215fe4a3e848e92d30f7516c2ce1d7d423cbc544603645342c15ed5e59732c0f7823ffc103019e7926240d0d4e23dccd784ba2a2f388d1b008587c0793 SHA512 08432e888e894af4ce943bccd1612f398f54a62d25ab4831286e04e8902065a7a850f1ab915ef3698f990105344f1d5c14121e0c362d4966a80d2785775798f3
+MISC metadata.xml 422 BLAKE2B bacaf060f870e305255375a8902e9d64332b4b19d7ee428f28a09b3d0d47ebe9131968c8aa2c9e940a632f2b742a4fc349154c6070604bc27dc8ac7b184a6bef SHA512 99e4db3ad705d867fad873bb8f58c02bc3716a0903fe59d4781e127994b00f40e2f9b205ad561f531da049ce7ba566c2300e9fc630220cbfbb9721ea045fd24b
diff --git a/kde-apps/dolphin/dolphin-19.08.0.ebuild b/kde-apps/dolphin/dolphin-19.08.0.ebuild
new file mode 100644
index 000000000000..158e8af0b6d2
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-19.08.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="activities semantic-desktop"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ activities? ( $(add_frameworks_dep kactivities) )
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package activities KF5Activities)
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ has_version "kde-apps/ark:${SLOT}" || \
+ elog "For compress/extract and other actions install kde-apps/ark:${SLOT}"
+
+ has_version "kde-apps/kleopatra:${SLOT}" || \
+ elog "For crypto actions install kde-apps/kleopatra:${SLOT}"
+
+ has_version "kde-apps/ffmpegthumbs:${SLOT}" || \
+ elog "For video file thumbnails install kde-apps/ffmpegthumbs:${SLOT}"
+
+ has_version "kde-apps/thumbnailers:${SLOT}" || \
+ elog "For graphics file thumbnails install kde-apps/thumbnailers:${SLOT}"
+
+ has_version "kde-frameworks/purpose:${SLOT}" || \
+ elog "For 'Share' context menu actions install kde-frameworks/purpose:${SLOT}"
+ fi
+}
diff --git a/kde-apps/dolphin/metadata.xml b/kde-apps/dolphin/metadata.xml
index 6038ccc85636..32739ea6f617 100644
--- a/kde-apps/dolphin/metadata.xml
+++ b/kde-apps/dolphin/metadata.xml
@@ -1,11 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <use>
- <flag name="thumbnail">Enables thumbnail generation</flag>
- </use>
<maintainer type="project">
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <use>
+ <flag name="activities">Track which folders are frequently accessed on a Plasma desktop</flag>
+ <flag name="thumbnail">Enables thumbnail generation</flag>
+ </use>
</pkgmetadata>