summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
commit0706fc6986773f4e4d391deff4ad5143c464ea4e (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /kde-apps/dolphin
parentaa3411e241a201d53a2689766fe419f2756819f3 (diff)
Revert "gentoo resync : 24.03.2019"
This reverts commit aa3411e241a201d53a2689766fe419f2756819f3.
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest5
-rw-r--r--kde-apps/dolphin/dolphin-18.08.3.ebuild87
-rw-r--r--kde-apps/dolphin/dolphin-18.12.3.ebuild2
-rw-r--r--kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch56
4 files changed, 148 insertions, 2 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index e8977ad06ca6..d7b23909244f 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,3 +1,6 @@
+AUX dolphin-18.08.3-kcrash-init.patch 1741 BLAKE2B f569dfc4fc07790b1c69697b2259b6cf13e4bd7ff0d98be5e3b09a8bf0d404f86fdfee001349c8631b8c74c5ba1a73bf6573b130a5d8bf30241560d2dc6a6eef SHA512 34393a2285647ee8e33eebccc2bb563e5ea5298252c88ece505389bceae58ecc953e5daec3ca5f05cf7838f39375474ef97e4b54ec120d0396cd7e3cc5ac0d7b
+DIST dolphin-18.08.3.tar.xz 4859384 BLAKE2B 60361ce997e0e4734fe953f988774dbe28aef9dcb7c2837c3860cfad5f56345d4d635f1478ce42a1649a6d5bd0d3838f722c95a747e1c77f17828d0d38b0ab29 SHA512 f3017ecb67009292972876f27ade398699622cd4253e608d78b9c8dd7693bce2a1d742af5f51885b28c1765496b31f83ac25fda40ba330821b460622adc7ad7c
DIST dolphin-18.12.3.tar.xz 4868312 BLAKE2B 000875449285baac35f9db6c6273de9061000c0a030524882e432b8c4a75f755cad2ed711ba88ffca61396e4ac372b9cdc5a3ee5c5afb6e4f108eb66019ec36c SHA512 369592af52053550eb482fecfbb54fda3d65db75b0bcf000f88c32d4e709e056f8f5399427674b3aac0bcea438fe8fa24bdbb08109373e0c44e495d9c772da1f
-EBUILD dolphin-18.12.3.ebuild 2182 BLAKE2B 2a24f6ccfeb3344b47b0cc2573c0d441acc48b8972aea6d9237f59200d29167b455469051aa50a0af7bdfdf0749e240b00468c3467e8049b3eb7c70f64363850 SHA512 c9c9fc282652c9ecdc73581277fc9334fe58db546a7d8dcb3f002a8b66fdd323bdb523cac833f6ece714dac3abd87ce6b9ea5b02dc64c42e850f21d5b36b4547
+EBUILD dolphin-18.08.3.ebuild 2277 BLAKE2B 447bd4a6809cf09a627eb3ae837df58088e6c396cc62e49c0daccf621e96b20210fb91d440ad222861fa17fccecac302769c7a7fcb0969dab208905ca9e841e7 SHA512 0bc9f70ab9a9be684b7b78d9d43d6996a3dd56242768d4acdcdb287e30cd92830ba31e5a01329040312ef213b0a8a42359a9d43bffe9830626e76021444f38bd
+EBUILD dolphin-18.12.3.ebuild 2184 BLAKE2B e7150ef620542a809124e1676551658977c4a872a29d67a2dbc84c7399302f38ab6469e995f6de0ef395bed4e5415cf1f4983a658e8c753f5a878071a994118c SHA512 25286daf99a48f2f9d70cc5739d7d8e39dfc210179fc7306a68520161bec78ff5796026a195e1056cb145f6efbbba7f1056213475d8c7037031ef45488af26e3
MISC metadata.xml 325 BLAKE2B 2526d5a76392c6c3ba96998586cab48d43c3bf87422c698fbfe009c398d2f84b13193f4cebd06e87b3f7856a83824e3ed3a34b902a437671fb9302de2af44674 SHA512 8a728d296c68f8046b32871bb185a467b1b03a25af3c026647d76b40d83d1f8ee959fac135b26ed1fdb3ec15cdb6c58c75d9fd128122331181530637e2d69169
diff --git a/kde-apps/dolphin/dolphin-18.08.3.ebuild b/kde-apps/dolphin/dolphin-18.08.3.ebuild
new file mode 100644
index 000000000000..660fdd8036ed
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-18.08.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://www.kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
+KEYWORDS="amd64 x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-kcrash-init.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ fi
+}
diff --git a/kde-apps/dolphin/dolphin-18.12.3.ebuild b/kde-apps/dolphin/dolphin-18.12.3.ebuild
index 9ba19ef094e0..72ad6427b9af 100644
--- a/kde-apps/dolphin/dolphin-18.12.3.ebuild
+++ b/kde-apps/dolphin/dolphin-18.12.3.ebuild
@@ -10,7 +10,7 @@ inherit kde5
DESCRIPTION="Plasma filemanager focusing on usability"
HOMEPAGE="https://www.kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
-KEYWORDS="amd64 ~arm64 x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="semantic-desktop thumbnail"
DEPEND="
diff --git a/kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch b/kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch
new file mode 100644
index 000000000000..cb7923534c3e
--- /dev/null
+++ b/kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch
@@ -0,0 +1,56 @@
+From a4cddf7517dab5f666f1c1ede2a58900f3bc5e53 Mon Sep 17 00:00:00 2001
+From: Harald Sitter <sitter@kde.org>
+Date: Thu, 15 Nov 2018 14:43:57 +0100
+Subject: move kcrash link to dolphin app (which is the effective user)
+
+Summary:
+to successfully use kcrash when linking with as-needed (which is a default
+flag on many linux distros) one also needs to call KCrash::initialize.
+this call happens in the app's main.cpp. as such the kcrash link target
+on the dolphinprivate library doesn't do anything for dolphinprivate but
+only kicks into action for dolphin itself.
+to avoid confusion and make it clear that kcrash is only initialized in the
+application scope the KF5::Crash link target is now on the application
+target, not the library target.
+
+(this makes no difference in the output, kcrash was still correctly linked
+ via dolphinprivate; but only for kdeinit_dolphin, dolphinprivate did
+ not get linked to it with as-needed)
+
+Test Plan: builds; links as expected
+
+Reviewers: elvisangelaccio, #dolphin
+
+Reviewed By: elvisangelaccio, #dolphin
+
+Subscribers: kfm-devel
+
+Tags: #dolphin
+
+Differential Revision: https://phabricator.kde.org/D16896
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 4a1f173..d5206be 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -136,7 +136,6 @@ target_link_libraries(
+ dolphinvcs
+ Qt5::Concurrent
+ Qt5::Gui
+- KF5::Crash
+ KF5::I18n
+ KF5::IconThemes
+ KF5::KIOCore
+@@ -301,6 +300,7 @@ kf5_add_kdeinit_executable(dolphin ${dolphin_SRCS})
+ target_link_libraries(kdeinit_dolphin PRIVATE
+ dolphinstatic
+ dolphinprivate
++ KF5::Crash
+ )
+
+ include(DbusInterfaceMacros)
+--
+cgit v0.11.2