summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin-plugins-mercurial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /kde-apps/dolphin-plugins-mercurial
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'kde-apps/dolphin-plugins-mercurial')
-rw-r--r--kde-apps/dolphin-plugins-mercurial/Manifest2
-rw-r--r--kde-apps/dolphin-plugins-mercurial/dolphin-plugins-mercurial-19.04.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-mercurial/Manifest b/kde-apps/dolphin-plugins-mercurial/Manifest
index d2cafb7341a0..b50279499a93 100644
--- a/kde-apps/dolphin-plugins-mercurial/Manifest
+++ b/kde-apps/dolphin-plugins-mercurial/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-plugins-18.12.3.tar.xz 191992 BLAKE2B 82dc3e03008949bc0af0c5938365b2d4dadbe8cafc0e7969e8c3a05804a53bfe6feb5e62e2f90f98940150709834472ff5b642681c7a6386b6362df8e4e75726 SHA512 a7d022652d80e832209c507b293c2701a8a3537d2b494e72c1e09dda9159751be8287991441869c0ce4cb8346c8c11fa537e94e06effb8e02d4f9f1fedaf9bf7
+DIST dolphin-plugins-19.04.0.tar.xz 192060 BLAKE2B 9024f60355f18e4961b5df543789f7c92501ff4162bea235760f47c5870e018fa42f092e4b3896ae470406f3b37b0171f814a48d246f085f377f215b8964f0ad SHA512 a9b8104f6472053f5e7b95a53238a2673d819a025b878a998c17c017683a1d61adbdd0abef6a40a4f3257735e2c16ca5a7550e95fe0bfa99ae470f3a4fe30ed5
EBUILD dolphin-plugins-mercurial-18.12.3.ebuild 1213 BLAKE2B dd917784730232106675d56ba3d6237e98729e3651da5f99265351476da3c0e041f88165d71f39a102967c78764350aa754c0da0be7cb27aa3861570a9f8a22a SHA512 9427064b621ebc297cf6fbb38ccef8c3be9ad98c1030013d22f16f795bcb2d7a0752026195b3fdc27e4778458ab4623c9a330d560dea08b41a916f599afc02b4
+EBUILD dolphin-plugins-mercurial-19.04.0.ebuild 1215 BLAKE2B 6d6df9b7f539fe3f7a6dacef24cc1bb978b25df429d3f3ba418aa7216f787d9d146b39c742db47d85b8fb21c1448303a6cec307f29c7585ed055082b92d3c04d SHA512 fabadcffda2df5da77f35fc54b5606ce25d9222cbcc29cffea8497ed1c89ac340507a29feb0e7dd0365e8dafe5de1b8c43a37a7516868eb9da4b165b33e47961
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-apps/dolphin-plugins-mercurial/dolphin-plugins-mercurial-19.04.0.ebuild b/kde-apps/dolphin-plugins-mercurial/dolphin-plugins-mercurial-19.04.0.ebuild
new file mode 100644
index 000000000000..c37f24664596
--- /dev/null
+++ b/kde-apps/dolphin-plugins-mercurial/dolphin-plugins-mercurial-19.04.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KMNAME="dolphin-plugins"
+KDE_HANDBOOK="false"
+MY_PLUGIN_NAME="hg"
+inherit kde5
+
+DESCRIPTION="Dolphin plugin for Mercurial integration"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/mercurial
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ punt_bogus_dep Qt5 Network
+ punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_svn=OFF
+ )
+ kde5_src_configure
+}