summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin-plugins-git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /kde-apps/dolphin-plugins-git
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest3
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-18.12.0.ebuild51
-rw-r--r--kde-apps/dolphin-plugins-git/metadata.xml8
3 files changed, 62 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
new file mode 100644
index 000000000000..5b966b82c560
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -0,0 +1,3 @@
+DIST dolphin-plugins-18.12.0.tar.xz 191844 BLAKE2B cf4c59909f961d2c295e6a15e963c409302f9ae52c001c284015977c88ed4d6fa71b47d0402bc7049834c702d94169a543e7552f6517882578dc9a0d490bfc6e SHA512 237fb4204267894903708ced1fed771871591606c12d3a25fb1452526fc71146f53f1e26c97954897eab97f08bfacc277dd189082c53aa867829a61e3b098348
+EBUILD dolphin-plugins-git-18.12.0.ebuild 1098 BLAKE2B 64043e10a4dc1a3181f2dedb5d816c5e60c0264aa72d7ae6a3c8e9169af5f98b0fee65a2eeb4b493eff9b6176cba075cfd1dbeb79aa4d8f47595cc9f0ea18114 SHA512 29dc5007d82ebe42d9bbd735e8f6a6a632091711cb2cbd227c565bb353ea9986ff7299d28d0248f665f36e59ed97c6314869e994d514a3027c73a9ad4dc8a009
+MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-18.12.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-18.12.0.ebuild
new file mode 100644
index 000000000000..452bdecba4b7
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-18.12.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KMNAME="dolphin-plugins"
+KDE_HANDBOOK="false"
+MY_PLUGIN_NAME="git"
+inherit kde5
+
+DESCRIPTION="Dolphin plugin for Git integration"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/git
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ punt_bogus_dep Qt5 Network
+ punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ kde5_src_configure
+}
diff --git a/kde-apps/dolphin-plugins-git/metadata.xml b/kde-apps/dolphin-plugins-git/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>