summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin-plugins-git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
commitcaf79cb4f7c4d5f7cce488d8f50dfb98ddbd09ab (patch)
tree4fb39a9252efabe8f160ef46b7b3be2f52af25aa /kde-apps/dolphin-plugins-git
parent3606ceecb950b302a6ba2a9882aeeff2a851e5dc (diff)
gentoo auto-resync : 10:12:2022 - 03:19:26
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest2
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-22.12.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 1a80220200ad..db033c828df8 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-plugins-22.08.3.tar.xz 260088 BLAKE2B 2927d42a603776cc3b600606ff2f27a77c8bbbe6b089d3e691571c7594d0e4d53023064afbf07e02f546073823a873fd45f200ea13b9e2765b61046602d8239b SHA512 2201858d9d349c28cced78dcfd9a31c3fde05b3ab107a28615af4cc5c32d4315074881f78dfb255638a13269de16ab68b7c53b68d013cf46ded091f8b059173e
+DIST dolphin-plugins-22.12.0.tar.xz 268876 BLAKE2B 8a21afe22227fdea29a63b09a6adcb5e6f263f9a0b11adad7466c72c3c145c4ce906b4acf77ced9c6a51d68d19f991e0c2933029d5848e10afa1eb7a3cd8da3a SHA512 be257382b493c2f318cfba7c594a1ef89c358ba5ccb3ff7478313040923f319106a1f94fcf9699695d3d17b59031bcdc88352fc6c58f779475b41a5080dc2126
EBUILD dolphin-plugins-git-22.08.3.ebuild 1517 BLAKE2B 935cf3af3313f747ad6f2657b52b21f62a97a17bbe70f0c14e7402a558cfebf0afddc3a8821d90417daca42a6b9859a9f494f5cf974dbca23a24682e68f04109 SHA512 0f5f6589748015f9d8f3d48bb85a1e6054dd7ad313c44f2eea276ee6a8a0a17a63eabd7ece3e6060bb64f7e12e1401bcc322d6db1867f83f8cc043564b47ca77
+EBUILD dolphin-plugins-git-22.12.0.ebuild 1471 BLAKE2B 6c5d9201d211c3bc2ccf3a9464dabcdf8374ada16e2cd364cfe26b5226987c665b8d444451a8c838665281f26a8a029ec73862a3e7f2fd27a76f27de28005fb1 SHA512 0284a2da4d0230b160484239918aca150a8a238ca4029aa6968e80e2782f008409ce9af71ebebcdb7e0d4aea1ce5f5f90a6315be8f76772c99cdf3f62d5f99e0
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-22.12.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-22.12.0.ebuild
new file mode 100644
index 000000000000..80257cc7ba37
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-22.12.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.99.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}