summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin-plugins-git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-13 02:01:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-13 02:01:50 +0000
commit2a3e0d61b3d88306b6fae46756f9ba7d230222ae (patch)
treea0d3259dd259861a49a2d3e6e9220beaa8ec39c2 /kde-apps/dolphin-plugins-git
parent39c32f4d5dca9f6293fccb69e9d50baf494c8de4 (diff)
gentoo auto-resync : 13:12:2024 - 02:01:50
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest2
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.12.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 6037fcda6fcb..66faad3d0120 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-plugins-24.08.3.tar.xz 317540 BLAKE2B 54fa2e13be2cceb53b12b1edb2d6d7c1793f6ba2bbec67e9e00121b33683aa6bd4895392cbdf5aa7627958c6323984ae3db8b5bbf6b14faba86b13181e0a2614 SHA512 05da7ac7b3ebe085cf0808d8e1eba49372bfeb1488800f40c1d0b9025e743efede1200095a1e660c1d538b2cc1b19f0f717f3d0723043517859f5c2015f961ce
+DIST dolphin-plugins-24.12.0.tar.xz 319128 BLAKE2B c793b10b882029eb7b2b681f15220fa065c2f59e4a1aa35ecf6ebfee253c4bd68aaf32c6555a8e03dad0ec8de7fba824834f1c0cbcb88c0c702b731b3d9b78d8 SHA512 94b4f8cd785c380b915da0e4a8efb9521d3a8440246466e4903746a2eb44188f1ae8cf3b483ec901f70c49c60a391de7c09d567e9a1a905b4229378c2623ee42
EBUILD dolphin-plugins-git-24.08.3.ebuild 1302 BLAKE2B 1ac3587dd6ad97347c1b3d6158e114b493dc386f8842f2395affd2805698eb793bae9427390a90519597767a5fc73e0a75c8904c7bf8aafe9f67dae56e9a892b SHA512 6c84d6c2c6f6bc3aee28e49b4310cc6c5a5a48280bd05e8d13323ea15d071555e65c157b91f7f37b6a0de9c1002a85b548b3e7a2d51a31f2ec215f142f2f5076
+EBUILD dolphin-plugins-git-24.12.0.ebuild 1304 BLAKE2B f43588a4aca14e194cfbd8f07e800c1e34db43f553439fced528e613a8a01476cdb7f826ca8c5aa6cd51765c2377bcc9170d975602c01da15c9d762a10264253 SHA512 07502d2af08d490a5c1fd4ce0d3957c2272ee80c1e6b65003b1a68be2c693e0fd6a0dd1eab6887144ff4ea10a0e9a26cdcbd89c6b235bd3a0b2f53dbeeb71c89
MISC metadata.xml 410 BLAKE2B 19c3aebce470d75ce9a551aa1100eec6faaf74fa06e74159d859ec31732a3a80170ecfbfe08edd931f9be9a00473ed6485bc2e23a65f7fe18339103cdc909f49 SHA512 752a847319ebf8d110347da3e6949f0ca6847c18453bf2b9a465a8415c79f37b4aefb03cc7fcf6874039c38ff4ee375715892a616c2766e1fd689c18c8b05c10
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.12.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.12.0.ebuild
new file mode 100644
index 000000000000..a60d133d4705
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.12.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+ >=kde-apps/dolphin-plugins-common-${PV}
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}