summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin-plugins-git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-18 08:46:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-18 08:46:05 +0100
commitcf1a411e806b434c96329401a6ff0901ec7f0d5c (patch)
tree969527fcceb3b686400c73b5ed22c1d587a8eb3e /kde-apps/dolphin-plugins-git
parent6a01345ec5dc673d0ebd4653ceb063eafa7fcf65 (diff)
gentoo auto-resync : 18:04:2025 - 08:46:04next
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest2
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-25.04.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 0b5e1fa0705f..5e5cbf7447ac 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-plugins-24.12.3.tar.xz 319108 BLAKE2B 0e6c5735b308cdea158b58f535335dedf1035920ec7cc6fc0bdb470dd0f58ce90c6efc3a4799b45fda7b967616babea980ce3792f2e9a507f543e4e8a488ae36 SHA512 4025ca9274e14d0f5c6bf880c8365ba5809f37d508174184daee6e7c45d5859fbeff3753a0c48d38ad9c59609be161ceea54cb38618de919ca762314e1001581
+DIST dolphin-plugins-25.04.0.tar.xz 329340 BLAKE2B 1ac49add95258837310aece77372cb5960909fdeadb78e1dcfce5bf56e1af1f94a3353894899d8e978658f40bde6365e93b582f33232721ee77e113a780dcc99 SHA512 6959f35e4b9699f4abe81a60b4a8823b17efa1cb46f12d1b6a3cc9477a78504f2401fbba61d69709598ad42c33245def21383fb315401db9bbe2d243a5a09952
EBUILD dolphin-plugins-git-24.12.3.ebuild 1302 BLAKE2B c39628d658f575b9c2aa51145acfe53c333f644d9a4b404ec3a68131a3034a6f1febbdd5469c993c019355143bca239f54bd3826f823420af7e7534f99613145 SHA512 268c92a23c39ba2bd9a14fd8bc7e6289f385d04f5ca10c839ebb0577791c5d9ec688a9739a092604fa940c0dcbd6df136f586f0bf74dcf938dba85fc2077abbd
+EBUILD dolphin-plugins-git-25.04.0.ebuild 1304 BLAKE2B b681bba5c4721809577cffea19fe42bccf845f7068fd603184c384542ce6a1db104442bbd736c06fb5c207a6986cddf3c23cfd4f502889d1e3682b79d060177b SHA512 d1af754d577ac7c6c3466e3d89463fbb5ef175c2bc0a0cfd5b77d6b1a689642192c40499010aa4b2372c0cb05e3aaccb1e57642539ff705209347fa23ba3b46d
MISC metadata.xml 410 BLAKE2B 19c3aebce470d75ce9a551aa1100eec6faaf74fa06e74159d859ec31732a3a80170ecfbfe08edd931f9be9a00473ed6485bc2e23a65f7fe18339103cdc909f49 SHA512 752a847319ebf8d110347da3e6949f0ca6847c18453bf2b9a465a8415c79f37b4aefb03cc7fcf6874039c38ff4ee375715892a616c2766e1fd689c18c8b05c10
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-25.04.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-25.04.0.ebuild
new file mode 100644
index 000000000000..f877360369c6
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-25.04.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.9.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+ >=kde-apps/dolphin-plugins-common-${PV}
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}