summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin-plugins-dropbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /kde-apps/dolphin-plugins-dropbox
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/Manifest2
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/Manifest b/kde-apps/dolphin-plugins-dropbox/Manifest
index 7fa21b558248..0cfb9cee4791 100644
--- a/kde-apps/dolphin-plugins-dropbox/Manifest
+++ b/kde-apps/dolphin-plugins-dropbox/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-plugins-19.12.3.tar.xz 195464 BLAKE2B b60be81fcb9932f9f645bc614ab74c2e862ef70df6958242dc67de2b9cb570cc8961c2ac593ad99db636f19bec1793316dab21b9cee9a59cf2764b67234c312a SHA512 f6d1ce129095d0ae608b2da4d91f55b93bb8fe94795c09217cc87607bb50cd8dcc5a7dac21b8655f9993da56ef90fa705520c7ac928295edb5254050af9c4a1e
+DIST dolphin-plugins-20.04.0.tar.xz 210308 BLAKE2B 3a2638fe995461dad3f1170181f959de15d6b7fe7b13bcd5b4b116e472f98f301b4de1821dbdd06823a27538c348f16416638120e536a61438f28470843151c0 SHA512 fecd7647661bfc157a41b280a8c32460676597b52e376d7e419c9d74d47a9cc16a6bd621677137f06c201f31c792b61280f1b08fe5b1f8d94bfb36a9b6a2c5cc
EBUILD dolphin-plugins-dropbox-19.12.3.ebuild 1335 BLAKE2B 1b4417ee9a3364fd7da7691046986b8ddc58f6943acc2067711fc95ce53ab2ddec4a652a3da0ebd240de5e75662733f63465b2981f1b0038c0725c7cac20c65c SHA512 a6488ec7a6660360838bcf885a68bb331e59dd5dc0ce6abf3a25d34e419169417578b214554a085f636aadd68b0fd022a1abf85d4e56f04e57c5b59007b98c72
+EBUILD dolphin-plugins-dropbox-20.04.0.ebuild 1332 BLAKE2B e3c7107472c31b51cfca0eb82550d0496333b722f9ef314ff96ebb9d5035775c6689b5fd310c2737b8d0eb1fa31c014c4b3523f4063c4bea9fa2e757500fe9e4 SHA512 dd0f86d21179c08d37179d4a37f9d70947db1d3e42aca66b7d4f90f7d0df627568f035938cbf3b71c8dd09f6c8f29a206351b1a9086775a8f5c3792aec3e0387
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.0.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.0.ebuild
new file mode 100644
index 000000000000..48d64702acc4
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.04.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="dropbox"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.69.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}