summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin-plugins-bazaar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /kde-apps/dolphin-plugins-bazaar
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'kde-apps/dolphin-plugins-bazaar')
-rw-r--r--kde-apps/dolphin-plugins-bazaar/Manifest3
-rw-r--r--kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-18.12.0.ebuild49
-rw-r--r--kde-apps/dolphin-plugins-bazaar/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-bazaar/Manifest b/kde-apps/dolphin-plugins-bazaar/Manifest
new file mode 100644
index 000000000000..d184008e1876
--- /dev/null
+++ b/kde-apps/dolphin-plugins-bazaar/Manifest
@@ -0,0 +1,3 @@
+DIST dolphin-plugins-18.12.0.tar.xz 191844 BLAKE2B cf4c59909f961d2c295e6a15e963c409302f9ae52c001c284015977c88ed4d6fa71b47d0402bc7049834c702d94169a543e7552f6517882578dc9a0d490bfc6e SHA512 237fb4204267894903708ced1fed771871591606c12d3a25fb1452526fc71146f53f1e26c97954897eab97f08bfacc277dd189082c53aa867829a61e3b098348
+EBUILD dolphin-plugins-bazaar-18.12.0.ebuild 1035 BLAKE2B 76aa92c4ecf691605ec1ed574398938b0432bc64f43476de87433ce655458948416d46c00859188b27d5514a8d651421f5238d9a197e08080f2992e627b6577a SHA512 e3105a3469fb39d766f5414af3b937bf81bce7aff655c5241df2934c3e7d5b730515d3c2fa30a8ae0344c7a4fda4d5e92e3aff75a6b73b1a9cecb7c301538641
+MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-18.12.0.ebuild b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-18.12.0.ebuild
new file mode 100644
index 000000000000..fa8c485a6ce5
--- /dev/null
+++ b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-18.12.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KMNAME="dolphin-plugins"
+KDE_HANDBOOK="false"
+MY_PLUGIN_NAME="bazaar"
+inherit kde5
+
+DESCRIPTION="Dolphin plugin for Bazaar integration"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/bzr
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ punt_bogus_dep Qt5 Network
+ punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ kde5_src_configure
+}
diff --git a/kde-apps/dolphin-plugins-bazaar/metadata.xml b/kde-apps/dolphin-plugins-bazaar/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/kde-apps/dolphin-plugins-bazaar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>