summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /gui-wm
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/Manifest.gzbin718 -> 716 bytes
-rw-r--r--gui-wm/sway/Manifest4
-rw-r--r--gui-wm/sway/sway-1.7.ebuild82
-rw-r--r--gui-wm/sway/sway-9999.ebuild8
4 files changed, 89 insertions, 5 deletions
diff --git a/gui-wm/Manifest.gz b/gui-wm/Manifest.gz
index 9703069166d7..768717183c26 100644
--- a/gui-wm/Manifest.gz
+++ b/gui-wm/Manifest.gz
Binary files differ
diff --git a/gui-wm/sway/Manifest b/gui-wm/sway/Manifest
index 10931d46f3a0..2b727aac5029 100644
--- a/gui-wm/sway/Manifest
+++ b/gui-wm/sway/Manifest
@@ -1,4 +1,6 @@
DIST sway-1.6.1.tar.gz 5550126 BLAKE2B a4ecc93df0eb16fcd9037ce62dd39c63e1712b3bc9e8ae36331a815759b18576f4a2c1b78a26545922038974f226f02e2d91f78d6e3933125d9b808871b7a887 SHA512 7f37fea99970db42c5485277df06d69bef5225fa03d25be179893b14d73c1d681f0355a1bc74091b4173bbccc88994a63ad0f9322e070811ba963648cf68cdeb
+DIST sway-1.7.tar.gz 5559075 BLAKE2B 702b9a209d603c88743f2e89d0787431b7a30e8b7554c9596edb9735af862d23c585158737a0943a470637138cbc5275bee37bd2d820a7489cdd0747d98e6e22 SHA512 028cf5d504d5914bfb78d44156d6a290de660c5ed0638f4e2c56e5be76db9b0baeda035e1fa1ae23559016bd7e4312f7ff70c2fb4904df25358577c1a3d21243
EBUILD sway-1.6.1-r1.ebuild 2344 BLAKE2B 68447972210cbecf79dbc7fcffdf70296d574c94ca9ccb7270c3f416f41cba7d430c8a0b8655dc52625d3906351c7fa6fe7b3f7ce982d08b04e122f27455707e SHA512 89b0e797a827702c60e4f9c7f81bf283e71803138c4e69230e73bf60979c36b17319475897a48921a80938b54c5dba1106b7674c7dd1a9fd54f263261c97cc76
-EBUILD sway-9999.ebuild 1833 BLAKE2B 185f92d75d50c5419a278c372847d8dc6408e363cce2aa460fb1e3da007fe4bb011da5e714bd0961484807b85228f7a61ab0e5fb42459ebb40760093f92ad60e SHA512 7ac063bf7c46928f7baeb57208619fdc80b4b90218141d13953bab06238fae3f4a3791bffcaebf73c4a37b1619733d14a8eaf5327266796b5aadb91d43ff3bc0
+EBUILD sway-1.7.ebuild 1840 BLAKE2B 5d1ed507b32a85a58e477112f1c6c7970aa96b95423de93e6afabb5188b5365c805fa246a8b0e49fd7c6af97cd67b9cf9e2e8cc4864e14583408be822d30e340 SHA512 aceed90fc9011d62cd661914eed30fb75e8531d83d579b8264876450f078f019ced2535d3695be96e500eb6ae0ab95e69d396ce967e9fc9b454b68c2324c67c5
+EBUILD sway-9999.ebuild 1840 BLAKE2B 50ee3eaea7183eb6c70e40b98ec3da860daf20fe906c216b49e3c70a4162e640eb57c949024d66feb7500d2557b9cbf9e4d5aee791a1da25113774f54ed8cfb6 SHA512 1ff51fc0c34cb02095a0e9f7f840de3f85190d7c8dd14ddd73238623486b8c809f4434901d5e7f466fdfc0e381c2615e2da3a21d91545f7908f7e09a8ccb5b6f
MISC metadata.xml 2188 BLAKE2B 5e8eb1e6cb3ef8e7398972a8a38556674469008a1531a5c44a35e2eb6c4a43ef01d1fe5f39d560c467b300aa3d9237268ae6a7768beccf4fa268563ac7bdd485 SHA512 a59f659d2b575d7db284dae3fe1c784c0ff2824365d8a96455e5cdc9850d20bf0ae66d3129884b15c8fb8a0fdd88316998a504558fa938c0403e1de64b922783
diff --git a/gui-wm/sway/sway-1.7.ebuild b/gui-wm/sway/sway-1.7.ebuild
new file mode 100644
index 000000000000..c23563749bdc
--- /dev/null
+++ b/gui-wm/sway/sway-1.7.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ MY_PV=${PV/_rc/-rc}
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag tray wallpapers X"
+
+DEPEND="
+ >=dev-libs/json-c-0.13:0=
+ >=dev-libs/libinput-1.6.0:0=
+ sys-auth/seatd:=
+ dev-libs/libpcre
+ >=dev-libs/wayland-1.20.0
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ media-libs/mesa[gles2,libglvnd(+)]
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ swaybg? ( gui-apps/swaybg )
+ swayidle? ( gui-apps/swayidle )
+ swaylock? ( gui-apps/swaylock )
+ wallpapers? ( x11-libs/gdk-pixbuf:2[jpeg] )
+ X? ( x11-libs/libxcb:0= )
+"
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~gui-libs/wlroots-9999:=[X=]"
+else
+ DEPEND+="
+ >=gui-libs/wlroots-0.15:=[X=]
+ <gui-libs/wlroots-0.16:=[X=]
+ "
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-util/meson-0.60.0
+ virtual/pkgconfig
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature tray)
+ $(meson_feature X xwayland)
+ $(meson_feature swaybar gdk-pixbuf)
+ $(meson_use swaynag)
+ $(meson_use swaybar)
+ $(meson_use wallpapers default-wallpaper)
+ -Dfish-completions=true
+ -Dzsh-completions=true
+ -Dbash-completions=true
+ -Dwerror=false
+ )
+
+ meson_src_configure
+}
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index 966fdddfa29c..376a229bbf80 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999 ]]; then
else
MY_PV=${PV/_rc/-rc}
SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
S="${WORKDIR}/${PN}-${MY_PV}"
fi
@@ -44,8 +44,8 @@ if [[ ${PV} == 9999 ]]; then
DEPEND+="~gui-libs/wlroots-9999:=[X=]"
else
DEPEND+="
- >=gui-libs/wlroots-0.15:=[X=]
- <gui-libs/wlroots-0.16:=[X=]
+ >=gui-libs/wlroots-0.16:=[X=]
+ <gui-libs/wlroots-0.17:=[X=]
"
fi
RDEPEND="