summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
commit3fd9d065ab109700e92fc1cea2a6519a39a5b007 (patch)
tree2666118c9404e846180636fbd2de92e3bd7870fd /gui-wm
parent11c791ab62dc711840a52676eef212362840fc17 (diff)
gentoo auto-resync : 09:08:2022 - 02:15:09
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/Manifest.gzbin721 -> 886 bytes
-rw-r--r--gui-wm/gamescope/Manifest3
-rw-r--r--gui-wm/gamescope/gamescope-3.11.33_beta1.ebuild69
-rw-r--r--gui-wm/gamescope/metadata.xml11
4 files changed, 83 insertions, 0 deletions
diff --git a/gui-wm/Manifest.gz b/gui-wm/Manifest.gz
index ae42892b552a..7cd7361e798a 100644
--- a/gui-wm/Manifest.gz
+++ b/gui-wm/Manifest.gz
Binary files differ
diff --git a/gui-wm/gamescope/Manifest b/gui-wm/gamescope/Manifest
new file mode 100644
index 000000000000..47117f6072ed
--- /dev/null
+++ b/gui-wm/gamescope/Manifest
@@ -0,0 +1,3 @@
+DIST gamescope-3.11.33_beta1.tar.gz 188791 BLAKE2B 9866d6131f7ab4bfa90e564d8cde21ae3fa3913fec9a22bc5fa83e418379814a087adf24207e67b737af243523725108958a3a8c34f245031683710b436144d7 SHA512 0842e52e6e9bac154b6256852866f8bb861256e07fa8b78535f2b8e2946c0ff5379c645fcfae710bd7168be2ddc9e48e77aaf49fc65f4b061e225fbb16b8b78c
+EBUILD gamescope-3.11.33_beta1.ebuild 1479 BLAKE2B c5dd3c7250afb0e4dc0a0eec048270e13eb6d7da29752c270878fdc4d0fda0df059c5b2f543b06d46a7f784eef75ac357d3fa15e1ff06557ef3e82ee8c41a227 SHA512 d6655c3ce5ad87966bfc3ff91cd7ecf3018f5deaadce10b8da9523359c928a3d9edea89b6651b7005a0d181b98b9bc2124aa6b3813a6aafefdb3494fc0ef422b
+MISC metadata.xml 329 BLAKE2B 55576d120d50b3fb6103479d383fb56655ab5ffa022bf829bc7a797b263fd7cf92da18d4b5c1028d92a5eb48fd2efa356fb3ecc2c1db7f57dfb58d63ee7f1649 SHA512 e7f2075f12a696de416e1fff294a17d1e9c669d5f7e430d8ffc9d317650ca665f96283023d38e0c68b79b23998881fc6a62fe9d9dd7818e69fe5f6b142cdc60e
diff --git a/gui-wm/gamescope/gamescope-3.11.33_beta1.ebuild b/gui-wm/gamescope/gamescope-3.11.33_beta1.ebuild
new file mode 100644
index 000000000000..d236ff8e6802
--- /dev/null
+++ b/gui-wm/gamescope/gamescope-3.11.33_beta1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps meson
+
+MY_PV="${PV//_/-}"
+DESCRIPTION="Efficient micro-compositor for running games"
+HOMEPAGE="https://github.com/Plagman/gamescope"
+SRC_URI="https://github.com/Plagman/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="pipewire"
+
+RDEPEND="
+ =dev-libs/libliftoff-0.2*
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.17
+ =gui-libs/wlroots-0.15*[X]
+ media-libs/libsdl2[video]
+ media-libs/vulkan-loader
+ sys-libs/libcap
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrender
+ x11-libs/libXres
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ pipewire? ( >=media-video/pipewire-0.3:= )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/stb
+ dev-util/vulkan-headers
+"
+BDEPEND="
+ dev-util/glslang
+ dev-util/wayland-scanner
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+FILECAPS=(
+ cap_sys_nice usr/bin/${PN}
+)
+
+src_prepare() {
+ default
+
+ # Normally uses stb from a git submodule. Upstream does not ship a
+ # pkg-config file so we don't install one. Work around this using symlinks.
+ mkdir subprojects/stb || die
+ ln -snf "${ESYSROOT}"/usr/include/stb/* "${S}"/subprojects/packagefiles/stb/* subprojects/stb/ || die
+}
+
+src_configure() {
+ local emesonargs=(
+ --force-fallback-for=
+ $(meson_feature pipewire)
+ )
+ meson_src_configure
+}
diff --git a/gui-wm/gamescope/metadata.xml b/gui-wm/gamescope/metadata.xml
new file mode 100644
index 000000000000..c218716acb8a
--- /dev/null
+++ b/gui-wm/gamescope/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <use>
+ <flag name="pipewire">Enable screen capture via PipeWire</flag>
+ </use>
+</pkgmetadata>