summaryrefslogtreecommitdiff
path: root/gui-wm/sway/sway-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /gui-wm/sway/sway-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'gui-wm/sway/sway-9999.ebuild')
-rw-r--r--gui-wm/sway/sway-9999.ebuild30
1 files changed, 6 insertions, 24 deletions
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index d03dab5a9bc0..c6a53ff0d87b 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit eutils meson
+inherit meson
DESCRIPTION="i3-compatible Wayland window manager"
HOMEPAGE="https://swaywm.org"
@@ -20,13 +20,12 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag seatd systemd tray wallpapers X zsh-completion"
-REQUIRED_USE="?? ( elogind systemd )
- tray? ( || ( elogind seatd systemd ) )"
+IUSE="fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag tray wallpapers X zsh-completion"
DEPEND="
>=dev-libs/json-c-0.13:0=
>=dev-libs/libinput-1.6.0:0=
+ sys-auth/seatd:=
dev-libs/libpcre
dev-libs/wayland
x11-libs/cairo
@@ -34,20 +33,19 @@ DEPEND="
x11-libs/pango
x11-libs/pixman
media-libs/mesa[gles2,libglvnd(+)]
- elogind? ( >=sys-auth/elogind-239 )
swaybar? ( x11-libs/gdk-pixbuf:2 )
swaybg? ( gui-apps/swaybg )
swayidle? ( gui-apps/swayidle )
swaylock? ( gui-apps/swaylock )
- systemd? ( >=sys-apps/systemd-239[policykit] )
wallpapers? ( x11-libs/gdk-pixbuf:2[jpeg] )
X? ( x11-libs/libxcb:0= )
"
if [[ ${PV} == 9999 ]]; then
- DEPEND+="~gui-libs/wlroots-9999:=[elogind=,seatd=,systemd=,X=]"
+ DEPEND+="~gui-libs/wlroots-9999:=[X=]"
else
DEPEND+="
- =gui-libs/wlroots-0.12.0*:=[elogind=,seatd=,systemd=,X=]
+ >=gui-libs/wlroots-0.14:=[X=]
+ <gui-libs/wlroots-0.15:=[X=]
"
fi
RDEPEND="
@@ -96,19 +94,3 @@ src_configure() {
meson_src_configure
}
-
-pkg_preinst() {
- if ! use systemd && ! use elogind && ! use seatd; then
- fowners root:0 /usr/bin/sway
- fperms 4511 /usr/bin/sway
- fi
-}
-
-pkg_postinst() {
- if ! use systemd && ! use elogind && ! use seatd; then
- elog ""
- elog "If your system does not set the XDG_RUNTIME_DIR environment"
- elog "variable, you must set it manually to run Sway. See wiki"
- elog "for details: https://wiki.gentoo.org/wiki/Sway"
- fi
-}