summaryrefslogtreecommitdiff
path: root/gui-wm/hyprland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-05 09:36:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-05 09:36:29 +0100
commit77f1c17f5328e59f3991203c579fbc85df6898a0 (patch)
treea548ffa40d8592c0a65665c44087e6ec27d9280b /gui-wm/hyprland
parent9ce4c0d3ec7daef46290a34cf0b02ae0d5b4f2f2 (diff)
gentoo auto-resync : 05:06:2023 - 09:36:29
Diffstat (limited to 'gui-wm/hyprland')
-rw-r--r--gui-wm/hyprland/Manifest4
-rw-r--r--gui-wm/hyprland/hyprland-0.25.0.ebuild10
-rw-r--r--gui-wm/hyprland/hyprland-0.26.0.ebuild96
3 files changed, 106 insertions, 4 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 05900cadc9be..542b97ebaec9 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1,4 +1,6 @@
AUX nvidia-0.25.0.patch 1394 BLAKE2B 95df2f6b82afb460a3e0a1769bb2abf41abcd76c564db3d43189fc9a617b92ae1de8422243f6624574d316187706d552439f47cc44bbcf3fa4f5fabd5d83b420 SHA512 5389d132e16c4dc7af3cdb48003ac7be8ae3760b6052d2edf637b3d645e2e85eda162353b245a848c5b9d218bfccfdfa987189d164444564d87a7048ec53f52d
DIST hyprland-0.25.0.gh.tar.gz 1510798 BLAKE2B c146c57e5142666ff76188e870ea4d2dd9613e25a1d2c3320dc222fbe62651975a40fffffe9cc936ced0e86f919534d7a6c94a8b1596f912c3ad9750a35e4f13 SHA512 84d12ef7bfb25e69c4a707a8ffc99ca23eb58e73630e3df1f134cb610c6206e42917f76b54db0cc6d10e7b929514cbac06dfc99feba8ff81aea0dc7fcb340450
-EBUILD hyprland-0.25.0.ebuild 1897 BLAKE2B 88f9ee0dada8869a41fda57ed111da9e917b76cf6e5e101966d335fe339829b89324aa77b0f405ee32f5ebbeb883b80a2d263584feee1ef3bc18933cad4903aa SHA512 e1ccd102eb9f7d56b3067f8801bc09d76f0b886c695e44515a916dda389f2d41221e658cbf5097c1f6ba526958b566a7aa0a2f75ab52e23d5639619ce8e4b7d5
+DIST hyprland-0.26.0.gh.tar.gz 1523005 BLAKE2B e54ebb73850f63427ff9347c7ad0cb2ffda3350baf3c4221de51b1094678f3ffdac67669f49bfe3ba416b627673f5ca8491d06e16791764ef1c39f5964f2b570 SHA512 b43639a8e0fdd60165b6caa51c9411bc6f97260690c5ee3d15126ef091ccf93955fdda904a226b4aeb4367785ecaba426882a2e9b726c2b79c81a2ede0f9e36a
+EBUILD hyprland-0.25.0.ebuild 2051 BLAKE2B 9ac8ded81174d7ebae4e6023b12ed316e778e04e3fabd828101a50505c663eb824919b58a2daf4cf60d56719efab41047ee11d9cd28fb6f65f0d3b19d3891160 SHA512 6c5174a4a1606c00df038eb7285ef91a61ffb98efe96daaacb017371b8acf5b24ecd2bbdd3c7f8801cc4839fc059917c1f524a4f5319674ce39b5e725fe379b5
+EBUILD hyprland-0.26.0.ebuild 2128 BLAKE2B 462924749d8784fc0e168d935e8fd28eb064d3af02d734efcfb156fd2eaf5e870d736df72da8e3b3877fa309a2cd7b0c7be5b9a69b7318c13e5f55afedc5dba9 SHA512 fb3d4ccfe4d118e8b3383917909d198dd131dd51c64cc38cf2ce8d51817f7cce25273ff768a166c0800ce046ca531bf451cc61255411340f729ac6e5eb8d3cf1
MISC metadata.xml 716 BLAKE2B fc5248c809b9b5bf1002e3d82ff80f595b8e613d09e5541f1a0151c3ea2c117376d25fa5a40c85d254533708d9eff5339bd329b42118e87ca49e22e55c0c5d7b SHA512 31252ced2546f3686f17259aabfe9273af14f7efaf3fa0bfb446c65c6d9478be3a23c531e0ac463f27fe1d50842f6f126f32e47a8a03a345306297e182952e98
diff --git a/gui-wm/hyprland/hyprland-0.25.0.ebuild b/gui-wm/hyprland/hyprland-0.25.0.ebuild
index bf62573979c1..aff592df7d8c 100644
--- a/gui-wm/hyprland/hyprland-0.25.0.ebuild
+++ b/gui-wm/hyprland/hyprland-0.25.0.ebuild
@@ -54,10 +54,14 @@ BDEPEND="
"
src_prepare() {
- STDLIBVER=$(echo '#include <string>' | $(tc-getCXX) -x c++ -dM -E - | \
+ if [[ $(tc-is-gcc) ]]; then
+ STDLIBVER=$(echo '#include <string>' | $(tc-getCXX) -x c++ -dM -E - | \
grep GLIBCXX_RELEASE | sed 's/.*\([1-9][0-9]\)/\1/')
- if ! [[ ${STDLIBVER} -ge 12 ]]; then
- die "Hyprland requires >=sys-devel/gcc-12.1.0 to build"
+ if ! [[ ${STDLIBVER} -ge 12 ]]; then
+ die "Hyprland requires >=sys-devel/gcc-12.1.0 to build"
+ fi
+ elif [[ $(clang-major-version) -lt 16 ]]; then
+ die "Hyprland requires >=sys-devel/clang-16.0.3 to build";
fi
if use video_cards_nvidia; then
diff --git a/gui-wm/hyprland/hyprland-0.26.0.ebuild b/gui-wm/hyprland/hyprland-0.26.0.ebuild
new file mode 100644
index 000000000000..a8cb65a2382c
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.26.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${PF}.gh.tar.gz"
+S="${WORKDIR}/${PN}-source"
+
+KEYWORDS="~amd64"
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd video_cards_nvidia"
+
+RDEPEND="
+ app-misc/jq
+ dev-libs/glib:2
+ dev-libs/libinput:=
+ dev-libs/libliftoff
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ dev-util/glslang
+ dev-util/vulkan-headers
+ gui-libs/gtk-layer-shell
+ media-libs/libdisplay-info
+ media-libs/libglvnd[X?]
+ media-libs/mesa[gles2,wayland,X?]
+ media-libs/vulkan-loader
+ sys-auth/seatd:=
+ x11-base/xcb-proto
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ x11-misc/xkeyboard-config
+ virtual/libudev:=
+ X? (
+ gui-libs/wlroots[x11-backend]
+ x11-base/xwayland
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-renderutil
+ x11-libs/xcb-util-wm
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/hyprland-protocols
+ >=dev-libs/wayland-1.22.0
+ dev-vcs/git
+ >=gui-libs/wlroots-0.16.0[X?]
+"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc; then
+ STDLIBVER=$(echo '#include <string>' | $(tc-getCXX) -x c++ -dM -E - | \
+ grep GLIBCXX_RELEASE | sed 's/.*\([1-9][0-9]\)/\1/')
+
+ if ! [[ ${STDLIBVER} -ge 12 ]]; then
+ die "Hyprland requires >=sys-devel/gcc-12.1.0 to build"
+ fi
+ elif [[ $(clang-major-version) -lt 16 ]]; then
+ die "Hyprland requires >=sys-devel/clang-16.0.3 to build";
+ fi
+}
+
+src_prepare() {
+ if use video_cards_nvidia; then
+ cd "${S}/subprojects/wlroots" || die
+ eapply "${FILESDIR}/nvidia-0.25.0.patch"
+ cd "${S}" || die
+ fi
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature legacy-renderer legacy_renderer)
+ $(meson_feature X xwayland)
+ $(meson_feature systemd)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install --skip-subprojects wlroots
+}