summaryrefslogtreecommitdiff
path: root/gui-wm/hyprland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
commit39ca6159b9ac903dc56818918d9f97bc831f0955 (patch)
treee9b34845be7f96bc244fd239f6dd8090096ce703 /gui-wm/hyprland
parentbc968d15e7f24968eb69567c7f2fca470fdedacd (diff)
gentoo auto-resync : 04:11:2023 - 22:13:37
Diffstat (limited to 'gui-wm/hyprland')
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/hyprland-0.31.0-r1.ebuild134
2 files changed, 135 insertions, 0 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 4dbdd1119d44..87c937f112bd 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -4,5 +4,6 @@ AUX hyprland-0.31.0-fix-log-headers.patch 865 BLAKE2B c8173cdac049a5914c3f002613
DIST hyprland-0.30.0.gh.tar.gz 14064946 BLAKE2B 188328ed08ca8a9db97ae94b77159f9ebe5361a050a177ec586f376b168dab4c9dcd6b6d71d3314e9470f46b57f0610a92cdfe73ff1704b9f55f21399895e69f SHA512 f8053c19460e7768aa00944d1fc624d85ff9e042d0750a74d28e08147fe50e45262bdb1c259642bb7241746a8fb967344841e58fa598213f8c333f15246f9c94
DIST hyprland-0.31.0.gh.tar.gz 14068621 BLAKE2B 272ba0c92ee6f8db623bb7b79a64ec1a3f2d2e0e1a8825ab7cc43e30dc64d77396ae014469a308c10deea0f9607680ff3a9328b747c82acccd5156e9d9c07cde SHA512 27798eba3bc430fe3689ecfb6ae38a59f48c39183c8cbd4fea8dca0a92a25941e6ee8b51d70f18498a3b0ef6c2575658299ee36ed6a6a93c7b54548ab64f07ca
EBUILD hyprland-0.30.0.ebuild 2774 BLAKE2B b74b342882ca178e338b03d76f92296f3aa2dc2df4ea48da9aa71cfb4cea90b495301d2bc4ee963a80cc765f631f5a493202d280f37763661d43cb7d37c625ed SHA512 8e582ef86485186a8675db8fdb6e8192cbcc04b994d1334504ccb61bbe9ca0fcbb2e297f23768caf88469006b8896b9c82798874d923ba072ac2a9e4abec2111
+EBUILD hyprland-0.31.0-r1.ebuild 3416 BLAKE2B 354b485417698a30376a62a683c9a94119a1febdfaa0bcaae756dc7c9e9c2b55f7880a266e03e1ccba93620ec33d94fb37369069f88dd1d0a59a5ba33171f62a SHA512 371014cee300671bd0c4a71f1536eb2c4004384ece4c435e5912f34f44aab44eabeddafb22c6716ac41982c617c208bb2ec18a25c2bdedb063f2dfedfbdbd27d
EBUILD hyprland-0.31.0.ebuild 2775 BLAKE2B 4ab232a342300d1c1fa9555f719f5b552509e225eb6dc478b934fe61542073a0ea3e057c4e4a82111d9616185635cd40f4bc0fa97313fe7eebd5990bb3d7bda4 SHA512 76058fa817e71b62680f5be7c458b4cd31b28be8c00c30e87a3a91edf6072a878f7df52546c2c22501ea0e3fc6040f5b8297100602f30ee8466a382025533ccc
MISC metadata.xml 716 BLAKE2B fc5248c809b9b5bf1002e3d82ff80f595b8e613d09e5541f1a0151c3ea2c117376d25fa5a40c85d254533708d9eff5339bd329b42118e87ca49e22e55c0c5d7b SHA512 31252ced2546f3686f17259aabfe9273af14f7efaf3fa0bfb446c65c6d9478be3a23c531e0ac463f27fe1d50842f6f126f32e47a8a03a345306297e182952e98
diff --git a/gui-wm/hyprland/hyprland-0.31.0-r1.ebuild b/gui-wm/hyprland/hyprland-0.31.0-r1.ebuild
new file mode 100644
index 000000000000..0e5c0a9d3180
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.31.0-r1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-source"
+
+KEYWORDS="~amd64"
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd video_cards_nvidia"
+
+# bundled wlroots has the following dependency string according to included headers.
+# wlroots[drm,gles2-renderer,libinput,x11-backend?,X?]
+# enable x11-backend with X and vice versa
+WLROOTS_RDEPEND="
+ >=dev-libs/libinput-1.14.0:=
+ dev-libs/libliftoff
+ >=dev-libs/wayland-1.22
+ media-libs/libdisplay-info
+ media-libs/libglvnd
+ media-libs/mesa[egl(+),gles2]
+ sys-apps/hwdata:=
+ sys-auth/seatd:=
+ >=x11-libs/libdrm-2.4.114
+ x11-libs/libxkbcommon
+ >=x11-libs/pixman-0.42.0
+ virtual/libudev:=
+ X? (
+ x11-base/xwayland
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-renderutil
+ x11-libs/xcb-util-wm
+ )
+"
+WLROOTS_DEPEND="
+ >=dev-libs/wayland-protocols-1.32
+"
+WLROOTS_BDEPEND="
+ dev-util/glslang
+ dev-util/wayland-scanner
+"
+
+RDEPEND="
+ ${WLROOTS_RDEPEND}
+ dev-libs/glib:2
+ dev-libs/libinput
+ dev-libs/wayland
+ media-libs/libglvnd
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ X? (
+ x11-libs/libxcb:0=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ ${WLROOTS_DEPEND}
+ dev-libs/hyprland-protocols
+ >=dev-libs/wayland-protocols-1.25
+"
+BDEPEND="
+ ${WLROOTS_BDEPEND}
+ || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+ app-misc/jq
+ dev-util/cmake
+ dev-util/wayland-scanner
+ dev-vcs/git
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/hyprland-0.31.0-fix-log-headers.patch"
+)
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-13 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
+ eerror "Hyprland requires >=sys-devel/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}
+
+src_prepare() {
+ if use video_cards_nvidia; then
+ cd "${S}/subprojects/wlroots" || die
+ eapply "${S}/nix/patches/wlroots-nvidia.patch"
+ cd "${S}" || die
+ fi
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature legacy-renderer legacy_renderer)
+ $(meson_feature systemd)
+ $(meson_feature X xwayland)
+ $(meson_feature X wlroots:xwayland)
+ -Dwlroots:backends=drm,libinput$(usev X ',x11')
+ -Dwlroots:xcb-errors=disabled
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install --skip-subprojects wlroots
+ meson_src_install --tags devel
+
+ # Wlroots headers are required by hyprland-plugins and the pkgconfig file expects
+ # them to be in /usr/include/hyprland/wlroots, despite this they aren't installed there.
+ # Ideally you could override includedir per subproject and the install tags would
+ # be granular enough to only install headers. But its not requiring this.
+ mkdir "${ED}"/usr/include/hyprland/wlroots || die
+ mv "${ED}"/usr/include/wlr "${ED}"/usr/include/hyprland/wlroots || die
+ # devel tag includes wlroots .pc and .a files still
+ rm -rf "${ED}"/usr/$(get_libdir)/ || die
+}