summaryrefslogtreecommitdiff
path: root/gui-wm/hikari
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /gui-wm/hikari
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'gui-wm/hikari')
-rw-r--r--gui-wm/hikari/Manifest4
-rw-r--r--gui-wm/hikari/hikari-2.3.2.ebuild72
-rw-r--r--gui-wm/hikari/metadata.xml13
3 files changed, 82 insertions, 7 deletions
diff --git a/gui-wm/hikari/Manifest b/gui-wm/hikari/Manifest
index 1c0d4dbed465..bb5bea8d2be8 100644
--- a/gui-wm/hikari/Manifest
+++ b/gui-wm/hikari/Manifest
@@ -1,4 +1,6 @@
AUX hikari-2.2.1-pkgconfig.patch 2675 BLAKE2B c5313156b4c9fb2871d3c5ee7b0b4532235c9ccf36747d5b6f2b519f1cd9f9fc65b366f404c4c30842286c3656ee75a59ebf214c6b06f4ad3be188d312f9b371 SHA512 d9e782c9bc7038e452a2a2956dd7e812484d8e8cbbd73018dff45a91522594ebd9cfa3e8737b66c143ab7a8cfd04e360b41b9cf4f037a8f215e1986745467378
DIST hikari-2.2.2.tar.gz 1019277 BLAKE2B 3cf76f0849cbc80493b6f078ec32b2a6f8e47f12ff3a015132e662dc2382f4071661126bf111550e5ab31eee69c54adaf10ec6ef64b681d7859771a180d30652 SHA512 53b1cb8b8e5fdbabcdcb5ba8af31f1cc66e89c8e94d217b7d1f89f0c733fb7969a251ef5090296b7aeca064aafc60d12878f3f2dbffa17e1fb24609e5549b4f1
+DIST hikari-2.3.2.tar.gz 1022093 BLAKE2B 8e4df4377728cc1feab3509588a9f2d5138af6e3175682672eedce4ca45d5bb9b7e56568a860871b319b3ff1213468f38f0b6253927f6ab4b905dd495c05c53e SHA512 b7485be089064dd19c4614f60066b3f7b2f322328fa771d4383db27656695746fb00ab534cc754929141c23b7556992391529e537e0522080177068f3d0e2954
EBUILD hikari-2.2.2-r1.ebuild 1721 BLAKE2B 752691578c78743032d04b5773e6165a384fa83fb2945d8d0b95177cf36605a2e482df839b23fed74a29ee5071bb15b8aff773f45e3de45e765cf49a9296b6f1 SHA512 684e98f99c7a12034bf02b178d75fe0b6086517c1d7b1876036931cb162f52de5fec39e82bff9ba17041abd6b7566fae06e1510094bc81cbb35f56e1c90501be
-MISC metadata.xml 1046 BLAKE2B 684215385f117eed8604eb2a11be44e52db4618298ef7e0adeef2f5ea605286e87ee92435ae5143d8377368bc0e7410e6055893dd5caabce5e54260327f4d4f2 SHA512 1b7bac644575c4545fc57e72d7ba44d58a8c6c98bf44216cba1d5bddb4e9ebd554aef5f8f6d427f67b48a6d1f87216407b8fd5b49eccc362dfbc3b8705d198a2
+EBUILD hikari-2.3.2.ebuild 1422 BLAKE2B 312e7affe946ab5060348d2ed20e35b42d69298f9aec161b0652826ec92a46eb88e2fee51aa2ad644558d3ed2872bfde290be7d91424ed2b57f44966f92ea01b SHA512 09a16c5af0ed7239de799464c33021acb5acede8e28831fac0f68ad21167c575e7f3ce63f221578fc7d8581be37842d08a8f47f658e5e9c2dd10a36c4a30d610
+MISC metadata.xml 1123 BLAKE2B 87bac2642347d19894041219a36a4dd0cdd74ff8f7715de61a57076db05734d343bc4a8c97cf2ed60ed170f00a1c6bbf96308198cbf5cc4db3649a52593b4835 SHA512 ca3221cd78298350f5cc7097ba029b69901f3bdcb45c405ce6b2db48dea3e9f1cb79eaed4f7839bb9c14e6f603c5d0a2a728f5d10c9966f210e01f1237109227
diff --git a/gui-wm/hikari/hikari-2.3.2.ebuild b/gui-wm/hikari/hikari-2.3.2.ebuild
new file mode 100644
index 000000000000..119bd1fe8f0c
--- /dev/null
+++ b/gui-wm/hikari/hikari-2.3.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing toolchain-funcs
+
+DESCRIPTION="Wayland compositor inspired by CWM"
+HOMEPAGE="https://hikari.acmelabs.space/"
+SRC_URI="https://hikari.acmelabs.space/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X suid"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/libinput:=
+ dev-libs/libucl
+ dev-libs/wayland
+ gui-libs/wlroots:0/14[X?]
+ sys-libs/pam
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-misc/xkeyboard-config"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/wayland-protocols"
+BDEPEND="
+ dev-util/wayland-scanner
+ sys-devel/bmake
+ virtual/pkgconfig"
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+
+ local bmake=(
+ bmake -j$(makeopts_jobs)
+ ETC_PREFIX="${EPREFIX}"
+ CFLAGS_EXTRA="${CFLAGS} ${CPPFLAGS}"
+ LDFLAGS_EXTRA="${LDFLAGS}"
+ VERSION=${PV}
+ -DWITH_GAMMACONTROL
+ -DWITH_LAYERSHELL
+ -DWITH_POSIX_C_SOURCE
+ -DWITH_SCREENCOPY
+ -DWITH_VIRTUAL_INPUT
+ $(usev X -DWITH_XWAYLAND)
+ )
+
+ # empty flags to avoid duplicates (some parts use only _EXTRA, others both)
+ echo "${bmake[*]}"
+ CFLAGS= LDFLAGS= "${bmake[@]}" || die
+}
+
+src_install() {
+ local bmake=(
+ bmake install
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ ETC_PREFIX="${EPREFIX}"
+ $(usev suid -DWITH_SUID)
+ )
+
+ echo "${bmake[*]}"
+ "${bmake[@]}" || die
+}
diff --git a/gui-wm/hikari/metadata.xml b/gui-wm/hikari/metadata.xml
index 9cd2500a639d..8446f7621df3 100644
--- a/gui-wm/hikari/metadata.xml
+++ b/gui-wm/hikari/metadata.xml
@@ -1,12 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <longdescription>
- hikari is a minimalistic wayland window manager
- based on wlroots trying inspired by the simplicity
- of CWM in the X days. It aims stay out of your way
- and focus more on the task than the windows.
- </longdescription>
<maintainer type="person" proxied="yes">
<email>gentoo@aisha.cc</email>
<name>Aisha Tammy</name>
@@ -15,7 +9,14 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <longdescription>
+ Hikari is a minimalistic wayland window manager
+ based on wlroots trying inspired by the simplicity
+ of CWM in the X days. It aims stay out of your way
+ and focus more on the task than the windows.
+ </longdescription>
<use>
+ <flag name="X">Enable support for X11 applications (XWayland)</flag>
<flag name="gamma">add gamma control for redshift</flag>
<flag name="layershell">add support for wayland apps using layer shell</flag>
<flag name="screencopy">add support for screen grabbing</flag>