summaryrefslogtreecommitdiff
path: root/gui-wm/dwl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-25 05:24:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-25 05:24:31 +0100
commit4eda0fe5576868e6c7f97b51aa1c279ff8cd320c (patch)
treec0397a47938edbcb6e46e34fe4f0defa3e4db920 /gui-wm/dwl
parentb914cf9afa036a8ab23e8cb4cf7df1acd4a1bd44 (diff)
gentoo auto-resync : 25:09:2023 - 05:24:31
Diffstat (limited to 'gui-wm/dwl')
-rw-r--r--gui-wm/dwl/Manifest6
-rw-r--r--gui-wm/dwl/dwl-0.4.ebuild79
-rw-r--r--gui-wm/dwl/dwl-9999-r1.ebuild76
-rw-r--r--gui-wm/dwl/dwl-9999.ebuild76
-rw-r--r--gui-wm/dwl/files/dwl.desktop5
-rw-r--r--gui-wm/dwl/metadata.xml16
6 files changed, 258 insertions, 0 deletions
diff --git a/gui-wm/dwl/Manifest b/gui-wm/dwl/Manifest
new file mode 100644
index 000000000000..af8cb37c44dd
--- /dev/null
+++ b/gui-wm/dwl/Manifest
@@ -0,0 +1,6 @@
+AUX dwl.desktop 75 BLAKE2B 696aa9fd4f0f8c3f67d6899474ba4759b6b81179dd0ec73162203b7bead322b4a679c4e1d3724d44648755d3c31f0a8d6b1e866232f267c3b7152238f2eec32b SHA512 fc8d6e93b6849512f0cafe7e98ab33fb2f6a5c0ae586e95358f03491a6f9736b54171f291de47d38a5ba7cd8a6eca1a36471842d4cc4c4f65086e98fdf4795f8
+DIST dwl-0.4.gh.tar.gz 54718 BLAKE2B 22aac990ed71bcb0be0e2ded7d335c3fb2ffa56d0185e4f15119f54d7dd28ce34c3d8888320f0d448d66c0dd829c036f22367706c4db1bd4a7e2db2dadf410fd SHA512 8db7e4d9559f57232f9dedc1645458cf504c1d56af93bfe3930ab4734dfe898b0ef7b86c987ec908afa43473fab4bef424abd0036645461dbefeb6ac3e2d0c5f
+EBUILD dwl-0.4.ebuild 1505 BLAKE2B fef0d5e1885b71021c1d2b640d4a0aac40644079947b8b365dd370504f3289f8f94c652c9cb6ae8e13a3a4117ed1734bf518f895f6cb5c6c0a051b9a802fe153 SHA512 71d7736f2bb10bd4b4aa34331259ddd66926313b42ea8855ab93a2e98376de5c2dbb19a5b98b17e36b01a8e531a281ddb75402b0f75f43eed0a23a75d2712ab1
+EBUILD dwl-9999-r1.ebuild 1442 BLAKE2B 31440f38d698cc1123f441d2eeaccc64882806c8e7658c23e3c7967460797bb394f5db62a94c1a4312288a3388da11d1bd24deb8729feb4863ddaaa85ea2dff6 SHA512 47d8d2699bdc37dfd774be3533040e639728f190725c0080798c128d98a307e8053d32051ee737496c2d6c34540bfc629dbd747ef0320f6cac51e3e27bc9bf59
+EBUILD dwl-9999.ebuild 1435 BLAKE2B 2542e18fef8a3a0d7bfb711eb6b010fb07aafc83353fb32cb7f292c1115cce1a274db8926bb9f1630ca64f9d021dd8c9883012f4932a19e42b41e625bbf3c0cd SHA512 e7efbf00fdfe985f16a5aabc0ec6b3fad300f96318ae83301f0db03f95fd46193c07a979797b534b2b2b02601303f486f542e7eb2e28c5b34fe7338e9a6c20e3
+MISC metadata.xml 605 BLAKE2B 5187a02016a0e6f1026498e99cd81110b594e0fe78705f4a382326a3af9f5897e44356da176643a152b502040558d50bad4456490ae351358952b105778eb552 SHA512 68efa2356b6ef06bf968d1510ecbe087ffdb5bbb9d73944c5e319e2f7f10742aa9516cfc25116975322d9a46ea26332f473cb343a6b58c881c02faf614e3d1be
diff --git a/gui-wm/dwl/dwl-0.4.ebuild b/gui-wm/dwl/dwl-0.4.ebuild
new file mode 100644
index 000000000000..784102072287
--- /dev/null
+++ b/gui-wm/dwl/dwl-0.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit savedconfig toolchain-funcs
+
+MY_P="${PN}-v${PV}"
+WLROOTS_SLOT="0/16"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/djpohly/dwl"
+ inherit git-r3
+
+ # 9999-r0: main (latest stable wlroots release)
+ # 9999-r1: wlroots-next (wlroots-9999)
+ case ${PVR} in
+ 9999)
+ EGIT_BRANCH=main
+ ;;
+ 9999-r1)
+ EGIT_BRANCH=wlroots-next
+ WLROOTS_SLOT="0/9999"
+ ;;
+ esac
+else
+ SRC_URI="https://github.com/djpohly/${PN}/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="dwm for Wayland"
+HOMEPAGE="https://github.com/djpohly/dwl"
+
+LICENSE="CC0-1.0 GPL-3+ MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+ dev-libs/libinput:=
+ dev-libs/wayland
+ gui-libs/wlroots:${WLROOTS_SLOT}[X(-)?]
+ x11-libs/libxkbcommon
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm
+ )
+"
+
+# uses <linux/input-event-codes.h>
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ restore_config config.h
+
+ default
+}
+
+src_compile() {
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)" CC="$(tc-getCC)" \
+ XWAYLAND="$(usev X -DXWAYLAND)" XLIBS="$(usev X "xcb xcb-icccm")" dwl
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md
+
+ insinto /usr/share/wayland-session
+ doins "${FILESDIR}/dwl.desktop"
+
+ save_config config.h
+}
diff --git a/gui-wm/dwl/dwl-9999-r1.ebuild b/gui-wm/dwl/dwl-9999-r1.ebuild
new file mode 100644
index 000000000000..8715e2f22781
--- /dev/null
+++ b/gui-wm/dwl/dwl-9999-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit savedconfig toolchain-funcs
+
+MY_P="${PN}-v${PV}"
+WLROOTS_SLOT="0/16"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/djpohly/dwl"
+ inherit git-r3
+
+ # 9999-r0: main (latest stable wlroots release)
+ # 9999-r1: wlroots-next (wlroots-9999)
+ case ${PVR} in
+ 9999)
+ EGIT_BRANCH=main
+ ;;
+ 9999-r1)
+ EGIT_BRANCH=wlroots-next
+ WLROOTS_SLOT="0/9999"
+ ;;
+ esac
+else
+ SRC_URI="https://github.com/djpohly/${PN}/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="dwm for Wayland"
+HOMEPAGE="https://github.com/djpohly/dwl"
+
+LICENSE="CC0-1.0 GPL-3+ MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+ dev-libs/libinput:=
+ dev-libs/wayland
+ gui-libs/wlroots:${WLROOTS_SLOT}[X(-)?]
+ x11-libs/libxkbcommon
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm
+ )
+"
+
+# uses <linux/input-event-codes.h>
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.32
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ restore_config config.h
+
+ default
+}
+
+src_compile() {
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)" CC="$(tc-getCC)" \
+ XWAYLAND="$(usev X -DXWAYLAND)" XLIBS="$(usev X "xcb xcb-icccm")" dwl
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md
+
+ save_config config.h
+}
diff --git a/gui-wm/dwl/dwl-9999.ebuild b/gui-wm/dwl/dwl-9999.ebuild
new file mode 100644
index 000000000000..bbea45cfc16a
--- /dev/null
+++ b/gui-wm/dwl/dwl-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit savedconfig toolchain-funcs
+
+MY_P="${PN}-v${PV}"
+WLROOTS_SLOT="0/16"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/djpohly/dwl"
+ inherit git-r3
+
+ # 9999-r0: main (latest stable wlroots release)
+ # 9999-r1: wlroots-next (wlroots-9999)
+ case ${PVR} in
+ 9999)
+ EGIT_BRANCH=main
+ ;;
+ 9999-r1)
+ EGIT_BRANCH=wlroots-next
+ WLROOTS_SLOT="0/9999"
+ ;;
+ esac
+else
+ SRC_URI="https://github.com/djpohly/${PN}/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="dwm for Wayland"
+HOMEPAGE="https://github.com/djpohly/dwl"
+
+LICENSE="CC0-1.0 GPL-3+ MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+ dev-libs/libinput:=
+ dev-libs/wayland
+ gui-libs/wlroots:${WLROOTS_SLOT}[X(-)?]
+ x11-libs/libxkbcommon
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm
+ )
+"
+
+# uses <linux/input-event-codes.h>
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ restore_config config.h
+
+ default
+}
+
+src_compile() {
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)" CC="$(tc-getCC)" \
+ XWAYLAND="$(usev X -DXWAYLAND)" XLIBS="$(usev X "xcb xcb-icccm")" dwl
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md
+
+ save_config config.h
+}
diff --git a/gui-wm/dwl/files/dwl.desktop b/gui-wm/dwl/files/dwl.desktop
new file mode 100644
index 000000000000..e1380f7aa20d
--- /dev/null
+++ b/gui-wm/dwl/files/dwl.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Name=dwl
+Comment=dwm for Wayland
+Exec=dwl
+Type=Application
diff --git a/gui-wm/dwl/metadata.xml b/gui-wm/dwl/metadata.xml
new file mode 100644
index 000000000000..4ebf54b3ad36
--- /dev/null
+++ b/gui-wm/dwl/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>leohdz172@proton.me</email>
+ <name>Leonardo Hernández Hernández</name>
+ <description>Additionally the upstream maintainer</description>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">djpohly/dwl</remote-id>
+ </upstream>
+</pkgmetadata>