summaryrefslogtreecommitdiff
path: root/gui-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /gui-libs
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/Manifest.gzbin1390 -> 1561 bytes
-rw-r--r--gui-libs/wf-config/Manifest4
-rw-r--r--gui-libs/wf-config/metadata.xml18
-rw-r--r--gui-libs/wf-config/wf-config-0.4.0.ebuild46
-rw-r--r--gui-libs/wf-config/wf-config-9999.ebuild46
-rw-r--r--gui-libs/wlroots/Manifest2
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild1
7 files changed, 116 insertions, 1 deletions
diff --git a/gui-libs/Manifest.gz b/gui-libs/Manifest.gz
index 13d735cad723..5cbc848c311f 100644
--- a/gui-libs/Manifest.gz
+++ b/gui-libs/Manifest.gz
Binary files differ
diff --git a/gui-libs/wf-config/Manifest b/gui-libs/wf-config/Manifest
new file mode 100644
index 000000000000..35058fd063f5
--- /dev/null
+++ b/gui-libs/wf-config/Manifest
@@ -0,0 +1,4 @@
+DIST wf-config-0.4.0.tar.xz 64108 BLAKE2B 83999dd246e6b7a6c54bbbcdf7abf08767b31bd29e75cd41d9844c4b98c66fbe787b7d87ec433e2c5e860e476f4f621116aac16c7f3f56903ee1689c5d1bc6c9 SHA512 30358ada695012b9f4be835f2b2d032e0d8d52c3e9d49d39ae975c74bc0cac188341e507124a088d8cdb3d62c77645a7d435262d15a6cc604b4738861362a299
+EBUILD wf-config-0.4.0.ebuild 816 BLAKE2B e643c9b57ce140a58213ae698a49629ab2b771d3a8d43ba0f1ac9da6442b07215308e72a3eb07f027422303838c2b8ac1ead89a55fef9095a67fab96921d230d SHA512 83bfd3e556031b561a64d3e2cedf8d73e6c218c595d91654dcf264063d4df0ab2478fcf5b5d6ca3832366a59260593066df5fb0af99eef919ca8f1a734b1ef99
+EBUILD wf-config-9999.ebuild 816 BLAKE2B e643c9b57ce140a58213ae698a49629ab2b771d3a8d43ba0f1ac9da6442b07215308e72a3eb07f027422303838c2b8ac1ead89a55fef9095a67fab96921d230d SHA512 83bfd3e556031b561a64d3e2cedf8d73e6c218c595d91654dcf264063d4df0ab2478fcf5b5d6ca3832366a59260593066df5fb0af99eef919ca8f1a734b1ef99
+MISC metadata.xml 635 BLAKE2B 9152d0eb342e1cd50821c22beb370e0fb62acb40edefc5f0c2bb8f2c61852239f596975692c6ab6cbb36304a074357ee567f807577facd768025e9452072db4b SHA512 acdaed58e3430342773bec4dff0c0879c371b4cd26fb8ddf84606fd3ab2eee3f4d19b1a471b843e6880d2678f47fdf8533e872c37357639094084a9480cd91ed
diff --git a/gui-libs/wf-config/metadata.xml b/gui-libs/wf-config/metadata.xml
new file mode 100644
index 000000000000..cf54d732b433
--- /dev/null
+++ b/gui-libs/wf-config/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Library for creating and parsing the configuration
+ file for the WayfireWM while also allowing you to
+ make changes in the configuration and reload them on
+ the fly.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-libs/wf-config/wf-config-0.4.0.ebuild b/gui-libs/wf-config/wf-config-0.4.0.ebuild
new file mode 100644
index 000000000000..328ec1807428
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ gui-libs/wlroots
+ media-libs/glm
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile () {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
diff --git a/gui-libs/wf-config/wf-config-9999.ebuild b/gui-libs/wf-config/wf-config-9999.ebuild
new file mode 100644
index 000000000000..328ec1807428
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ gui-libs/wlroots
+ media-libs/glm
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile () {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index 63572b27b891..d3075bdfdeb2 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -3,5 +3,5 @@ DIST wlroots-0.10.0.tar.gz 454540 BLAKE2B 0d2326a62267019001be5f0d79c7b5c937ed20
DIST wlroots-0.10.1.tar.gz 455232 BLAKE2B 0f4def61d8501b7746ccc589d59586b3641340fb7633b0c4a7b518f1b1b5285c1ee71fb629aa0a0e649c15a4ae69b5cfbc7a034c96e545765a96ddda35f10609 SHA512 e1af5a5b6484b5f4060090e13d22d699d5aaa6926e1a6b1043d2b900f88a002ed67dacf8498f23ed3008bf8a35500f415f95b3dbcf50de5da354f309f9161d58
EBUILD wlroots-0.10.0.ebuild 1882 BLAKE2B c438d4d1e895ad8c539ccfd69f32a80ceb609b139e2b14929f6e5d173184e01026978531919805b3602530813ecbbc5abe5393933b1fe34bf374b86f830129f5 SHA512 269a1ec002a5e80bc5384833025135eadba865e106009d214fa24271066344d1a8876d7b1832483a78ffdd59f1b2e2d009c26eeee1370027132ddc16bd12ba7b
EBUILD wlroots-0.10.1.ebuild 1949 BLAKE2B 3e7e878846b1d2911b3fe2f34483757e48c918fe33ecf7b84cd664992b070bbb96a2e1495a85c7e58631231708384116b251ebf4f5c41f1f1820c6090732ae05 SHA512 28a91c1e0c5ed36e4b6f4c47d8f8609b8762936172b5ad22dd464e76041690930b80dbee5af01d4680ad6215af8ef55aa69cea3fc9e2d98b2e2fbbc58859c29e
-EBUILD wlroots-9999.ebuild 1843 BLAKE2B f6e787d25eb5f8eba9d2e89633f81102838ebf66078cfa13a77d0d2ea4f9855296071aa0efb69ca8cb4f90af02c813a2b9e31ca262318240df7464425ed35f55 SHA512 6e7d5fbf03074fea6472cd1ce843778dff9933130dc4ce667124b53db4b84e4eab235215ff6eeedd0f678cf7f630c2a04159c6531bc209bd95c2588ab6f19471
+EBUILD wlroots-9999.ebuild 1868 BLAKE2B 0a3ec528911987688a69ac334fc9a4d9c50306e1bfd4df5c7a7a4df6c8bc057f2ff4454e8d3aa21b3217e9b6b8b08620cec6c69d9c7a6e8bcf12ceb46e1f14e6 SHA512 7b00c440de3dea8082e82c52975afefc209495e294bb905be8bce0ea2b42f1546fe5f837c01c456ebeb1d7d7da17c8f3eae5dd2c74ab361721b026126d966f66
MISC metadata.xml 1611 BLAKE2B a52787db83324cc424c28255d7a6db05fa6ea7f92f2d5d7cd6ac4121e89f77b9e642be4ecccdb5b75be2f4ac9b1434f98d40743ae86be8044165f70cc59add65 SHA512 b04fbd1afea30e057f0feea17d05195fb76bf872aa80b5d5d6f20ac47a99c08c3703bee65b2352587a6ac588974a7da375228b439c82f861bdefa41537278a99
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index f0caa7de4f5a..35d3047c671d 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -44,6 +44,7 @@ RDEPEND="
"
BDEPEND="
>=dev-libs/wayland-protocols-1.17
+ >=dev-util/meson-0.54.0
virtual/pkgconfig
"