summaryrefslogtreecommitdiff
path: root/gui-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /gui-libs
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/Manifest.gzbin3121 -> 3122 bytes
-rw-r--r--gui-libs/wlroots/Manifest4
-rw-r--r--gui-libs/wlroots/wlroots-0.14.0.ebuild68
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild2
4 files changed, 72 insertions, 2 deletions
diff --git a/gui-libs/Manifest.gz b/gui-libs/Manifest.gz
index 75f9ce9c52c0..05e9ad167c7f 100644
--- a/gui-libs/Manifest.gz
+++ b/gui-libs/Manifest.gz
Binary files differ
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index a546fca45f8c..b899bcbef100 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,4 +1,6 @@
DIST wlroots-0.13.0.tar.gz 503575 BLAKE2B bfcd40ea5cf9f85157b9a44a4a49f0fef1c82c2199ee428316b578e8d53cc39276b42d0a2c4b6b94d1a1f49df5d312539cdf4d053ea2472e0de93254e39dc015 SHA512 1c942a6b8a628383e2b68cd9096d3525021347c5c363a8239a3b4fb0d5736ffcd3e2c1333fdd7d95ecf214dd04bf01062b4f1b4fbbcd88d1d086a55261ca0c82
+DIST wlroots-0.14.0.tar.gz 505461 BLAKE2B d2fa28f64014ef9d840838cb5938af23f6f6b211b62dc352d0d5bb824ccaa7d7a85531e1eca14feeb06d31d59955ff9a913e40a73cad21ed1ebfe76ada39d558 SHA512 83f001133cb4b11a72bb9532b7321655428826662848f67de8e3220a33d9dff4d37c859602bdc319929949d387d014a257b0347039a6649944d7b084c76bb611
EBUILD wlroots-0.13.0.ebuild 1950 BLAKE2B 680b6a39783806291c950dae086800ead41f337ed611b6d86655bf342bb80e13b63f97a32f11f58c8875e4ee14b7f53e1d122fe69fbb67c91f998baab57da70a SHA512 8497307be27fe7884384986cea09a5cead3fa25a205ec13eec37026ebf5bbbf89aab1d9384970b4a1b4798589c3c30205567979d0accd50b5b61efd17a4f5e82
-EBUILD wlroots-9999.ebuild 1502 BLAKE2B cc3fe493692c7063ceb2d505603b3d508cc88807e4608d653afbc19e94d80261b7279ca1d44fda8ad41afcb4f29ac20f7a13607b5d5aa1a6d3685e76e8536745 SHA512 577162e7a4f5181b196f7cf8cd209fa0099b45ef8b6bcfdb32841f17ae4748ebd139107d5667de1c2799876d522a7f31a681cfca85af9dd79e7ccd2cf6c11e05
+EBUILD wlroots-0.14.0.ebuild 1502 BLAKE2B cc3fe493692c7063ceb2d505603b3d508cc88807e4608d653afbc19e94d80261b7279ca1d44fda8ad41afcb4f29ac20f7a13607b5d5aa1a6d3685e76e8536745 SHA512 577162e7a4f5181b196f7cf8cd209fa0099b45ef8b6bcfdb32841f17ae4748ebd139107d5667de1c2799876d522a7f31a681cfca85af9dd79e7ccd2cf6c11e05
+EBUILD wlroots-9999.ebuild 1502 BLAKE2B 5d51d77f6c908a0d12d322e420ee4e259d8907ab70468dc33d501285650b9869ffc5689c83e5c42540671d93becfbf581eafb23af7bcf24c7f0e1aa363ff321c SHA512 1f5f2ddf111d0cd85760613b8bd386e5cce9fbd55a56de97d76ac2d19e5331453f73d6d66b416afc7d723a04dff7904d9cbfcc393b7192ae052fd8fd61432285
MISC metadata.xml 1719 BLAKE2B 363f75063f67b87b9447f4aafa37c528a6b418f8bf8039453c79a9d8a7e4c9bfb60c36b181f311f21dc26c854b51d98b060fd3367d0f45787420c61cec426577 SHA512 a75cb0f8f9b3ce1576c4e688b0abff4f2c68e57a4661b1ffb46a1d3b0d6edd3cea2a8bcf69558ff9210d654daba38c7fe5d8b1ad2c1cacaa78387f6623089633
diff --git a/gui-libs/wlroots/wlroots-0.14.0.ebuild b/gui-libs/wlroots/wlroots-0.14.0.ebuild
new file mode 100644
index 000000000000..cb80b4e42fd5
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.14.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://github.com/swaywm/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+ inherit git-r3
+ SLOT="0/9999"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ SLOT="0/14"
+fi
+
+LICENSE="MIT"
+IUSE="x11-backend X"
+
+DEPEND="
+ >=dev-libs/libinput-1.14.0:0=
+ >=dev-libs/wayland-1.19.0
+ >=dev-libs/wayland-protocols-1.17.0
+ media-libs/mesa[egl,gles2,gbm]
+ sys-auth/seatd:=
+ virtual/libudev
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ x11-backend? ( x11-libs/libxcb:0= )
+ X? (
+ x11-base/xorg-server[wayland]
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.17
+ >=dev-util/meson-0.56.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
+ local emesonargs=(
+ "-Dxcb-errors=disabled"
+ "-Dexamples=false"
+ "-Dwerror=false"
+ "-Drenderers=gles2"
+ -Dxwayland=$(usex X enabled disabled)
+ -Dx11-backend=$(usex x11-backend enabled disabled)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index cb80b4e42fd5..37d74dc38438 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -44,7 +44,7 @@ RDEPEND="
"
BDEPEND="
>=dev-libs/wayland-protocols-1.17
- >=dev-util/meson-0.56.0
+ >=dev-util/meson-0.58.1
virtual/pkgconfig
"