summaryrefslogtreecommitdiff
path: root/gui-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /gui-libs
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/Manifest.gzbin2618 -> 2962 bytes
-rw-r--r--gui-libs/egl-wayland/Manifest5
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild52
-rw-r--r--gui-libs/egl-wayland/files/10_nvidia_wayland.json6
-rw-r--r--gui-libs/egl-wayland/files/egl-wayland-1.1.6-remove-werror.patch7
-rw-r--r--gui-libs/egl-wayland/metadata.xml15
-rw-r--r--gui-libs/eglexternalplatform/Manifest3
-rw-r--r--gui-libs/eglexternalplatform/eglexternalplatform-1.1.ebuild30
-rw-r--r--gui-libs/eglexternalplatform/metadata.xml15
-rw-r--r--gui-libs/gtk-layer-shell/Manifest2
-rw-r--r--gui-libs/gtk-layer-shell/metadata.xml4
11 files changed, 136 insertions, 3 deletions
diff --git a/gui-libs/Manifest.gz b/gui-libs/Manifest.gz
index 6d27544de634..1c8ef6de390d 100644
--- a/gui-libs/Manifest.gz
+++ b/gui-libs/Manifest.gz
Binary files differ
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
new file mode 100644
index 000000000000..885d3484516d
--- /dev/null
+++ b/gui-libs/egl-wayland/Manifest
@@ -0,0 +1,5 @@
+AUX 10_nvidia_wayland.json 115 BLAKE2B b10206c742e8966d1192b9b0604137e6b296d2be74a437841c63844c0716343578b11565a34fb4c534d5908c0b5775305581b68039a6ff9ed7421c9d385a2b7a SHA512 1a611ac0fc2762d94661efc28fa58d57a821185afa7589158d1b8d503bd7361ba1b5029302550134ed1787c2bf90e2ea8afbf3bdefbfe268d8cf13d2f340fb47
+AUX egl-wayland-1.1.6-remove-werror.patch 251 BLAKE2B 12a14b185f9b1cb3a42226708642f5b57c2b0eb64d81c96438ee24ac45b950ba588591194648fc8e64e3aa8d2fda9ba2dba63a2f78fc22c00a14d56403bf6839 SHA512 c6c3c4d4f776f44d642d51ab2eed44a0388558b43f2c4c894b6d19bdef40b8a646be43b6b356a3ffa0297e36a48122ef057265db68a8717020abe30906bc8f28
+DIST egl-wayland-1.1.6.tar.gz 48674 BLAKE2B 66f58d4b841ebaaec6c0711e0dae0b3c774a7b0206f9cfd4d9e94a2c05688d563fddbbf9a60247980df00c3c493147e292bc536e2eb56de962f3b34c6215e026 SHA512 81fd3be3f49ad012efd31189d85666e869653f1f4004de4103f4ad13b7fda036cef432d1e30e33664ae423092dc1b86cfd2773d6542bb09d7a74720ba14e0fa4
+EBUILD egl-wayland-1.1.6.ebuild 1285 BLAKE2B 014cdae3321aa8f9a8e38c79f7b32cbfc8cba6c76cac39d024b9a91953792d11c524ed4118e45381a2e45d3c58a0f5e0d05def012395696624395ca8165d17ae SHA512 12ebdf2a45aeef40585c6bab222c2178ed0661b592c28a9820dfece36f448de637d47e0affacbc9432b493a819b9d30b56b157011f2e21cc62e7b7cb1ae2c0ec
+MISC metadata.xml 477 BLAKE2B 406298dc8bb1aabdb3f5dbe507846089c4dfeee1bf4db6e76624c33b369b2f3afd485c91020073aaaf09bc0a3500c0ca6f991b52325478e302c4c7134f009f74 SHA512 cc1b9b630d0751801cb834dafe15003eb370f3984ffeec7d5515eb2972587a5b8bb72b03dabb1e27dcbfc6c509e6974713d0fdcfcb2c96c5737f19e9ebe2ac18
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
new file mode 100644
index 000000000000..931329d094c9
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic meson
+
+DESCRIPTION="EGLStream-based Wayland external platform (for NVIDIA)"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland"
+SRC_URI="https://github.com/NVIDIA/egl-wayland/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/wayland
+ !x11-drivers/nvidia-drivers[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ gui-libs/eglexternalplatform
+ media-libs/libglvnd"
+BDEPEND="dev-util/wayland-scanner"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-werror.patch
+)
+
+src_configure() {
+ # EGLStream is not intended for X11, always build without (bug #777558)
+ append-cppflags -DEGL_NO_X11
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To use EGLStream with x11-drivers/nvidia-drivers, it is necessary to"
+ elog "load the nvidia-drm module with experimental nvidia-drm.modeset=1."
+ elog
+ elog "Can be accomplished by:"
+ elog " echo 'options nvidia-drm modeset=1' > ${EROOT}/etc/modprobe.d/nvidia-drm.conf"
+ elog "...then reloading the module."
+ fi
+}
diff --git a/gui-libs/egl-wayland/files/10_nvidia_wayland.json b/gui-libs/egl-wayland/files/10_nvidia_wayland.json
new file mode 100644
index 000000000000..c08a64112af8
--- /dev/null
+++ b/gui-libs/egl-wayland/files/10_nvidia_wayland.json
@@ -0,0 +1,6 @@
+{
+ "file_format_version" : "1.0.0",
+ "ICD" : {
+ "library_path" : "libnvidia-egl-wayland.so.1"
+ }
+}
diff --git a/gui-libs/egl-wayland/files/egl-wayland-1.1.6-remove-werror.patch b/gui-libs/egl-wayland/files/egl-wayland-1.1.6-remove-werror.patch
new file mode 100644
index 000000000000..ef392d9b5567
--- /dev/null
+++ b/gui-libs/egl-wayland/files/egl-wayland-1.1.6-remove-werror.patch
@@ -0,0 +1,7 @@
+https://bugs.gentoo.org/777546
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -7,3 +7,2 @@
+ add_project_arguments('-Wall', language : 'c')
+-add_project_arguments('-Werror', language : 'c')
+ add_project_arguments('-fvisibility=hidden', language : 'c')
diff --git a/gui-libs/egl-wayland/metadata.xml b/gui-libs/egl-wayland/metadata.xml
new file mode 100644
index 000000000000..cb6ef54fb36c
--- /dev/null
+++ b/gui-libs/egl-wayland/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sudinave@gmail.com</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">NVIDIA/egl-wayland</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-libs/eglexternalplatform/Manifest b/gui-libs/eglexternalplatform/Manifest
new file mode 100644
index 000000000000..aa20d9d4f44b
--- /dev/null
+++ b/gui-libs/eglexternalplatform/Manifest
@@ -0,0 +1,3 @@
+DIST eglexternalplatform-1.1.tar.gz 10372 BLAKE2B f18bd0c5244da34343b3bde8451602b8071972d33139ab4839e7bf68eae6be5fa69a12d5059b4b259bc4eac2e97f46d4d5fa734d48e45b6a6ae69251af86cdf0 SHA512 ee72c928abac060e28515807975a371d3792acd119fa9f9da926ae32105e1e528df8d9a3db57ffac0587b115293ede44997606d9da8e20e7f7061a01dd502748
+EBUILD eglexternalplatform-1.1.ebuild 634 BLAKE2B d7d6e46a0fc50c8be846851a2f021397b192d32c538c2371993f93719dc7655247908870b4efc2e283de9c20bc05b995777523cc11c792ab45879fcc0a4bb90e SHA512 7566e6f37729c1193a889e92f6faacd7d58a4b2adebcdb5a7cb6dd6a67502c8d174578303c745e6013ecc5850842ec11d146cf5d36df933316a42fe87ae66847
+MISC metadata.xml 485 BLAKE2B 9ed0d6b72dd03f636ecaa872e07b1569c0d33644566fdc4910bdadb60b259efe351acc34749869594a3b5b0d448d8716de6dcff491ed730f4cd1ade39bda517d SHA512 feed0ff8d4f301b7214d762c1bbedde2d071862b72e70dd66004bf9c9060e1da556f1322d9cfbb24262b59da962f436764f466c7dadbd2866f3a590d312105e2
diff --git a/gui-libs/eglexternalplatform/eglexternalplatform-1.1.ebuild b/gui-libs/eglexternalplatform/eglexternalplatform-1.1.ebuild
new file mode 100644
index 000000000000..d8cb2dbadf48
--- /dev/null
+++ b/gui-libs/eglexternalplatform/eglexternalplatform-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="EGL External Platform interface"
+HOMEPAGE="https://github.com/NVIDIA/eglexternalplatform"
+SRC_URI="https://github.com/NVIDIA/eglexternalplatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -i "/^inc/s@=@=${EPREFIX}@" eglexternalplatform.pc || die
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins eglexternalplatform.pc
+
+ insinto /usr/include/EGL
+ doins interface/*.h
+
+ einstalldocs
+
+ docinto examples
+ dodoc samples/*.c
+}
diff --git a/gui-libs/eglexternalplatform/metadata.xml b/gui-libs/eglexternalplatform/metadata.xml
new file mode 100644
index 000000000000..c7865d8e5e2a
--- /dev/null
+++ b/gui-libs/eglexternalplatform/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sudinave@gmail.com</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">NVIDIA/eglexternalplatform</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
index 11ae4ef5ddf6..6fd0524bf692 100644
--- a/gui-libs/gtk-layer-shell/Manifest
+++ b/gui-libs/gtk-layer-shell/Manifest
@@ -1,3 +1,3 @@
DIST gtk-layer-shell-0.1.0.tar.xz 34580 BLAKE2B db815d711e53485e00de2e0b7d238f6c66ddac9ca790d5f31c44eed965ad01ee07392d27552ae21bb1eab4905cc1d5f7dad9c10fd059afb43ba85c7ea1af2aa5 SHA512 3788559405a495d43279b20b9d64e1fb0fb9be4125eb3011a623565938246310c2e81cb6d52db111e42a9cd0739bb273ccf7fcb7c52db8b74a1e44108e061c6d
EBUILD gtk-layer-shell-0.1.0-r1.ebuild 840 BLAKE2B 979c1c8f5360f0aa82b30d28cc3619d26670f2af06c76b130dcd56c979d730a5ba114beb84bc38089d85019a81c1c77fba2ac3d9b20d8c3d8670e4932cb1a41d SHA512 730515236b7164a453e46fe0115ff9dde161f7d878564b9240a1e2a20921eccd0532d07aacedf5352cb859e0d0f2aee81840a52fc1dbfe13b1faaab81513ed81
-MISC metadata.xml 332 BLAKE2B 0a31e2eca9df62f77354cfca6ed1aa3a56977bcba959b824afbc31f79f633244165223fe32745efd9eda4eaa3fbd320fd904c8d484e1141c3360b61774d3e332 SHA512 f50943a594c70d084a249e88f5a1f228a6b5d9d03a2def7c7561677519d6b260850a795d1f46c0726d2d0fa2b8e82f41ab8bdc38e63ffe57827bd46c145e028c
+MISC metadata.xml 334 BLAKE2B 6271f17b26b7ba8f4a2a20123b6cb3592a8f948ee99a224780e61cb806994c0cfc99303776a8eabea7caf7cbf440cd035b897f28e1f6d89d38c91f120398cbb5 SHA512 ec49b361da7bba1cb4feec03a0e299e64e9d65115102b79f4969461873efa21506dc06f805c9dc4d23bf1393df51a48d3a607fe441967f64ba47997c774e9b0d
diff --git a/gui-libs/gtk-layer-shell/metadata.xml b/gui-libs/gtk-layer-shell/metadata.xml
index 0aa25c098eef..db80acb31073 100644
--- a/gui-libs/gtk-layer-shell/metadata.xml
+++ b/gui-libs/gtk-layer-shell/metadata.xml
@@ -2,8 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>NP-Hardass@gentoo.org</email>
- <name>NP-Hardass</name>
+ <email>np-hardass@gentoo.org</email>
+ <name>Adam Feldman</name>
</maintainer>
<upstream>
<remote-id type="github">wmww/gtk-layer-shell</remote-id>