summaryrefslogtreecommitdiff
path: root/gui-libs/xdg-desktop-portal-wlr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /gui-libs/xdg-desktop-portal-wlr
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'gui-libs/xdg-desktop-portal-wlr')
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/Manifest2
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/metadata.xml11
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild54
3 files changed, 67 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-wlr/Manifest b/gui-libs/xdg-desktop-portal-wlr/Manifest
new file mode 100644
index 000000000000..e5f9cd1ffd1e
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-wlr/Manifest
@@ -0,0 +1,2 @@
+EBUILD xdg-desktop-portal-wlr-9999.ebuild 1110 BLAKE2B 095863023783374e704e11ec6d3db643294893b877f39fe3b3c5f430b8380ed26fb8f47a62cf900233e42111d79e7b547d7229e9dd5ab3652940c8a57619674c SHA512 f6e7b15f9500200fef370f44a5abfce0a83ba33b08cdd693ffc1cf246cdc28fae2e6dabad34b9c287f13b2ad1e711e1f98c4c63c89eb130b511d95562ffb54ec
+MISC metadata.xml 347 BLAKE2B acd0b0dd1010eab7fcb18925c58a2f41a53704327e1b2419f2fba11b5f2c84eca044b7c1998fd16744c91e58d8cfaaa0c3e7758a892ba380774ea3132a7a4d92 SHA512 6cc79a37a31c38f1b3ab61124b5489fd0b9bfb5852eff1cc21b2285c2c7a83fcca129c9dd04c491cc33e5bcd6d3798e20d791a440d8612841315249eb29ca591
diff --git a/gui-libs/xdg-desktop-portal-wlr/metadata.xml b/gui-libs/xdg-desktop-portal-wlr/metadata.xml
new file mode 100644
index 000000000000..e797b91ba9cc
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-wlr/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <use>
+ <flag name="elogind">Enable support for rootless session via elogind</flag>
+ </use>
+</pkgmetadata>
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
new file mode 100644
index 000000000000..ee6f4d833661
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="xdg-desktop-portal backend for wlroots"
+HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ #KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS=""
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=media-video/pipewire-0.2.9:=
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14:=
+ elogind? ( >=sys-auth/elogind-237 )
+ systemd? ( >=sys-apps/systemd-237 )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=media-video/pipewire-0.2.9:=
+ >=dev-libs/wayland-protocols-1.14
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-DHAVE_SYSTEMD=1")
+ else
+ emesonargs+=("-DHAVE_ELOGIND=1")
+ fi
+
+ meson_src_configure
+}