summaryrefslogtreecommitdiff
path: root/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild')
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild
new file mode 100644
index 000000000000..1aa36ee0f399
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="xdg-desktop-portal backend for wlroots"
+HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ #KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=media-video/pipewire-0.3.2:=
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14:=
+ elogind? ( >=sys-auth/elogind-237 )
+ systemd? ( >=sys-apps/systemd-237 )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=media-video/pipewire-0.3.2:=
+ >=dev-libs/wayland-protocols-1.14
+ >=dev-util/meson-0.50.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}