summaryrefslogtreecommitdiff
path: root/gui-libs/xdg-desktop-portal-lxqt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /gui-libs/xdg-desktop-portal-lxqt
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'gui-libs/xdg-desktop-portal-lxqt')
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/Manifest3
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/metadata.xml11
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.2.0.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-lxqt/Manifest b/gui-libs/xdg-desktop-portal-lxqt/Manifest
new file mode 100644
index 000000000000..d49d24b27e19
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/Manifest
@@ -0,0 +1,3 @@
+DIST xdg-desktop-portal-lxqt-0.2.0.tar.xz 15908 BLAKE2B c149395fa9f8993b20358f7958fe76bc355c42b3229f9287f045eaea456204e1faef28bfeaebcc85bf6ef45e11475adb5aed9af20d5e0a2befba62e22dc2e5b8 SHA512 4c1119340f4483eefe2ddb87ca6503d5213237007fef698765cf8c9e373339cc76ab6f66a0a6f58b605c1bb7e6320aeb815138ea72fad2a56e13cbd7a86bb4c6
+EBUILD xdg-desktop-portal-lxqt-0.2.0.ebuild 744 BLAKE2B 70037c06c63f270341ad82496b96c533ce63ddbc0463bc530546c71c85d1386b146cabbbe4e08eacc150abae5378769e0b840cd861bfd59ba011cde2e02b9b8f SHA512 a95046788de19fb1ae7487092611bbca43d99fd5e72af9b41253730a2509d45de3b0292665d1ef727880c714d9a2541289b130f7d4498ab443855ab8908ac80d
+MISC metadata.xml 330 BLAKE2B d6c8f676536c73e4da1008ade05265ee20a9a93d05cf6b1c4b1c02ab1fd6090426c6476fd9524242618345d46170ef2242ef378f19e8c4ad4156fb291255b30e SHA512 b56fbd10eacdd17845452afcbd63af25046bc763fe2daf102632cd9a0380746c5b7d940ba852b5f7a37ef1ed347bff691a443ba2581ea5c12256dfd8c139fe8c
diff --git a/gui-libs/xdg-desktop-portal-lxqt/metadata.xml b/gui-libs/xdg-desktop-portal-lxqt/metadata.xml
new file mode 100644
index 000000000000..d128d8a4bbd7
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/xdg-desktop-portal-lxqt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.2.0.ebuild b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.2.0.ebuild
new file mode 100644
index 000000000000..0a41e94ab069
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Qt/KF5/libfm-qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~loong ~riscv"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.11.0"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ x11-libs/libfm-qt:=
+"
+RDEPEND="${DEPEND}
+ sys-apps/xdg-desktop-portal
+"