summaryrefslogtreecommitdiff
path: root/gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
commit61f10f985e19dfe20a4d9552902625edd5b6eabb (patch)
tree50db31971b38c4e0358253ef5005058a46fc773e /gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild
parent34dea8e38f88007799629d0a56b12dec480b1d21 (diff)
gentoo resync : 21.06.2021
Diffstat (limited to 'gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild')
-rw-r--r--gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild
new file mode 100644
index 000000000000..03c027d50901
--- /dev/null
+++ b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="WPE backend designed for Linux desktop systems"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/libepoxy[egl]
+ dev-libs/glib:2
+ >=dev-libs/wayland-1.10
+ >=gui-libs/libwpe-1.6:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild_docs=false # hotdoc not packaged
+ )
+
+ meson_src_configure
+}