summaryrefslogtreecommitdiff
path: root/gui-libs/vte-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /gui-libs/vte-common
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'gui-libs/vte-common')
-rw-r--r--gui-libs/vte-common/Manifest2
-rw-r--r--gui-libs/vte-common/vte-common-0.70.3.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/gui-libs/vte-common/Manifest b/gui-libs/vte-common/Manifest
index 1281ffc6168e..1ccff23a70ae 100644
--- a/gui-libs/vte-common/Manifest
+++ b/gui-libs/vte-common/Manifest
@@ -1,4 +1,6 @@
AUX vte-common-0.70.0-musl-W_EXITCODE.patch 779 BLAKE2B c35f3cd21e59b9693d75b00232ef8b2d95448f4ff7031142050e9286ff854a19095bb56cec471d50585302ac08ca7a1d40ad068c013d8af142b0165d4c8d2112 SHA512 a3dd31fb4fcc9c2e725cfd64bbc63def63c1c1a85b6896b4a82083d6ff985df885c3a587e8c3c001de2acae476cb950f05a1e31b33bb263ba4895d25fa1e275b
DIST vte-0.70.2.tar.bz2 502395 BLAKE2B ae127d8262c7038b3a2cda9a9622e9a075dfc1e06a7710810a4bb894a6646155790776553f663677cb86c3479e6d3faf92c38b5b97dd6970df37cee92dd963fa SHA512 1e113da0591830c057358dd78cfe2f814dd0bfabd037973369266823a9a4936a200b5b23faab3757ced4d08aa96a76d6b1120419815a181598493e35d2ea58d0
+DIST vte-0.70.3.tar.bz2 502706 BLAKE2B 1fee46dee38618137781d62b27730893b0c6969cf3badfa157628621a608983be48e35ef4d8e58099c93b8be91434b257d120cab2e7a943cfecaf37ff7b3fd5d SHA512 5520bc58b0ad2f803da27985e30862de987ecc31c0137895c6945c53f99a7c16ee0281646b9e04362de934364ee7beaa1acf47dad9baf5a16ab9898d5f746d2d
EBUILD vte-common-0.70.2.ebuild 1893 BLAKE2B 44307cc4fcfca5292f2302b263eaf4bf2008053e787f098fce7a46f5013b95261920ccd824c1370282408d1a319ecf3d323ea76050188d0c4b71f6476f513750 SHA512 9d0c60985026894dd7e6343f8ff46c4459ed21c92484edea35590e0d475f6899762404043608fb49053a284d6be2444b28741da3db139d539eb988273854c61e
+EBUILD vte-common-0.70.3.ebuild 1900 BLAKE2B e1a18682d390761d4c865d7dbc33d5a0782e64115a8e04aca28144b618d2e02ee1934f68aa7678ee1720686870ab7a6f10474a3a3bbe87bb17009cf8d406bc32 SHA512 7954594f37c1f041168bc3e9e3261f3962440cfe3900f1fff76d1b6579fa7b9e6fdf05b821e6518743ce24eb70544153e8b42fa835e75bd21abdd00155d2b8f2
MISC metadata.xml 524 BLAKE2B 2a7e14b63adff1385d2a1260d238c0f35854cbd7ba0579a55edf0c6367e37fba80c99fa21b911279c6b7eb7ff4d122f56d02cfc463076614adec2eb059666b68 SHA512 60c71846ff7745c3f3d4c2fb0c9b0214c7fef04d221d2b7e568d1a63b2bff56d49a442072aa5aba48b9247c1a60b1cdf3ca8e3766986e9ef1a38ee659fb65437
diff --git a/gui-libs/vte-common/vte-common-0.70.3.ebuild b/gui-libs/vte-common/vte-common-0.70.3.ebuild
new file mode 100644
index 000000000000..49887bf0c20b
--- /dev/null
+++ b/gui-libs/vte-common/vte-common-0.70.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome.org meson python-any-r1
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91" # vte_api_version in meson.build
+IUSE="systemd"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/vte/-/archive/${PV}/vte-${PV}.tar.bz2"
+
+DEPEND="
+ || ( >=gui-libs/gtk-4.0.1:4 >=x11-libs/gtk+-3.24.22:3 )
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ x11-libs/pango
+"
+RDEPEND="
+ !<x11-libs/vte-0.70.0:2.91
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/vte-${PV}"
+
+src_prepare() {
+ default
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.70.0-musl-W_EXITCODE.patch
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=false
+ -Ddebugg=false
+ -Ddocs=false
+ -Dgir=false
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=false
+ -Dgnutls=false
+ -Dgtk3=false
+ -Dgtk4=false
+ -Dicu=false
+ $(meson_use systemd _systemd)
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ exeinto /usr/libexec/
+ doexe "${BUILD_DIR}"/src/vte-urlencode-cwd
+ insinto /etc/profile.d/
+ newins "${BUILD_DIR}"/src/vte.sh vte-${SLOT}.sh
+ newins "${BUILD_DIR}"/src/vte.csh vte-${SLOT}.csh
+ if use systemd; then
+ insinto /usr/lib/systemd/user/vte-spawn-.scode.d/
+ newins "${S}"/src/vte-spawn-.scope.conf defaults.conf
+ fi
+ einstalldocs
+}