summaryrefslogtreecommitdiff
path: root/gui-libs/vte-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-22 23:18:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-22 23:18:20 +0100
commit820b3cf4687f358703c643bacf3e5a06ccfa4402 (patch)
tree9cb7c40b4ec609b7d07a8ec876bdd3207d132bb9 /gui-libs/vte-common
parentf66a06e8f9736ea679bc3e95d8c8e90ff7c3f466 (diff)
gentoo auto-resync : 22:09:2023 - 23:18:20
Diffstat (limited to 'gui-libs/vte-common')
-rw-r--r--gui-libs/vte-common/Manifest2
-rw-r--r--gui-libs/vte-common/vte-common-0.74.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/gui-libs/vte-common/Manifest b/gui-libs/vte-common/Manifest
index 0a2a2645a507..d8064fc2d098 100644
--- a/gui-libs/vte-common/Manifest
+++ b/gui-libs/vte-common/Manifest
@@ -1,4 +1,6 @@
AUX vte-common-0.70.0-musl-W_EXITCODE.patch 779 BLAKE2B c35f3cd21e59b9693d75b00232ef8b2d95448f4ff7031142050e9286ff854a19095bb56cec471d50585302ac08ca7a1d40ad068c013d8af142b0165d4c8d2112 SHA512 a3dd31fb4fcc9c2e725cfd64bbc63def63c1c1a85b6896b4a82083d6ff985df885c3a587e8c3c001de2acae476cb950f05a1e31b33bb263ba4895d25fa1e275b
DIST vte-0.72.2.tar.bz2 503986 BLAKE2B dbd99a1288176482ebe2cee25a1ae508694a8b47739e9c93aa8f752bf50a1f7a6efd0944430550a73224ac92248e2c4738c51eec66a643efc03616dfa7c4b110 SHA512 0510677d67474fb04c69df0038b042d379ac8e1e89b77961e403b854e4a26b2063e93bcffd75ef0a0a324df077cf2f0a4ce51afa0ad0b1e66f707393590af274
+DIST vte-0.74.0.tar.bz2 505492 BLAKE2B d4f6acd817d1a950032678847c53d4cc720cf33a028078e28eee103591c480603e39eff0a8a517afddd57037ffddb25be9421487651df8d6110cf9743d8e0477 SHA512 36b1af8b41436ed00c889b99b8cab68eb1dd76c8302320d6f6703a19eed4a270faeb91d99ee906ac292da33757c6c89b6c0e54c1a224792b5424007b2879a966
EBUILD vte-common-0.72.2.ebuild 1894 BLAKE2B d9f1b80c18eb9811b0add869e56d5c3ba90bc4637a1f2f237a260f56ef120e3f2ce8a225934b1ddd9907d00bc3b4d27815bb853df5bcdf2bbec6f500621b9b01 SHA512 e40ca8b67b98526aef8fc16448cfcfab6604b3c9d57440c2d05c31adb5bb0b1f35dc55f5bb152727e40156633a8c69396abbe112c1fa379cbaa91b6a5f16c373
+EBUILD vte-common-0.74.0.ebuild 1923 BLAKE2B e75bfbff282f27b59e105d11a89b49235f6ef9185f825095ab3898c177eaee6c805dbbe4cbb1c4884434ec70ef11089a2d776712ceb297919259666ca2efdc0d SHA512 ad77f8f69833f3a968c2c2eb772b7c216e7a368d024125ba545ec0881e1f1b0cac27dcfbd76df63b5984a75943ee309f7e6ddd0137b0498342397356e2933c67
MISC metadata.xml 549 BLAKE2B 8dc2d9f7cd740c190e9c59b5c658181b92d916f219696291dfff4c3615d91fed087654251558dfef0c70af271ad4d8847ce9ca24d80f77d4d58c33dd31904a16 SHA512 530fecebff3bfde9dd98bf9572351aa0de09acbbe354bf74d504d4985232a2f31d6a967812a8ac8ee5a3ae3402779a32dd686e12376ce06006846ca326103e73
diff --git a/gui-libs/vte-common/vte-common-0.74.0.ebuild b/gui-libs/vte-common/vte-common-0.74.0.ebuild
new file mode 100644
index 000000000000..53f88fb7cf2c
--- /dev/null
+++ b/gui-libs/vte-common/vte-common-0.74.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit gnome.org meson python-any-r1
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91" # vte_api_version in meson.build
+IUSE="systemd"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/vte/-/archive/${PV}/vte-${PV}.tar.bz2"
+
+DEPEND="
+ || ( >=gui-libs/gtk-4.0.1:4 >=x11-libs/gtk+-3.24.22:3 )
+ >=x11-libs/cairo-1.0
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.60:2
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ x11-libs/pango
+"
+RDEPEND="
+ !<x11-libs/vte-0.70.0:2.91
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/vte-${PV}"
+
+src_prepare() {
+ default
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.70.0-musl-W_EXITCODE.patch
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=false
+ -Ddebugg=false
+ -Ddocs=false
+ -Dgir=false
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=false
+ -Dgnutls=false
+ -Dgtk3=false
+ -Dgtk4=false
+ -Dicu=false
+ $(meson_use systemd _systemd)
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ exeinto /usr/libexec/
+ doexe "${BUILD_DIR}"/src/vte-urlencode-cwd
+ insinto /etc/profile.d/
+ newins "${BUILD_DIR}"/src/vte.sh vte-${SLOT}.sh
+ newins "${BUILD_DIR}"/src/vte.csh vte-${SLOT}.csh
+ if use systemd; then
+ insinto /usr/lib/systemd/user/vte-spawn-.scode.d/
+ newins "${S}"/src/vte-spawn-.scope.conf defaults.conf
+ fi
+ einstalldocs
+}