summaryrefslogtreecommitdiff
path: root/gui-libs/vte-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-05 21:37:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-05 21:37:49 +0100
commit50c291a3ace58006f8fa9cf44a36f6e42bff2b54 (patch)
tree6d245677a5bb2d38b74c141346e35465540e9b7f /gui-libs/vte-common
parent53623081143d09702d8f3d7224e9da8c5f681c3b (diff)
gentoo auto-resync : 05:06:2023 - 21:37:49
Diffstat (limited to 'gui-libs/vte-common')
-rw-r--r--gui-libs/vte-common/Manifest2
-rw-r--r--gui-libs/vte-common/vte-common-0.72.2.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/gui-libs/vte-common/Manifest b/gui-libs/vte-common/Manifest
index 8771ff96cea7..f90716b19276 100644
--- a/gui-libs/vte-common/Manifest
+++ b/gui-libs/vte-common/Manifest
@@ -1,4 +1,6 @@
AUX vte-common-0.70.0-musl-W_EXITCODE.patch 779 BLAKE2B c35f3cd21e59b9693d75b00232ef8b2d95448f4ff7031142050e9286ff854a19095bb56cec471d50585302ac08ca7a1d40ad068c013d8af142b0165d4c8d2112 SHA512 a3dd31fb4fcc9c2e725cfd64bbc63def63c1c1a85b6896b4a82083d6ff985df885c3a587e8c3c001de2acae476cb950f05a1e31b33bb263ba4895d25fa1e275b
DIST vte-0.72.1.tar.bz2 504271 BLAKE2B 8ab39ab8d491757ab9402ad4bfc10ca733427d2efe895204c0db580e44107a9ab005c29ce2e6934ae27e8da7c27e39d1173fe787ddb8569938a29697eed2e2e1 SHA512 a5655d2d2602183cbda1050003d7cf883e427c8e00976af4ee2685f43530d87169e31a3b9597133d14dffdc95f20f9ca1488186d8463997a2672510f5a95d145
+DIST vte-0.72.2.tar.bz2 503986 BLAKE2B dbd99a1288176482ebe2cee25a1ae508694a8b47739e9c93aa8f752bf50a1f7a6efd0944430550a73224ac92248e2c4738c51eec66a643efc03616dfa7c4b110 SHA512 0510677d67474fb04c69df0038b042d379ac8e1e89b77961e403b854e4a26b2063e93bcffd75ef0a0a324df077cf2f0a4ce51afa0ad0b1e66f707393590af274
EBUILD vte-common-0.72.1.ebuild 1893 BLAKE2B 8af6a8a9c3e61640c5b8197e7172f7d5ff02a6c74c5ea18f9d041e1bc0a7f518a92dc79ea50adacd4ca3d6ebf2e912e9711b3383cae7a1e77ee13547b8ff4c1f SHA512 6b0303ceaf501e2a5fcc9f640a59f1b968c440636bcedd2f03604a3c3f4c8d6f6d14cc3c654240dea2bfc616894ef053aa41cfb87a1cd6196363c0edd0934ccb
+EBUILD vte-common-0.72.2.ebuild 1901 BLAKE2B bf7357973de7c22c5e26b7cf49f71e4433d57ce96415d7ef2a2fb138926f78697e277ddecef78bc6d302d7c918292ebad34dcc18a8d0d93aa23bf92eaacb2e5e SHA512 a122512358fe07f48b5bc4227885c02e853df2c9dc08e190bff6bafe6bdf681f4ef587da04bf2270596503343aa715e6ccc952380b9168f8ed62bc1250d8c5a2
MISC metadata.xml 524 BLAKE2B 2a7e14b63adff1385d2a1260d238c0f35854cbd7ba0579a55edf0c6367e37fba80c99fa21b911279c6b7eb7ff4d122f56d02cfc463076614adec2eb059666b68 SHA512 60c71846ff7745c3f3d4c2fb0c9b0214c7fef04d221d2b7e568d1a63b2bff56d49a442072aa5aba48b9247c1a60b1cdf3ca8e3766986e9ef1a38ee659fb65437
diff --git a/gui-libs/vte-common/vte-common-0.72.2.ebuild b/gui-libs/vte-common/vte-common-0.72.2.ebuild
new file mode 100644
index 000000000000..5ea36a8149ca
--- /dev/null
+++ b/gui-libs/vte-common/vte-common-0.72.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org meson python-any-r1
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91" # vte_api_version in meson.build
+IUSE="systemd"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/vte/-/archive/${PV}/vte-${PV}.tar.bz2"
+
+DEPEND="
+ || ( >=gui-libs/gtk-4.0.1:4 >=x11-libs/gtk+-3.24.22:3 )
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.60:2
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ x11-libs/pango
+"
+RDEPEND="
+ !<x11-libs/vte-0.70.0:2.91
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/vte-${PV}"
+
+src_prepare() {
+ default
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.70.0-musl-W_EXITCODE.patch
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=false
+ -Ddebugg=false
+ -Ddocs=false
+ -Dgir=false
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=false
+ -Dgnutls=false
+ -Dgtk3=false
+ -Dgtk4=false
+ -Dicu=false
+ $(meson_use systemd _systemd)
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ exeinto /usr/libexec/
+ doexe "${BUILD_DIR}"/src/vte-urlencode-cwd
+ insinto /etc/profile.d/
+ newins "${BUILD_DIR}"/src/vte.sh vte-${SLOT}.sh
+ newins "${BUILD_DIR}"/src/vte.csh vte-${SLOT}.csh
+ if use systemd; then
+ insinto /usr/lib/systemd/user/vte-spawn-.scode.d/
+ newins "${S}"/src/vte-spawn-.scope.conf defaults.conf
+ fi
+ einstalldocs
+}