summaryrefslogtreecommitdiff
path: root/gui-libs/tepl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /gui-libs/tepl
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'gui-libs/tepl')
-rw-r--r--gui-libs/tepl/Manifest3
-rw-r--r--gui-libs/tepl/metadata.xml8
-rw-r--r--gui-libs/tepl/tepl-4.2.0.ebuild54
3 files changed, 65 insertions, 0 deletions
diff --git a/gui-libs/tepl/Manifest b/gui-libs/tepl/Manifest
new file mode 100644
index 000000000000..ca1f72f58f81
--- /dev/null
+++ b/gui-libs/tepl/Manifest
@@ -0,0 +1,3 @@
+DIST tepl-4.2.0.tar.xz 456540 BLAKE2B 8861d2cdcddcb5b9e5aa58798835c0969dd12ce6c5ada69b5b97224f215bfdbf8ee0a7173d5c7cb2cc11894988351ce4df7a81e91e7b7036a48cc89e2cb9dd62 SHA512 32f69c6f0942a82e6b7f94eba776d55dce2af1c8e4c7abadf6af38a0a5abb0a94f0c426d5ec727b8eb478406ba113728b771597c2c84e508b8ccb113a74eab3d
+EBUILD tepl-4.2.0.ebuild 1358 BLAKE2B 8057ab6dc74a34cfbe58eda3870ff50959cb76a3c2614854329b48d48f7948dcc5b7002c06d283d85da4f2a18902ed45cddf17b3f317ed0eccee2ce1fd07abae SHA512 69056d30678f3713c255c42d32c075e212b4e0e2b2dd33092b82d654a0fc01a9da6dd42ab25605dab1ae8f248924f75a85003689ce73049edde3bfb1db81879f
+MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/gui-libs/tepl/metadata.xml b/gui-libs/tepl/metadata.xml
new file mode 100644
index 000000000000..996e7cacd217
--- /dev/null
+++ b/gui-libs/tepl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-libs/tepl/tepl-4.2.0.ebuild b/gui-libs/tepl/tepl-4.2.0.ebuild
new file mode 100644
index 000000000000..0837cfd954ba
--- /dev/null
+++ b/gui-libs/tepl/tepl-4.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 virtualx
+
+DESCRIPTION="GtkSourceView-based text editors and IDE helper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gtef"
+
+LICENSE="LGPL-2.1+"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0:4[introspection?]
+ >=gui-libs/amtk-5.0:5[introspection?]
+ >=dev-libs/libxml2-2.5:2
+ app-i18n/uchardet
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${DEPEND}
+ >=sys-devel/gettext-0.19.4
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ # requires running gvfs-metadata
+ sed -e 's:\(g_test_add_func.*/file/load_save_metadata_sync.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/file/load_save_metadata_async.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/file/set_without_load.*\):/*\1*/:' \
+ -i testsuite/test-file-metadata.c || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # valgrind checks not ran by default and require suppression files not in locations where they'd be installed by other packages
+ gnome2_src_configure \
+ --enable-gvfs-metadata \
+ --disable-valgrind \
+ $(use_enable introspection)
+}
+
+src_test() {
+ virtx emake check
+}