summaryrefslogtreecommitdiff
path: root/gui-libs/tepl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /gui-libs/tepl
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'gui-libs/tepl')
-rw-r--r--gui-libs/tepl/Manifest2
-rw-r--r--gui-libs/tepl/tepl-4.2.1.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/gui-libs/tepl/Manifest b/gui-libs/tepl/Manifest
index 3225acae612a..a3eaf2bbd387 100644
--- a/gui-libs/tepl/Manifest
+++ b/gui-libs/tepl/Manifest
@@ -1,3 +1,5 @@
DIST tepl-4.2.0.tar.xz 456540 BLAKE2B 8861d2cdcddcb5b9e5aa58798835c0969dd12ce6c5ada69b5b97224f215bfdbf8ee0a7173d5c7cb2cc11894988351ce4df7a81e91e7b7036a48cc89e2cb9dd62 SHA512 32f69c6f0942a82e6b7f94eba776d55dce2af1c8e4c7abadf6af38a0a5abb0a94f0c426d5ec727b8eb478406ba113728b771597c2c84e508b8ccb113a74eab3d
+DIST tepl-4.2.1.tar.xz 464120 BLAKE2B 74146cdf837923ab1a8e843e189bd83b2c7d7ae9cbf03ce4f3dbbbbfee1f47dffcda537ad8133cdf1b4efd747f0ee60092ddab029a67282b71fdc52d51564dc4 SHA512 c1b848cf1d336efdc2971e16060baf721e9019e6e6827bd755235c9dd37ae47803343e51888d9dd5817b6127bb1ba05a19d4a1be0caab9d2de125bc0cd8175a7
EBUILD tepl-4.2.0.ebuild 1361 BLAKE2B e6ff837f68cc2f8dd66448dd8878499faca11166de512352eb12957c910872d01febd43bc6d2019f1e1338bc6727e61f865a4f4c75144aa1b964bc4ddedcac8c SHA512 2a13898ac148f043948918a5215bdf01b06f7a20075c91bd342d4665331e1b94d584f9e8059751f92911c575eb2a94262d0becb75b4f762687a639658752183f
+EBUILD tepl-4.2.1.ebuild 1363 BLAKE2B 82274a0413fba4f62d97b121e88abc46d8466423ed229ffe4f396eec88aa8bafca59ca6868ca92e27e73fecc56f4d4492965a448bb0d1b5b764cf45ca2bec2f3 SHA512 42aad96875eda3dafd119c7b428c5ff8109aa62121fb8d972b1d0101f1fc8b48956d577b67ea3cbb8a0f7117c4279d96f22919fb534283679ded0a22a96ae714
MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/gui-libs/tepl/tepl-4.2.1.ebuild b/gui-libs/tepl/tepl-4.2.1.ebuild
new file mode 100644
index 000000000000..61989b5579ba
--- /dev/null
+++ b/gui-libs/tepl/tepl-4.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 virtualx
+
+DESCRIPTION="GtkSourceView-based text editors and IDE helper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gtef"
+
+LICENSE="LGPL-2.1+"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0:4[introspection?]
+ >=gui-libs/amtk-5.0:5[introspection?]
+ >=dev-libs/libxml2-2.5:2
+ app-i18n/uchardet
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${DEPEND}
+ >=sys-devel/gettext-0.19.4
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ # requires running gvfs-metadata
+ sed -e 's:\(g_test_add_func.*/file/load_save_metadata_sync.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/file/load_save_metadata_async.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/file/set_without_load.*\):/*\1*/:' \
+ -i testsuite/test-file-metadata.c || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # valgrind checks not ran by default and require suppression files not in locations where they'd be installed by other packages
+ gnome2_src_configure \
+ --enable-gvfs-metadata \
+ --disable-valgrind \
+ $(use_enable introspection)
+}
+
+src_test() {
+ virtx emake check
+}