summaryrefslogtreecommitdiff
path: root/gui-libs/hyprutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-26 00:12:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-26 00:12:24 +0100
commit9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (patch)
tree2d53ee03e360a9c66a5d8dd8986eee286514336b /gui-libs/hyprutils
parent996a2bda06cb164877d5d952774a6db1b271c2f3 (diff)
gentoo auto-resync : 26:06:2024 - 00:12:24
Diffstat (limited to 'gui-libs/hyprutils')
-rw-r--r--gui-libs/hyprutils/Manifest4
-rw-r--r--gui-libs/hyprutils/hyprutils-0.1.4.ebuild26
-rw-r--r--gui-libs/hyprutils/hyprutils-9999.ebuild26
-rw-r--r--gui-libs/hyprutils/metadata.xml10
4 files changed, 66 insertions, 0 deletions
diff --git a/gui-libs/hyprutils/Manifest b/gui-libs/hyprutils/Manifest
new file mode 100644
index 000000000000..5eda56b90c05
--- /dev/null
+++ b/gui-libs/hyprutils/Manifest
@@ -0,0 +1,4 @@
+DIST hyprutils-0.1.4.gh.tar.gz 16561 BLAKE2B 90c435f892015791a88870613235204e39e0e41cbeea00a8f21d7f0c84dd2cbe733604da9830334e4f21a0d57d21aa770cc69dc5a34c9324e673d1c86e732606 SHA512 78b1ad188579b7ba9fb32f08aa3da6e96ec18544a1802d144cee9f64f473b6ee41a4cb3fba971524cfbf448e6cbe0aa32c36f53e8d50cbdf926126a9a44da8b6
+EBUILD hyprutils-0.1.4.ebuild 715 BLAKE2B 6475e82b2b356baccfc340c68ddf294e8f33f5bd71b748f6826961a628501b39f4f083ac955a4f671e03bd521f4cabd9e896f4b2df6608a93c0b04c6da680a30 SHA512 82d188f0a67491151ddbdec6420d94a8fc1ecab4cc07a7da4e09e11a10a32cb860a4b7530a82d94a7e952df4f30c85b03ac56cd171d50c881ed1765249d38652
+EBUILD hyprutils-9999.ebuild 715 BLAKE2B 6475e82b2b356baccfc340c68ddf294e8f33f5bd71b748f6826961a628501b39f4f083ac955a4f671e03bd521f4cabd9e896f4b2df6608a93c0b04c6da680a30 SHA512 82d188f0a67491151ddbdec6420d94a8fc1ecab4cc07a7da4e09e11a10a32cb860a4b7530a82d94a7e952df4f30c85b03ac56cd171d50c881ed1765249d38652
+MISC metadata.xml 383 BLAKE2B 74ae8927a46a999fefe3af4558f10647f5a8793db7244626f0535c76bdacb3b902fb9186c86d076d783bc41bcb3730bf89e1ca7aaefdc66cf53fce7610e4ab6b SHA512 773e25ec47b3a766d3914f0f71ae03a69438cdc876f97fa1eecde4f09d36dec410af6d956cec86c9c26d176ce721def701467d2078f9afacbc25503e0c8297e8
diff --git a/gui-libs/hyprutils/hyprutils-0.1.4.ebuild b/gui-libs/hyprutils/hyprutils-0.1.4.ebuild
new file mode 100644
index 000000000000..d7a92f59830e
--- /dev/null
+++ b/gui-libs/hyprutils/hyprutils-0.1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Hyprland utilities library used across the ecosystem"
+HOMEPAGE="https://github.com/hyprwm/hyprutils"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"
diff --git a/gui-libs/hyprutils/hyprutils-9999.ebuild b/gui-libs/hyprutils/hyprutils-9999.ebuild
new file mode 100644
index 000000000000..d7a92f59830e
--- /dev/null
+++ b/gui-libs/hyprutils/hyprutils-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Hyprland utilities library used across the ecosystem"
+HOMEPAGE="https://github.com/hyprwm/hyprutils"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"
diff --git a/gui-libs/hyprutils/metadata.xml b/gui-libs/hyprutils/metadata.xml
new file mode 100644
index 000000000000..bbf6d06daf66
--- /dev/null
+++ b/gui-libs/hyprutils/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <changelog>https://github.com/hyprwm/hyprutils/releases</changelog>
+ <bugs-to>https://github.com/hyprwm/hyprutils/issues</bugs-to>
+ <remote-id type="github">hyprwm/hyprutils</remote-id>
+ </upstream>
+</pkgmetadata>