summaryrefslogtreecommitdiff
path: root/gui-libs/gtksourceview
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-21 17:26:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-21 17:26:21 +0100
commit1c724102ee86c2c9fc156106acc870f69a4764c3 (patch)
tree764c8508307b679f73b5da39393ff9f98a89f2d6 /gui-libs/gtksourceview
parent944021dc3fb629a9c074228bf7da9f7ddf7a0caa (diff)
gentoo auto-resync : 21:09:2022 - 17:26:21
Diffstat (limited to 'gui-libs/gtksourceview')
-rw-r--r--gui-libs/gtksourceview/Manifest2
-rw-r--r--gui-libs/gtksourceview/gtksourceview-5.6.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/gui-libs/gtksourceview/Manifest b/gui-libs/gtksourceview/Manifest
index c0140f1bb755..25a9f07b052f 100644
--- a/gui-libs/gtksourceview/Manifest
+++ b/gui-libs/gtksourceview/Manifest
@@ -1,4 +1,6 @@
AUX 5-gentoo.lang 3898 BLAKE2B a47c411fa650a53cb9176c3b670b5189ea9ee0c268d09444e08756f49d1d73c14c9505a19d9354671254cbfe0bfdc69545c3d5b761998037ab2ec57ce58bb2d7 SHA512 fffb635074ed0de4cedb3836f37322c7b9b58b65e91a014b72bd6a41bcaf195f0b25d4031d65d60fa5abd1c7f4f5aaf19d61a77eb91ab6f59df814dacf0a0595
DIST gtksourceview-5.4.2.tar.xz 1261496 BLAKE2B 3c7447de6d252c7fbccd5fb18222aeb25cd264b53847d3fb45a5b30a528d3a850d059f226a696e9d8462085910c67e318be10de89c0e7a554787fb25f27a6674 SHA512 eef5267bd473327f4e3e7b79d4a96c53067e221e9f171dde864a7866ccab8258ca9e13b5f59e40272fd7e3acd9e1e08bb4bea3674fa2864ec108b4a47220e9d3
+DIST gtksourceview-5.6.0.tar.xz 1266084 BLAKE2B b633de2abaa8476ae86cb4ec7b1bf4e1c48077f2674988b3ba807cb02c1b4ccc792325ddc3c2e1333d3f373371b378f8e2fa73089279d48b825267370af9d6a0 SHA512 f1dd7dc236b30ca540f033dd7ffdb2715375854d22ae69d7229dc525ea54f5319408624497d7c0c4b7b8e14a2c8a6b992721fe397171b62efab48b5a38509df9
EBUILD gtksourceview-5.4.2.ebuild 1837 BLAKE2B 9d0e8e7e9c1c70f23fa4a084ca6ffc889852f6089a65a77b5c2f01824325eb4d46df77b0f19e5fdc3c8ae8b5b024f8550e218bddc0e383d0e8f9def708153afa SHA512 9b8046f6adbc152d196cb61da8d030fd5695780498d37a28cfafa300358a8ca81885a8d6cb42d45a683e5b9b59dcbb74b76ed9546c8d3d6b77cbb6b42226dfda
+EBUILD gtksourceview-5.6.0.ebuild 1840 BLAKE2B d8c52b66fc18c229ac48d9bc02988a9e03ae6d82bf17700686fe618b7224e5afdfd22436bde598035250bb2af6988563b0c41b4e6809c9c37a325457d663b545 SHA512 4dad09a9d221bed4f56a5b9dfd8ee665c5051e28357bebbc2223ec92a0b46b8e5a43719a916c8f5f83a951e5d2ced88c3de31e37749e42e41cf5c9ce6853bafb
MISC metadata.xml 372 BLAKE2B b688307985302494fc956df801d7ab8e4ac52ede6baec476031c31cabc013df8f0846ca3a0d67b613d4f3ba80edf69631f4d15bb43cadba82ecb1468b558651a SHA512 33dbeb75d42b8d42953d1db99e286baa90b0c7a2e6a93e945e2c1e2cb0287445aeef287bc41d44a53fcc243529880c237cf1acedc4962ee5ef5cc1e6424e102c
diff --git a/gui-libs/gtksourceview/gtksourceview-5.6.0.ebuild b/gui-libs/gtksourceview/gtksourceview-5.6.0.ebuild
new file mode 100644
index 000000000000..ff010dbd6254
--- /dev/null
+++ b/gui-libs/gtksourceview/gtksourceview-5.6.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx xdg
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+
+IUSE="gtk-doc +introspection sysprof +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.72:2
+ >=gui-libs/gtk-4.6:4[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ introspection? ( >=dev-libs/gobject-introspection-1.70.0:= )
+ >=dev-libs/fribidi-0.19.7
+ media-libs/fontconfig
+ x11-libs/pango[introspection?]
+ >=dev-libs/libpcre2-10.21:=[-recursion-limit(-)]
+ sysprof? ( dev-util/sysprof-capture:4 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gi-docgen )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dinstall_tests=false
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use sysprof)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Tests fail in test-regex with libpcre2[recursion-limit] - https://gitlab.gnome.org/GNOME/gtksourceview/-/issues/255
+ # Ensured OK via USE dep, as it would mean issues in real usage for syntax highlighting as well
+ virtx meson_src_test --timeout-multiplier=2
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/${PN}-5/language-specs
+ newins "${FILESDIR}"/5-gentoo.lang gentoo.lang
+
+ if use gtk-doc ; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}${SLOT} "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}